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Managing Digital Signage and Enterprise TV 

Revised: March 17, 2008, OL-15762-02 
Activation Software feature modules for Cisco DMS are purchased and licensed separately. Features are hidden from all users until you purchase and install the required license to use them, and even 
then remain hidden from users whose privilege levels are low. To understand feature licenses and learn how to install them, see Managing Licenses for Features and Components of Cisco DMS, page 2-
3. To learn how user access to features is restricted by the combination of licenses and user privilege levels, see Understanding User Roles in DMS-Admin, page 2-9. To learn which software feature 
modules are available for you to purchase, see http://www.cisco.com/go/dms. 

• Overview 
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• Using Advanced Tasks 

• Stopping All Running Events and Commands on DMPs 

• Enabling and Disabling Troubleshooting Access on DMPs 

• Upgrading the Firmware or Kernel on DMPs 

• Planning for and Responding to Emergencies 

• Scheduling Time Slots for Media and Events on DMPs 

• Using Administrative Options 

• Common Scenarios for Using DMM-DSM 

• Integrating Third-party Applications with DMM-DSM 

Overview 
The separately-licensed DMM software modules for digital signage (DMM-DSM) and Enterprise TV (DMM-ETV) consolidate certain features and interoperate in other ways. The privileges that your Cisco DMS administrator has 
granted to your username determine which features and user interface (UI) elements you are permitted to see and use in these modules. 

• Features of DMM-DSM provide a flexible environment in which to create, manage, and run a digital signage network. Simple but powerful design and publishing features help you to create content libraries and deliver 
presentations for digital signage, while centralized management features help you to manage a global IP network of DMP displays for any purpose in conference rooms, public venues, or executive offices. Used well, DMM-
DSM can help your organization to enhance customer experience, entertain, and inform. 
• Features of DMM-ETV help your organization to deliver video-on-demand and live broadcast TV channels over your global IP network of DMP displays in conference rooms, public venues, or executive offices. You can 
search the interactive on-screen menus and program guides, and then show live news, financial information, sales and marketing messages, educational or training content for classrooms, corporate communications, 
entertainment, or any other type of content that is suitable for your purpose. Alternatively, hospitality and healthcare providers might use enterprise TV features in support of in-room IPTV. 

Tip The firmware for DMPs provides a web-based "craft interface" to manage one DMP in isolation. This software is called Digital Media Player Device Manager, or DMPDM. To learn about DMPDM, check the printed quick 
start guide that shipped in the product kit with your DMP or check the corresponding version of the User Guide for DMPDM on Cisco.com. 

Related Topics 
• Starting DMM-DSM 

• Starting DMM-ETV 

• Configuring User Rights and Permissions for Digital Signage and Enterprise TV 

Starting DMM-DSM 
Procedure 

Step 1 If you just logged in to DMM or if you have been using features of a software module that is not related to digital signage, do one of the following: 

• On the DMM dashboard, click Digital Signage. 

• Choose Digital Signage from the global navigation. 

Related Topics 
• Configuring User Rights and Permissions for Digital Signage and Enterprise TV 

Starting DMM-ETV 
Procedure 

Step 1 If you just logged in to DMM or if you have been using features of a software module that is not related to Enterprise TV, do one of the following: 

• On the DMM dashboard, click Enterprise TV. 

• Choose Enterprise TV from the global navigation. 

The TV Channels tab is preselected by default. To understand elements on this tab, see UI Reference: Elements to Manage TV Channels. 

Related Topics 
• Configuring User Rights and Permissions for Digital Signage and Enterprise TV 

• Configuring the Settings for Enterprise TV 
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Working with Dashboard Gauges for Digital Signage and Enterprise TV 
DMM-DSM and DMM-ETV share a dashboard that shows various gauges. This shared dashboard summarizes and centralizes all features for monitoring DMPs, schedules, assets, and settings for content delivery. Gauge data 
is not updated in real time; you must refresh your browser to refresh the data. 
If problems of any kind interfere with the data-collection processes that populate these gauges, they will show question marks in addition to the best data that is available. 
Click the Dashboard tab to load this dashboard in your browser. 

Tip Click + or - in the title bar for a gauge to expand or collapse it. 
 
Drag a gauge by its title bar to rearrange the dashboard. All gauges are made wide that load on the left side of the dashboard, and all gauges are made narrow that load on the right side. 

• Working with the Media and Schedules Gauge 

• Understanding and Using the Digital Media Players Gauge 

• Understanding and Using the Enterprise TV Gauge 

• Understanding and Using the Settings Gauge 

Working with the Media and Schedules Gauge 
The Media and Schedules gauge represents differing types of data on its left and right sides. 

• Understanding the Left Side of the Media and Schedules Gauge 

• Using the Left Side of the Media and Schedules Gauge 

• UI Reference: Elements on the Right Side of the Media and Schedules Gauge 

• Using the Right Side of the Media and Schedules Gauge 

Understanding the Left Side of the Media and Schedules Gauge 
The left side of the Media and Schedules gauge shows a read-only version of the deployment schedule that digital signage and Enterprise TV share. You can browse through the schedule timeline here and increase or 
decrease the magnification level for the range of hours that the gauge shows without your ever scrolling. 

Figure 3-1 The Left Side of the Media and Schedules Gauge 

This gauge describes only the midnight-to-midnight, 24-hour schedule for today. You can center it on the current hour and you can filter it to show only the events that are scheduled for a particular DMP group. 
Related Topics 

• Using the Left Side of the Media and Schedules Gauge 

• Understanding and Using the Digital Media Players Gauge 
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• Understanding and Using the Enterprise TV Gauge 

• Understanding and Using the Settings Gauge 

Using the Left Side of the Media and Schedules Gauge 
Before You Begin 
You must be logged in an administrator or as a user who has at least read-only permissions for the schedule. 
Procedure 

Step 1 Do any of the following: 

• Click Now to center the timeline on the current hour. 

• Move the slider left or right to adjust magnification of the schedule timeline: 

– The far left position "zooms out" to show schedule magnification in 6-hour increments. 
– The far right position "zooms in" to show schedule magnification in 5-minute increments. 

• If your browser window is small enough that it shows a horizontal scrollbar above the timeline, use this scrollbar to scroll the timeline left or right, where left is earlier in the day and right is later in the day. 

Related Topics 
• Understanding the Left Side of the Media and Schedules Gauge 

• Working with Future Deployments 

• Understanding and Using the Digital Media Players Gauge 

• Understanding and Using the Enterprise TV Gauge 

• Understanding and Using the Settings Gauge 

UI Reference: Elements on the Right Side of the Media and Schedules Gauge 
The right side of the Media and Schedules gauge counts and categorizes assets of various types that are saved in your media library, and also counts the playlists and presentations that are saved. In addition, it shows 
10 categorized shortcuts. 

Figure 3-2 The Right Side of the Media and Schedules Gauge 

Shortcut Description 
 
All Digital Signage area 

All Digital Signage Shows the sum total count of how many assets, presentations, and playlists are saved. 
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Presentations Counts the number of presentations that your organization has designed and saved in DMD. 
Also, a shortcut to Digital Signage > Presentations. 
The dashboard does not show this information to you unless you are logged in as an administrator or as a user with sufficient permissions to 
see presentations. 

Playlists Counts the number of ordinary playlists that your organization has populated and saved in DMM-DSM. 
Also, a shortcut to selecting Digital Signage > Playlists. 
The dashboard does not show this information to you unless you are logged in as an administrator or as a user with sufficient permissions to see playlists. 

Create Presentation A shortcut that starts Digital Media Designer. See Getting Started with DMD. 

The dashboard does not show this information to you unless you are logged in as an administrator or as a user with sufficient permissions to 
create presentations. 

 
All Assets area 

• HTML 
• IMAGES 
• UDP  
• FIRMWARE 
• FLASH 
• VIDEO 

Counts how many assets of each type are saved in the digital signage and Enterprise TV share in common. 
Also, shortcuts that open your media library, filtering the result to describe assets of only the specified type. 
The dashboard does not show this information to you unless you are logged in as an administrator or as a user with sufficient permissions to see assets in 
the media library. 

Add Asset Opens the Add Asset dialog box, from which you can add assets to your media library. 
The dashboard does not show this information to you unless you are logged in as an administrator or as a user with sufficient permissions to add assets to 
at least one category within the media library. 

 
Related Topics 

• Using the Right Side of the Media and Schedules Gauge 

• Understanding and Using the Digital Media Players Gauge 

• Understanding and Using the Enterprise TV Gauge 

• Understanding and Using the Settings Gauge 

Using the Right Side of the Media and Schedules Gauge 
Procedure 

Step 1 Do any of the following: 

• Click Presentation to go directly to the page at Digital Signage > Presentations. 

• Click Playlist to go directly to the page at Digital Signage > Playlist. 

• Click Create Presentation to start Digital Media Designer. 

• Click HTML to open the media library, filtering the result to describe only HTML URLs. 

• Click IMAGES to open the media library, filtering the result to describe only image files. 

• Click UDP to open the media library, filtering the result to describe only UDP URLs. 

• Click FIRMWARE to open the media library, filtering the result to describe only DMP firmware. 

• Click FLASH to open the media library, filtering the result to describe only SWF files. 

• Click VIDEO to open the media library, filtering the result to describe only MPEG videos. 

Related Topics 
• UI Reference: Elements on the Right Side of the Media and Schedules Gauge 

• Understanding and Using the Digital Media Players Gauge 
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• Understanding and Using the Enterprise TV Gauge 

• Understanding and Using the Settings Gauge 

Understanding and Using the Digital Media Players Gauge 
The Digital Media Players gauge shows a colored bar chart to summarize the health of registered DMPs in your network and counts the number of configured DMP groups. 

• The color green represents registered DMPs that are reachable. 
• The color red represents registered DMPs that are unreachable. A registered DMP might become unavailable if it receives a new dynamic IP address from the DHCP server at its deployment site. In this case, you 
should restart the DMP or edit the IP address record that DMM-DSM maintains for the DMP. 

Figure 3-3 The Digital Media Players Gauge 

Tip The interval between DMP polling cycles is 5 minutes, so any newly added DMP might report temporarily that it is unavailable; wait a few minutes if this happens to you, and then check again. If you notice that any of 
your DMPs are unreachable, see FAQs and Troubleshooting Guide for Cisco Digital Media System 4.x and 5.x on Cisco.com. 
 
To check the free space on the SD memory card in a DMP, choose Digital Media Players > DMP Manager, and then — in the row that describes that DMP — check the value in the Internal Storage MB. (Total/
Free) column. Alternatively, log in to the local instance of DMPDM on that DMP, and then click Internal Storage. 

Note DHCP servers at your deployment sites should be configured to expire leased IP addresses for DMPs only when DMPs are restarted. A registered DMP might become unavailable for centralized management if it 
receives a new dynamic IP address from the DHCP server at its deployment site. In this case, you should restart the DMP or edit the IP address record that DMM-DSM maintains for the DMP. 

Before You Begin 
You must be logged in as an administrator or as a user with sufficient permissions to see at least one DMP or one DMP group. 
Procedure 

Step 1 Click View All DMPs and DMP Groups to learn more. 

Related Topics 
• Managing and Grouping Your DMPs 

• Working with the Media and Schedules Gauge 

• Understanding and Using the Enterprise TV Gauge 

• Understanding and Using the Settings Gauge 

Understanding and Using the Enterprise TV Gauge 
The Enterprise TV gauge shows whether Enterprise TV is configured and tells you whether the most recent synchronization succeeded with your 
preferred EPG provider. 

Figure 3-4 The Enterprise TV Gauge 
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Procedure 

Step 1 Click Manage ETV to learn more. 

Related Topics 
• Configuring the Settings for Enterprise TV 

• Working with the Media and Schedules Gauge 

• Understanding and Using the Digital Media Players Gauge 

• Understanding and Using the Settings Gauge 

Understanding and Using the Settings Gauge 
The Settings gauge summarizes the most basic attributes of configured settings for your DMM appliance and your content delivery network, which might use ACNS or WAAS. 

Figure 3-5 The Settings Gauge 

Procedure 

Step 1 Click Manage Settings to learn more. 

Related Topics 
• Working with the Media and Schedules Gauge 

• Understanding and Using the Digital Media Players Gauge 

• Understanding and Using the Enterprise TV Gauge 

• Configuring DMM-DSM Server Settings 

• Configuring the Settings to Use ACNS or WAAS 

Configuring Your DMPs to Support Centralized Management 
You must configure your DMPs to recognize the authority of your DMM appliance, so that you can manage them centrally in DMM-DSM. This process occurs automatically when you autoregister DMPs, but if autoregistration is 
somehow not suitable, such as for testing purposes, you can also perform the required steps manually. 
DMM-DSM and your DMPs communicate over TCP port 7777 when centralized management is enabled. 

Caution To stop untrusted DMM appliances from being able to seize control of your DMPs, you must configure your network firewall to restrict which devices you will permit to send inbound traffic to your DMP over 
TCP port 7777. If you do not know how to work with access control lists, see the manufacturer documentation for your firewall. 

Caution The DMPDM login username by default is admin and the password by default is default. However, we urged you to change both of these when you set up your DMPs, because they are well known 
and constitute a security vulnerability in your network. To learn how to change the login credentials if you skipped that essential step during setup, see the quick start guide on Cisco.com for your DMP model type. 

Procedure 

Step 1 Point your browser to the IP address of a DMP that you will manage centrally. 

Step 2 At the DMPDM login prompt, enter the username and the password that you configured for the DMP. 
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Note All DMPs that you manage centrally in DMM-DSM must share one identical set of login credentials for DMPDM. To learn how to reconfigure your DMPs so that they all share identical credentials, see the quick 
start guide for your DMP model type on Cisco.com. 

Step 3 Click Centralized Management in the Settings area, and then enter the required values: 

• DMM Appliance IP Address — The IP address of your DMM appliance. 

• DMM-DSM Server Timeout (in seconds) — The maximum number of seconds that your DMP should wait for a response from your DMM appliance. 

Step 4 Click Apply to confirm your entries and to implement them until you change them or until you restart the DMP. 

Step 5 Click Save Configuration in the Administration area to make your configuration changes permanent even after you restart your DMP, and then (after you see the Save Configuration page) click 
Save. 

Step 6 Click Restart DMP, and then (after you see the Restart DMP page) click Restart. 

Related Topics 
• Managing and Grouping Your DMPs 

• Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them 

• Adding and Editing One DMP Manually 

Enabling the YPbPr (Component Video) Interface on DMPs 
To take advantage of the latest features, options, and modern technologies, most digital signage environments use digital displays. However, some networks might include legacy devices and technologies, including analog 
displays. If you use analog displays or have any other reason to use YPbPr component video cables when you connect your DMPs to their displays (and if your DMPs use firmware release 5.0.0 or 5.0.1) you must first enable 
the YPbPr interface on your DMPs. 

Tip This procedure is not necessary for DMPs that use firmware release 5.0.2, 5.0.3, or 5.1, where DMPDM includes Component as a selectable video signal type. 

Procedure 

Step 1 Choose Digital Media Players > Advanced Tasks, and then click the System Tasks row in the Application Types list. 

Step 2 Click  Add New Application. 

Step 3 After the page is refreshed, choose the required options and enter the required values for this task: 

a. Enter DMP_Enable_YPbPr_(Component_Video) in the Name field. 

b. Enter Enable DMP support for Component Video output on the YPbPr in the Description field. 

c. Choose Set from the Request Type list. 

d. Enter sigma.conn=6&sigma.tvst=91&sigma.cspc=1&mib.save=1 in the Request field. 

Step 4 Click Submit to save your selections. 

Step 5 To deploy to any of your DMPs the "DMP_Enable_YPbPr_(Component_Video)" task that you defined and saved, see Scheduling Time Slots for Media and Events on DMPs. 

Managing and Grouping Your DMPs 
Features available to you on the DMP Manager page (at Digital Media Players > DMP Manager) can help you to: 

• Organize your DMPs in groups. 
• Manage DMPs collectively instead of managing only one DMP at a time. 
• Deploy assets or instructions to DMPs immediately. 
• Manage the DMP displays in your network. 

When you choose options anywhere on the DMP Manager page, it is updated automatically to show the options and features that are relevant to your selection. 
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Table 3-1 Tasks That You Can Perform on the DMP Manager Page  

Task To Learn More 
 
DMP Group Management Tasks 

View the group hierarchy and collapse or expand any of its levels • Click a group in the object selector to load a list of its member DMPs in the DMP table. 
• Click a Closed Group icon to expand its level in the object selector. 
• Click an Opened Group icon to collapse its level in the object selector. 

Add a new group See: 
• Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them. 

• Understanding the Effect of Nesting One DMP Group Inside Another. Edit an existing group 

Populate a group with DMPs See: 
• If automatically, in a production network: 
Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them. 

• If manually, in a lab: 
Adding DMPs Manually to DMP Groups. 

Delete a group See Deleting DMP Groups. 

 
DMP Management Tasks 

Add a DMP See Adding and Editing One DMP Manually. 

Edit a DMP 

Delete a DMP See Deleting DMPs Manually from Your Device Inventory. 

Send assets or instructions immediately to DMPs that you choose See Using the Actions List to Deploy Assets or Instructions Immediately to DMPs. 

Associate DMPs with groups See: 
• If automatically, in a production network: 
Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them. 

• If manually, in a lab: 
Adding DMPs Manually to DMP Groups. 

Remove DMPs from groups See Removing DMPs Manually from DMP Groups. 

Filter which DMPs are described in the DMP List table See Filtering the DMP List Table. 

 
DMP Display Management Tasks 

Manage certain DMP displays manufactured by Cisco, NEC, and DMTech See Managing DMP Displays That Are Attached to Your Centrally-Managed DMPs. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

• Understanding HTTP Proxy Implications for DMPs 

UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 
Navigation Path 
Digital Media Players > DMP Manager 

Table 3-2 Elements for Managing DMPs and DMP Groups  

Element Icon and Description 
 
DMP Groups 
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A hierarchical tree (an object selector) of DMP groups, subgroups, and DMPs. Here, you can add or remove group assignments for registered DMPs, create new groups, edit 
existing groups, and choose which DMPs the DMP List table should describe. 

Add New DMP Group 
 

Shows the Add New DMP Group pane. 

Edit DMP Group 

 

Shows the Edit DMP Group pane, where you can edit attributes of the 
group that you highlighted. 

Delete DMP Group 

 

Deletes the group that you highlighted. 

Opened Group   Shows the list of group members until you click to hide them. 

Closed Group   Hides the list of group members until you click to show them. 

DMP   A DMP that you assigned to the relevant parent group. 

 
DMP List 

All DMPs at (or below) the highlighted level in the DMP Groups object selector, or the DMPs at this level that match your criteria for filtering this list. To see every registered DMP 
in your network, click the group that represents the root level. (By default, its name is "All DMPs" but this name is editable.) If there are more DMPs than there are rows, the list 
might straddle multiple pages. In this case, use pagination controls above the table to move from one page to another. 

Actions List from which to select any instruction or asset that you might send to DMPs. 

Add New DMP 
 

Shows the Add New DMP pane. 

Edit DMP 

 

Shows the Edit DMP pane. 

Delete DMP 

 

Deletes the DMP that you highlighted. 

Control TV 
 

Opens the LCD Control dialog box. 

Assign DMP to Group  Creates an association between at least one DMP and at least one group. 

Remove DMP from Group  Severs the association between at least one DMP and at least one group. 

Filter A method to redraw the DMP List table, so that it includes only the DMPs that match your filter. 

Display Number The maximum number of rows that the table should show per page if it straddles multiple pages. 

Status Says whether a DMP is reachable. 

• A green icon ( ) tells you that the DMP is connected to a power source, uses a 
known IP address, and is reachable. 

• A red icon ( ) tells you that the DMP is unreachable. 
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Name A unique and human-readable name that you entered or that DMM-DSM chose; If DMM-DSM 
chose the name, it is either the DMP IP address or MAC address. 

IP The public IP address at which the DMP receives instructions and data from DMM-DSM. 

Version The release number for the installed firmware version on the DMP. 

Description The description that you entered. 

Internal Storage MB. (Total/Free) Measures the total storage capacity of the internal flash drive, and then measures the available 
capacity. 

External Storage MB. (Total/Free) Measures the total storage capacity of the external USB drive, if the DMP is connected to one, 
and then measures the available capacity. 

WAAS Status Says that a DMP has mounted a CIFS share, or does not say anything. 

 
Related Topics 

• Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them 

• Deleting DMP Groups 

• Using the Actions List to Deploy Assets or Instructions Immediately to DMPs 

• Adding and Editing One DMP Manually 

• Deleting DMPs Manually from Your Device Inventory 

• Managing DMP Displays That Are Attached to Your Centrally-Managed DMPs 

• Adding DMPs Manually to DMP Groups 

• Removing DMPs Manually from DMP Groups 

• Filtering the DMP List Table 

• Configuring the Settings to Use ACNS or WAAS 

Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them 

Note DMM-DSM uses TCP port 7777 to communicate with DMPs. This port is open on DMPs and you cannot close it. 

When you create or edit a DMP group, the least that you must do is specify the group name and description. In addition, you can populate the group automatically with all of the DMPs in any NMAP address range that 
you specify, or you can manually add DMPs to a group. 
Before You Begin 

• The DMPs in your digital signage network must all share identical user credentials for their DMP Web Account and identical user credentials for their DMP Service Account. Otherwise, autoregistration cannot occur. To 
learn more, see the quick start guide on Cisco.com for your DMP model type. 
• Verify that the "Enable TAC Troubleshooting Access" option in DMPDM is not disabled. (It is enabled by default.) If you disable it, autoregistration cannot occur. 
• Verify that the routers, switches, and firewalls between your DMM appliance and the CIDR address range for autodiscovery allow TCP port 7777 to send and receive packets, and that they allow ICMP traffic to pass 
from your DMM appliance to your DMPs. If any of this traffic is blocked anywhere along its route, autoregistration cannot occur. 
• If you have more than one DMM appliance, be careful to autoregister only those DMPs that you are not already managing centrally from another instance of DMM-DSM. Otherwise, you might temporarily disrupt the 
deployment of presentations and their assets in your digital signage network. When you autoregister DMPs that are not currently registered in DMP database on your DMM appliance, they restart immediately even if they 
are already centrally managed by a different DMM appliance than the one that you are using, and even if they are showing presentations on their attached DMP displays. 
• We recommend that you autoregister DMPs after normal business hours. Autoregistration of 5,000 DMPs takes approximately 4 minutes in a fast network and does not use polling. 

Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Do either of the following: 

• Click the  Add New DMP Group icon above the DMP Groups object selector. 
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• Click the name of a DMP group to choose it in the object selector, and then click the  Edit DMP Group icon above the object selector. 

Step 3 Enter a name and a description for the group. 

Step 4 Define the network ranges from which to autoregister DMPs that should be added as members of this DMP group. Alternatively, if you will not autoregister DMPs now, you can skip this step. 

Tip DMM-DSM runs each autodiscovery job one time. It does not look continuously in the specified network range for DMPs that you might add in the future. If you plan to add DMPs to your network continuously, 
you can schedule an autodiscovery event to recur as often as necessary. 

Step 5 Click Submit to save your work. You can save a named group for use in the future, even if you have not yet assigned any DMPs to it. 

Related Topics 
• Understanding the Sequence of Operations for DMP Autoregistration 

• UI Reference: Settings to Add or Edit a DMP Group and Autoregister DMPs 

Understanding the Sequence of Operations for DMP Autoregistration 
Autoregistration finds every DMP in the subnets that you specify and then configures these DMPs to know and trust the IP address for your DMM appliance. It restarts the DMPs and then registers them in DMM-DSM for 
centralized management. Autoregistration operations follow this sequence: 

1. DMM-DSM scans every device in the specified address range, looking for devices where TCP port 7777 is open. 
2. DMM-DSM confirms which of the devices with port 7777 open are DMPs. 
3. DMPs receive information about your DMM server, and are then instructed to restart. 
4. Upon restarting, DMPs transmit updated information about themselves to DMM-DSM and set their own status to "Up." 
5. DMM-DSM generates new database records for all DMPs that are newly autoregistered, assigns these DMPs to any DMP groups corresponding to the address range that you entered, and assigns them to the 
"All DMPs" group. 

Related Topics 
• Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them 

• UI Reference: Settings to Add or Edit a DMP Group and Autoregister DMPs 

UI Reference: Settings to Add or Edit a DMP Group and Autoregister DMPs 
Navigation Path 
Digital Media Players > DMP Manager 

Table 3-3 Elements to Add and Edit DMP Groups  

Element Icon and Description 

These elements load when you click the  Add New DMP Group or  Edit DMP Group icon above the DMP Groups pane. 

Name A unique and human-readable name for the group. 

Description A brief description of the group and its purpose. 
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Add New Range 
 

IP address subnet ranges in which to find and autoregister DMPs. 
• The netmask typically is /24. 
• To find every DMP in a subnet, use 0 (zero) as the only digit in the fourth quad, such as 192.0.2.0/24. 
• To find one DMP whose address is already known to you, enter its IP address and the netmask but use a comma 
instead of the fourth dot, such as 192.0.2,50/24. 
• To find all of the DMPs in a narrow range of addresses, substitute a range for the fourth quad, such as 192.0.2.1-254. 
• The address range can span one subnet or multiple subnets. 

Note You can schedule multiple DMP autoregistration operations to run simultaneously if they all search the same one 
subnet. If the DMP autoregistration operations that you configure do not all search the same one subnet, you should not 
schedule them to run simultaneously. If you do, only the first such operation will run and DMM-DSM will not show any 
error message to explain why the other autoregistration operations failed to find any DMPs. If you must run DMP 
autoregistration tasks that search different subnets, schedule a 35-minute interval between the start time for one 
autoregistration and the start time for the next autoregistration. In a very large network that contains thousands of DMPs, 
the required interval might be longer than 35 minutes. 

Delete a Range 

 

Deletes the range that you highlighted. 

Automatic Grouping 
Ranges 

Shows a list of all the defined NMAP address ranges. Click a range to edit it. 

Range (CIDR) The field where you edit one CIDR address range at a time. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

• Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them 

• Understanding the Sequence of Operations for DMP Autoregistration 

Understanding the Effect of Nesting One DMP Group Inside Another 
We recommend that you create DMP groups to organize your DMPs according to characteristics that they have in common, such as where or how you will use them, according to whatever logic works best for you. For example, 
the logical basis for your DMP groups might be geographic (by state, province, or metropolitan area) or corporate (by product team, sales region, time zone, primary spoken language, or type of facility), as in this illustration: 

One DMP group can contain another and each choice that you make for centralized management propagates from parent (DMP group), to child (DMP subgroup or DMP), to grandchild (DMP). There is no maximum number of 
levels that you can add to the hierarchy, but a simpler organization is more scalable than an unreasonably complex one would be. 
We recommend that you do not assign any DMP to the root level in the hierarchy, due to the complexity of management, but we do not prevent you from doing this. 

Deleting DMP Groups 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Navigate in the DMP Groups object selector, expanding its levels as necessary until you find in its hierarchy the DMP group to be deleted. 

Step 3 Click the name of this DMP group in the object selector. 

Step 4 Click Delete DMP Group, above the object selector. 

Step 5 Click Submit to delete the group. Alternatively, click Cancel to stop this deletion. 

Related Topics 
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• Removing DMPs Manually from DMP Groups 

• Deleting DMPs Manually from Your Device Inventory 

UI Reference: Elements to Delete a DMP Group 
Navigation Path 
Digital Media Players > DMP Manager 

Table 3-4 Element to Delete DMP Groups  

Element Icon and Description 

This element loads above the DMP Groups object selector. 

Delete DMP Group 

 

Deletes the group that you highlighted. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

Adding and Editing One DMP Manually 

Caution DMM-DSM includes a feature to autoregister your DMPs so that you do not have to register each DMP manually. Nonetheless, you can register a DMP manually for testing purposes.  
 
We recommend that you never use this method to register a DMP manually, except in a lab for testing purposes. This method is neither suitable nor scalable in a production network. 
 
Later, when autodiscovery finds and adds this same DMP, a new entry will be added for it in addition to the entry that you added manually. This duplication causes an IP address conflict, which interferes with normal 
operation and triggers an alarm in DMS-Admin. 

Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Do either of the following: 

• Click the  Add New DMP icon above the DMP List table. 

• Click the name of a DMP group to choose it in the object selector, and then click the  Edit DMP icon above the DMP List table. 

Step 3 Choose options and enter required values for the DMP. 

Step 4 Click Submit to save your work. Alternatively, click Clear to discard your work. 

Step 5 (Optional) Add the DMP to a DMP group. 

Related Topics 
• UI Reference: Elements to Add or Edit a DMP 

• Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them 

• Adding DMPs Manually to DMP Groups 

UI Reference: Elements to Add or Edit a DMP 
Navigation Path 
Digital Media Players > DMP Manager 
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Table 3-5 Elements to Add and Edit One DMP  

Element Description 

These elements load when you click the  Add New DMP or  Edit DMP icon above the DMP List table. 

Name A unique and human-readable name for the DMP. 

IP Address The public IP address that receives instructions and data from DMM-DSM. 

MAC Address The MAC address that the DMP NIC uses. 

Description Optional, brief description of the DMP, its deployment site, or anything that is relevant or meaningful to you. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

Deleting DMPs Manually from Your Device Inventory 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Do either of the following: 

• Navigate in the DMP Groups object selector, expanding its levels as necessary until you find in its hierarchy the parent group for a DMP that should be deleted. Then, click the name of this DMP group in the object 
selector. 

• Choose an option from the Filter list to restrict which DMPs the DMP List table describes. 

Step 3 (Optional) If DMP data in the table straddles multiple pages, use pagination controls above the table to move between pages. 

Step 4 Check the check box for the DMP to be deleted. 

Step 5 Click  Delete DMP, above the DMP List table. 

Step 6 Click Submit to save your work. Alternatively, click Clear to discard your work. 

Related Topics 
• UI Reference: Elements to Delete a DMP 

• Filtering the DMP List Table 

UI Reference: Elements to Delete a DMP 
Navigation Path 
Digital Media Players > DMP Manager 

Table 3-6 Elements to Delete One DMP  

Element Icon and Description 

This element loads above the DMP List table. 
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Delete DMP 

 

Deletes the DMP that you highlighted. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

• Deleting DMPs Manually from Your Device Inventory 

Adding DMPs Manually to DMP Groups 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Click  Assign DMP to Group, above the DMP List table. 

Step 3 Click a DMP in the DMP List table to choose it. Alternatively, use check boxes in the table to choose multiple DMPs. 

Step 4 Navigate in the DMP Groups object selector, expanding its levels as necessary until you find in its hierarchy the group that should contain the DMP. 

Step 5 Click the name of the DMP group in the object selector. 

Step 6 Click  Assign DMP to Group again. 

Related Topics 
• UI Reference: Elements to Add DMPs Manually to a DMP Group 

UI Reference: Elements to Add DMPs Manually to a DMP Group 
Navigation Path 
Digital Media Players > DMP Manager 

Table 3-7 Elements to Associate DMPs with a DMP Group  

Element Icon and Description 

This element loads above the DMP List table. 

Assign DMP to Group  Creates an association between at least one DMP and at least one group. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

• Adding DMPs Manually to DMP Groups 

Removing DMPs Manually from DMP Groups 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Navigate in the DMP Groups object selector, expanding its levels as necessary until you find in its hierarchy the group that should no longer include a DMP. 

Step 3 Click the name of this DMP group in the object selector. 

Step 4 Click  Remove DMP from Group, above the DMP List table. 

Step 5 Click a DMP in the DMP List table to choose it. Alternatively, use check boxes in the table to choose multiple DMPs. 

Step 6 In the object selector, click the DMP group from which to remove the selected DMPs. 

Step 7 Click  Remove DMP from Group again. 
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Related Topics 
• UI Reference: Elements to Remove a DMP from a DMP Group 

UI Reference: Elements to Remove a DMP from a DMP Group 
Navigation Path 
Digital Media Players > DMP Manager 

Table 3-8 Elements to Remove a DMP from a DMP Group  

Element Icon and Description 

This element loads above the DMP List table. 

Remove DMP from Group  Deletes the association between at least one DMP and at least one group. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

• Removing DMPs Manually from DMP Groups 

Filtering the DMP List Table 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Click the entry in the DMP Group object selector for a group whose list of member DMPs you will filter. 

Step 3 Choose an option from the Filter list, above the DMP List table: 

• Status — Select Up or Down to limit matches by DMP availability. 

• Name — Enter the text string to limit matches by DMP name. 

• IP — Enter any part of the "dotted quad" to limit matches by DMP IP address. 

• MAC — Enter the text string to limit matches by DMP MAC address. 

• Description — Enter the text string to limit matches by DMP descriptions. 

• Version — Enter the text string to limit matches by DMP firmware release version number. 

Step 4 (Optional) Enter a number in the Display # field to specify how many rows of data the DMP List table should load per page. 

When there are more DMPs than there are rows per page, the table straddles multiple pages. 

Step 5 (Optional) If DMP data in the table straddles multiple pages, use pagination controls above the table to move between pages. 

Step 6 Click Go. 

Related Topics 
• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

Understanding HTTP Proxy Implications for DMPs 
Important considerations apply to your digital signage network if any of your DMPs uses an HTTP proxy server. It is unusual and not scalable to manage many DMPs that share one HTTP proxy server. We recommend that 
your DMPs should not use HTTP proxy servers. 

• If your DMPs must use proxied connections, we recommend that you configure them to use Web Cache Communication Protocol (WCCP) instead of using a proxy server. WCCP reroutes HTTP requests transparently. 
To learn how to use WCCP if you do not already know how, see Cisco.com. 
• To configure one DMP to use one proxy server, use DMPDM, not DMM-DSM. See the "Adjusting Basic Network Settings" topic in User Guide for Cisco Digital Media Player Device Manager 5.1 on Cisco.com. 

Related Topics 
• Configuring Multiple DMPs to Share One HTTP Proxy Server 

Configuring Multiple DMPs to Share One HTTP Proxy Server 
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You can configure multiple DMPs to share one HTTP proxy server, even though we recommend that you do not. 
Procedure 

Step 1 Choose Digital Media Players > Advanced Tasks. 

Step 2 Click System Tasks in the list of defined tasks, and then click  Add New Application. 

Step 3 Enter a name and description. 

Step 4 Choose Set from the Request Type list and use this syntax in the Request field: init.BROWSER_PROXY=<on | off>&init.BROWSER_PROXY_IP= 
<proxy_server_IP_address>&init.BROWSER_PROXY_PORT=<proxy_server_logical_port>. 

For example, if the proxy server uses 192.168.12.12 as its IP address and delivers proxy services through port 5678, the Request string would look like this: init.BROWSER_PROXY=on&init. 
BROWSER_PROXY_IP=192.168.12.12&init.BROWSER_PROXY_PORT=5678&mib.save=1&mng.reboot=1. 

To remove that example proxy, you would choose Set from the Request type list, and then enter this Request string: init.BROWSER_PROXY_IP=&init.BROWSER_PROXY_PORT=&init.
BROWSER_PROXY=off 
&mib.save=1&mng.reboot=1. 

Related Topics 
• Understanding HTTP Proxy Implications for DMPs 

Managing Your DMP Displays 
• Managing DMP Displays That Are Attached to Your Centrally-Managed DMPs 

• Using RS-232 Commands to Manage Cisco LCD Professional Series Displays 

Managing DMP Displays That Are Attached to Your Centrally-Managed DMPs 
Before You Begin 

• Prepare any Cisco LCD Professional Series displays for centralized management through a DVI or HDMI signal cable. 
• Connect your DMPs to your DMP displays with signal cables that can relay RS-232 commands. 
• Use the system task that activates RS-232 command access for the brand of DMP display to be managed centrally. 

– If the DMP display brand is Cisco or NEC, the system task to use is: 
RS-232: Control supported, non-DMTech displays. 
– If the DMP display brand is DMTech, the system task to use is: 
RS-232: Control DMTech displays. 

Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Do either of the following: 

• Navigate in the DMP Groups object selector, expanding its levels as necessary until you find in its hierarchy the parent group for a DMP whose attached DMP display should receive instructions. Then, click the name of 
this DMP group in the object selector. 

• Choose an option from the Filter list to restrict which DMPs the DMP List table describes. 

Step 3 (Optional) If DMP data in the table straddles multiple pages, use pagination controls above the table to move between pages. 

Step 4 Click a DMP in the DMP List table to choose it. Alternatively, use check boxes in the table to choose multiple DMPs that are all attached to identical DMP displays. 

Step 5 Click  Control TV, above the DMP List table. 

Step 6 Use options in the LCD Control dialog box to configure these DMP displays. 

Step 7 Click Submit to save your work in the LCD Control popup window. Alternatively, click Cancel to discard your work. 

Related Topics 
• UI Reference: Elements to Manage DMP Displays 

• Preparing a Cisco LCD Display for Centralized Management Through DVI 
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UI Reference: Elements to Manage DMP Displays 
Navigation Path 
Digital Media Players > DMP Manager 

Table 3-9 Elements to Manage a DMP Display  

Element Icon and Description 

This element loads above the DMP List table. 

Control TV 
 

Opens the LCD Control dialog box, where you can configure parameters for a DMP display that Cisco, NEC, or DMTech manufactured. 

 
UI Elements in the LCD Control Dialog Box 

TV Type A list from which to choose the manufacturer and the model type for a DMP display that you will manage. Other elements in the LCD Control 
dialog box do not load until you choose an option from this list, and vary according to the capabilities of whichever manufacturer and model 
you choose. The LCD display types that we support for centralized management are: 

• CISCO_40N 
• CISCO_52S 
• DMTECH 
• NEC_3210 
• NEC_4010 
• NEC_4610 
• NEC_5710 

Contrast Choose or enter a contrast value from 0 to 100, and then check the corresponding Apply check box. 

Brightness Choose or enter a brightness value in the range from 0 to 100, and then check the corresponding Apply check box. 

Sharpness Choose or enter a sharpness value in the range from 0 to 100, and then check the corresponding Apply check box. 

Color Choose or enter a color value in the range from 0 to 100, and then check the corresponding Apply check box. 

Tint Choose or enter a tint value in the range from 0 to 100, and then check the corresponding Apply check box. 

TV Channel Choose or enter the analog television signal frequency for a channel from 0 to 99, and then check the corresponding Apply check box. 

Audio Volume Choose or enter a volume level in the range from 0 to 100, and then check the corresponding Apply check box. 

Mute Choose On to mute audio from the DMP display speakers, or choose Off to unmute audio. 

Input A list from which to choose the video signal input type. Options vary according to the manufacturer and display model. 

• CISCO_40N 
• CISCO_52S 

• PC 
• BNC 
• DVI 

• AV 
• Component 
• HDMI 

DMTECH • TV 
• RGB 
• Video 1 
• Video 2 
• Video 3 
• S-Video 

• None (DVD) 
• Component 
• PC 
• HDMI 
• None (DVBT) 

• NEC_3210 
• NEC_4010 
• NEC_4610 
• NEC_5710 

• RGB1 (DVI-D) 
• RGB2 (D-SUB) 
• RGB3 (BNC) 

• DVD/HD 
• VIDEO (Composite) 
• S-Video 
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Power Choose On to turn the DMP display on, or choose Off. 

Safety Lock Note When you use DMM-DSM to lock the remote control unit and the front panel controls for your LCD Professional Series display, 
you cannot then use the remote control to unlock them. The only way to unlock them in this case is to switch the Safety Lock, Remote 
Control Lock, and Panel Lock toggles all to Off in DMM-DSM. 

The option that you choose from this list clears your choice, if any, in the Remote Control Lock and Panel Lock lists. You can choose only 
one option among all three of these lists, which are hidden from you unless you chose CISCO_40N or CISCO_52S from the TV Type list. 

• Choose On to lock the front panel controls and the remote control buttons for your LCD Professional Series display. When anyone 
at its physical location presses buttons on the remote control or uses controls on the display front panel while they are locked, an on-
screen message explains that the lock is engaged. There is no effect when anyone at its physical location uses the remote control unit to 
enter the safety lock PIN. 
• Choose Off to unlock these controls. It does not matter how you locked them. When you use DMM-DSM to remotely unlock the 
remote control unit and controls on the display front panel, it is not necessary to enter the safety lock PIN. 

Remote Control Lock Note When you use DMM-DSM to lock the remote control unit for your LCD Professional Series display, you cannot then use the 
remote control to unlock itself. The only way to unlock the remote control in this case is to switch the Safety Lock and Remote Control 
Lock toggles both to Off in DMM-DSM. 

The option that you choose from this list clears your choice, if any, in the Safety Lock and Panel Lock lists. You can choose only one option 
among all three of these lists, which are hidden from you unless you chose CISCO_40N or CISCO_52S from the TV Type list. 

• Choose On to lock the remote control unit for your LCD Professional Series display. When anyone at its physical location presses 
buttons on the remote control while it are locked, an on-screen message explains that the lock is engaged. There is no effect when 
anyone at its physical location uses the remote control unit to enter the safety lock PIN. 
• Choose Off to unlock the remote control. It does not matter how you locked it. When you use DMM-DSM to remotely unlock a 
remote control, it is not necessary to enter the safety lock PIN. 

To learn more, see User Guide for Cisco LCD Professional Series Displays on Cisco.com. 

Panel Lock Note When you use DMM-DSM to lock controls on the front panel for your LCD Professional Series display, you cannot use the 
remote control to unlock them. The only way to unlock the front panel controls in this case is to switch the Safety Lock and Panel Lock 
toggles both to Off in DMM-DSM. 

The option that you choose from this list clears your choice, if any, in the Safety Lock and Remote Control Lock lists. You can choose only 
one option among all three of these lists, which are hidden from you unless you chose CISCO_40N or CISCO_52S from the TV Type list. 

• Choose On to lock the front panel controls for your LCD Professional Series display. When anyone at its physical location uses 
controls on the display front panel while they are locked, an on-screen message explains that the lock is engaged. 
• Choose Off to unlock the front panel controls. It does not matter how you locked them. When you use DMM-DSM to remotely 
unlock these controls, it is not necessary to enter the safety lock PIN. 
Tip Alternatively, anyone at its physical location can use the remote control unit to unlock front panel controls on your LCD 
Professional Series Display, by entering the safety lock PIN correctly when prompted to enter it. 

To learn more, see User Guide for Cisco LCD Professional Series Displays on Cisco.com. 

 
Related Topics 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

Using RS-232 Commands to Manage Cisco LCD Professional Series Displays 
• Preparing a Cisco LCD Display for Centralized Management Through DVI 

• RS-232 Command Reference for Cisco LCD Displays 

Preparing a Cisco LCD Display for Centralized Management Through DVI 
When you use an HDMI cable or a DVI cable to connect your DMP to an LCD display model from the Cisco LCD Professional Series, you can use DMM-DSM to centrally manage the LCD display. 
When HDMI is the connection type from a DMP to a Professional Series display, centralized management from DMM works immediately, without any prerequisites. However, when DVI is the connection type, you must complete 
a simple task at the physical installation site for your LCD display before you can start to centrally manage it. 
Before You Begin 

• Use the system task that activates RS-232 command access for your Professional Series display. The system task to use is: RS-232: Control supported, non-DMTech displays. 
Procedure 

Step 1 Do either of the following: 

• On the remote control for your LCD display, press Menu. 

• On the front panel of your LCD display, press Menu. 
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Step 2 Choose Input > Source List > DVI, and then press Enter. 

Step 3 Choose Input > Edit Name > DVI > HD STB, and then press Enter. 

Related Topics 
• RS-232 Command Reference for Cisco LCD Displays 

• Managing DMP Displays That Are Attached to Your Centrally-Managed DMPs 

RS-232 Command Reference for Cisco LCD Displays 
You can use RS-232 command strings for centralized management of LCD display models (LCD-100-Pro-40N and LCD-110-Pro-52S) from the Cisco LCD Professional Series: 

• Turning the Display On and Off 

• Muting and Unmuting the Display 

• Adjusting Brightness 

• Adjusting Colorfulness 

• Adjusting Contrast 

• Turning the Remote Control On and Off 

• Locking and Unlocking the Display and Its Remote Control 

Before You Begin 
• Prepare Cisco displays for centralized management through a DVI or HDMI signal cable. 
• Deploy the system task that activates RS-232 command access for your Professional Series display. The system task to use is: RS-232: Control supported, non-DMTech displays. 

Table 3-10 RS-232 Commands to Manage LCD Professional Series Displays Remotely  

Task RS-232 Syntax 
 
Turning the Display On and Off 

Turn on the display rs232.tx_hex=aa11fe010111 

Turn off the display rs232.tx_hex=aa11fe010010 

 
Muting and Unmuting the Display 

Mute the display rs232.tx_hex=aa13ff010114 

Unmute the display rs232.tx_hex=aa13ff010013 

 
Adjusting Brightness 

Set brightness to 50 percent rs232.tx_hex=aa25ff013257 

Set brightness to 75 percent rs232.tx_hex=aa25ff014b70 

Set brightness to 100 percent rs232.tx_hex=aa25ff016489 

 
Adjusting Colorfulness 

Set colorfulness1 to 50 percent rs232.tx_hex=aa27ff013259 

Set colorfulness to 75 percent rs232.tx_hex=aa27ff014b72 

Set colorfulness to 100 percent rs232.tx_hex=aa27ff01648b 

 
Adjusting Contrast 

Set contrast to 50 percent rs232.tx_hex=aa24ff013256 
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Set contrast to 75 percent rs232.tx_hex=aa24ff014b6f 

Set contrast to 100 percent rs232.tx_hex=aa24ff016488 

 
Turning the Remote Control On and Off 

Turn on the remote control rs232.tx_hex=aa36ff010137 

Turn off the remote control rs232.tx_hex=aa36FF010036 

 
Locking and Unlocking the Display and Its Remote Control 

Lock all features rs232.tx_hex=aa5dff01015e 

Unlock all features rs232.tx_hex=aa5dff01005d 

1 An image with a colorfulness value of zero percent is grayscale, while the same image with a colorfulness value of 100 percent has vivid 
colors. 

 
Configuring the Settings for Enterprise TV 

Activation Software feature modules for Cisco DMS are purchased and licensed separately. Features are hidden from all users until you purchase and install the required license to use them, and even 
then remain hidden from users whose privilege levels are low. To understand feature licenses and learn how to install them, see Managing Licenses for Features and Components of Cisco DMS, page 2-
3. To learn how user access to features is restricted by the combination of licenses and user privilege levels, see Understanding User Roles in DMS-Admin, page 2-9. To learn which software feature 
modules are available for you to purchase, see http://www.cisco.com/go/dms. 

An administrator uses DMM-ETV to: 
• Customize on-screen menus with a logo and a skin. 
• Configure video channel assignments. 
• Specify what channels and programs should be available to the DMP displays where your organization will deploy Enterprise TV, and when they should be available. 

An on-premises operator uses a handheld remote control unit or an emulated remote control to navigate through live video channel menus, change channels, and select from video-on-demand categories. 
• Understanding Restrictions for Enterprise TV 

• Choosing Where in Your WAN to Show Live or On-Demand Programming 

• Understanding the Typical Workflow for Enterprise TV 

• Configuring Settings for TV Channels 

• Configuring Subscription Settings for EPG Providers 

• Configuring Enterprise TV Settings for Video on Demand 

• Using `Skins' to Customize the Enterprise TV Menu System 

• Emulating the DMP Remote Control for Enterprise TV 

Understanding Restrictions for Enterprise TV 
• Video-on-demand (VoD) features for Enterprise TV depend upon the media library features for digital signage. Therefore, even though the DMM-ETV and DMM-DSM software modules are licensed separately and can 
operate independently of one another in most ways, you cannot use the VoD features for Enterprise TV unless you have installed the licenses for both DMM-ETV and DMM-DSM. 
• The features for Enterprise TV in this release support 99 or fewer channels of live broadcast programming and VoD programming, combined. 
• Any digital encoders that you use for live broadcast channels must adhere to the MPEG2-TS standard for streaming and must support at least one of these codecs: 

– MPEG1 
– MPEG2 
– MPEG4/h.264 (supported on DMP 4400G endpoints only) 

For this reason, we recommend that you use a Scientific Atlanta 9032SD encoder or 9050HD encoder to encode the video streams that your DMPs use for Enterprise TV channels. 

Choosing Where in Your WAN to Show Live or On-Demand Programming

Programming Factors to Consider 
Live Organizations that use Enterprise TV tend to show live video programming at their sites with the 

greatest bandwidth capacity, such as their main site. Live video programming is not suitable for 
remote branch offices with low bandwidth capacity. 
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VoD Remote branch offices are better suited to VoD programming than they are to live video 
programming. Common use cases for VoD programming include training and executive 
communications. We recommend that you use a content delivery system to provision the assets for 
your VoD programming, particularly if your remote sites have low bandwidth capacity. 

 
Understanding the Typical Workflow for Enterprise TV 
This topic describes the ordinary workflow for Enterprise TV. 
Before You Begin 

• Install the license for Enterprise TV on your DMM appliance. 
• Deploy DMPs and DMP displays to the sites where you will show Enterprise TV. 
• For live TV — Negotiate with a cable or satellite TV service in your region for the right to redistribute their package of TV channel signals, in whole or in part. 
• For live TV — Configure one Scientific Atlanta 9032SD encoder or 9050HD encoder apiece for each TV channel signal that you will stream in real time. 

 Workflow Actions 

Step 1  Use elements on the Skin Customization tab to enable or 
disable the electronic program guide (EPG) for Enterprise 
TV. When it is enabled, people at your deployment sites 
can use a handheld remote control unit or an emulated 
remote control to browse on-screen program listings and 
choose programs to watch. 

a. See Using `Skins' to Customize the Enterprise TV Menu System. 

Step 2  If you will use an EPG, choose a channel description 
population method for each channel that the EPG will 
describe. 

• See Understanding Supported Methods to Populate EPG Channel Descriptions 

You can skip this task if you will not use the EPG. 

Step 3  If you will use an EPG and populate its channel descriptions 
from an EPG data subscription, define the settings for that 
subscription. 

Use elements on the EPG Providers tab to: 
a. Enter login credentials for your subscription. See Adding or Editing Subscriptions 
to Data from an EPG Provider. 

b. Obtain and then synchronize the schedule and description data for programs. 
See Synchronizing TV Channel Schedules and Program Descriptions for the EPG. 

Step 4  If your DMM appliance does not have direct Internet access 
and should use a proxy server to obtain data from your 
preferred EPG data service provider, configure a SOCKS 
proxy for Enterprise TV. 

a. See Proxy Settings (Optional) 

Configuring Settings for TV Channels 
• UI Reference: Elements to Manage TV Channels 

• Adding New Channels 

• Editing Channels 

• Reassigning Channel Numbers 

• Deleting Channels 

• Listing Only the Defined (Active) or Undefined (Inactive) TV Channels 

UI Reference: Elements to Manage TV Channels 
Navigation Path 
Enterprise TV > TV Channels 
The TV Channels table describes the defined and undefined TV channels for your network and includes features that help you to manage these channels. 

Table 3-11 Elements of the TV Channels Table  

Element Description 
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Channel View list Enables or disables a filtered view of which channels this table describes, based on which option you choose: 
• All Channels — Shows the combination of all defined and undefined channels. 
• Active Channels — Shows only the defined channels. 
• Inactive Channels — Shows only the channels that are not yet defined. 

Channel Number One numeral per row, in the range from 1 to 99, where any numeral can be the TV channel number that you associate with a particular 
multicast stream. The default behavior for this table is that it shows all 99 possible channel numbers, one per row. 
Your choice from the Channel View list might limit how many rows the table contains, and this can affect indirectly how many channel 
numbers you see. 
If you sort the table by clicking a column heading, channel numbers might be rearranged temporarily into an unrecognizable sequence. To 
sort channels back into the expected sequence if their sequence has become unrecognizable, click the Channel Number column heading. 

Channel Name Blank when the corresponding row describes an undefined TV channel. Otherwise, shows a value that you entered or an option that you 
chose from a list when you defined the channel. To understand these values, see Table 3-12. 

Description 

Multicast Address: Port 

Call Letters for Channel 

Reassign to Nearest Unused 
Channel 

Two buttons, either of which can change the association between a channel definition and a channel number. The channel definition in the 
corresponding row becomes associated instead with the closest channel (of a higher number or a lower number, respectively) that is 
undefined. These buttons have no effect when every channel is already defined. 
The first row and last row of this table will only ever show one of these buttons apiece. These rows differ from all other rows in the table 
because you cannot use any channel number that is lower than the lowest supported channel number or higher than the highest supported 
channel number. The first row shows only , while the last row shows only . 

•  — Associates the channel definition that the corresponding row describes with whichever lower-numbered channel is nearest 
among the undefined channels. The arrow points up because table rows above this row are reserved for lower-numbered channels. 

•  — Associates the channel definition that the corresponding row describes with whichever higher-numbered channel is nearest 
among the undefined channels. The arrow points down because table rows above this row are reserved for higher-numbered channels. 

Actions One of these: 
• Set Up Channel — Opens the dialog box where you can enter values and define attributes for a TV channel. This button is 
visible only in rows that describe undefined TV channels. 

•  — A list from which you can choose one of the following options. This list is visible only in rows that describe defined TV 
channels. 

– Edit Channel Settings — Opens the dialog box where you can edit the values and attributes of a channel that is 
already defined. 
– Reassign to Any Unused Channel — Associates the channel definition that the corresponding row describes 
with whichever channel is nearest among the undefined channels. The new channel number might be higher or lower than 
whichever channel number was in effect until you changed it. 
– Delete This Channel — Deletes all entries and attribute values from the definition of the channel that the 
corresponding row describes. The relevant channel number will not be associated with any defined channel unless or until you 
define a new channel for it or associate an existing channel with it. 

 
Related Topics 

• Adding New Channels 

• Editing Channels 

• Reassigning Channel Numbers 

Adding New Channels 
You can define many attributes for a new TV channel in your lineup. Permitted channel assignments range from 1 to 99. 

Tip When you plan how many TV channels to configure, consider the actual bandwidth capacity in your WAN and at each remote site where you will show Enterprise TV. The typical rate of bandwidth consumption will be in 
the range from 2 Mbps to 16 Mbps per channel, per site. 

Procedure 

http://www.cisco.com/en/US/docs/video/digital_media_systems/5_x/5_1/dmm/user/guide/dsm+etv.html (26 of 104)2/9/2010 4:40:53 PM



User Guide for Cisco Digital Media Manager 5.1.x - 03 -- Managing Digital Signage and Enterprise TV  [Cisco Digital Media Manager] - Cisco Systems 

Step 1 Click the TV Channels tab. 

Step 2 In the Channel Number column, identify the channel to be defined and then, in the corresponding row, click Set Up Channel in the Actions column. 

The Add a New Channel dialog box opens. 

Step 3 Choose the options or enter the values that meet your requirements. 

Step 4 Do one of the following: 

• To save your entries, click Add a Channel. 

• To discard your entries, click Cancel. 

Related Topics 
• UI Reference: Elements to Manage TV Channels 

• Actions 

Understanding Supported Methods to Populate EPG Channel Descriptions 
Using Generic Channel Descriptions 
You can disassociate a channel from all EPG data sources. In this case, the only information that an EPG will show about the channel is exactly the text that you enter in the Text to Show if Program Guide is Not Available field. 
This brief message, which you enter one time, describes the channel in a broad and general sense, and straddles all time slots. 
Using Channel Descriptions from a CSV File 
You can enter descriptions into a CSV file for each program that a channel will show. With this method, you can have and use an EPG without entering into a subscription contract. To populate an EPG completely, you must 
create and upload a separate CSV file for every channel that your EPG should include. EPG provider-related prerequisites do not apply if your channel will use programming data from a CSV file. 
There are strict requirements for what constitutes a valid CSV file. It must use syntax and formatting that are perfectly consistent with output from a downloadable Microsoft Excel format template that we provide for your use. 
We strongly recommend that you derive your CSV files from the free template. Click Download the CSV Template to obtain a copy of the template, and start using it to define the EPG attributes for programs on 
one channel. You can define the attributes for only a few programs or for as many as 14 days of programs. 
Populate fields in the template as follows, where each table row contains the attributes for one program in the EPG for the corresponding TV channel: 

• Date — The date and time of day when one described program will start. Start times for programs in your CSV file must use the format MM/DD/YY HH:mm. 
• Duration — The total running time for the described program. Duration values for programs must use numerals, which indicate the total duration in minutes. 
• Title — The title that the program guide should show for the described program. Program titles are limited to a maximum of 23 characters. If the text to be displayed in a program title should show any visible quotation 
marks, you must enter exactly \" for each quotation mark that should be visible. 
• Description — The actual description that the program guide should show for the program. Descriptions are limited to a maximum of 50 characters. If the text to be displayed in your program guide should show 
any visible quotation marks, you must enter exactly \" for each quotation mark that should be visible. 

Define the attributes for programs on one channel, and then save and upload your CSV file. 
Using Channel Descriptions from a Data Subscription 
You can negotiate with a vendor of programming data to establish a paid subscription, by which you will gain automatic access to current program schedules and descriptions for multiple channels. Before your channel can use 
any EPG data from a subscription provider, you must enter your subscription details and synchronize data on the EPG Providers tab. Then, you must configure the channel on the TV Channels tab. The supported data formats 
are: 

• TMS — Your EPG will use Tribune Media Services data to describe the channel and its programs. 
• <XMLTV> — Your EPG will use data in the XMLTV format to describe the channel and its programs. The provider name here is not necessarily "XMLTV." Instead, it matches exactly what you entered for the provider 
name when you configured your subscription settings, assuming that you have an XMLTV data subscription. 

Related Topics 
• Adding New Channels 

• Download the CSV Template 

UI Reference: Elements to Define Channel Settings 
Navigation Path 

• Enterprise TV > TV Channels > Set Up Channel 

• Enterprise TV > TV Channels >  > Edit Channel Settings 

Table 3-12 Elements for Channel Definition  

Element Description 
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Your Name for This Channel A meaningful, brief, and unique description of the channel that the corresponding row describes, such as China Central 
Television, Univision, Al-Jazeera, BBC-1, Star Cricket, HBO, or CNN. 

Address Type The method (multicast or HTTP) that your DMPs will use to receive the video stream for this channel. Choose an option from the 
list to enter the correct kind of address. Your choice determines which other fields appear on this page. The options are: 

• Multicast Address — The routable IP address and UDP port for a streaming server, as described in the "Multicast 
Address: Port" row elsewhere in this table. 

• HTTP URL — The full HTTP URL for one video file of a supported type, as described in the "HTTP URL" row elsewhere 
in this table. 

Multicast Address: Port The IP address and port number of the streaming server from which your DMPs will receive the multicast stream for this channel. 
You must specify the port number. This field is visible only after you choose Multicast Address from the Address Type list. If you 
later choose any other option from the Address Type list, DMM-ETV will ignore the values in this field. 

HTTP URL The exact URL and path that points to one MPEG video file on an HTTP server. You must use HTTP as the protocol and the 
filename extension must be MPG. This field is visible only after you choose HTTP URL from the Address Type list. 

Text to Show if Program Guide is Not 
Available 

Text that describes this channel. The electronic program guide (EPG) shows this text when no other information is available. 
When the EPG uses this text, it does not describe individual programs for this channel. See Using Generic Channel Descriptions. 

EPG Provider Associates or disassociates this channel with one EPG data source and specifies the nature of that source if you associate one 
with this channel. You can choose whether to use any data source. The options are similar to these: 

• TMS — Your EPG will use data from Tribune Media Services to describe this channel and its programs. See Using 
Channel Descriptions from a Data Subscription. 

• <XMLTV> — Your EPG will use data in the XMLTV format to describe this channel and its programs. See Using 
Channel Descriptions from a Data Subscription. 

• Upload CSV — Your EPG will use data from a CSV file to describe this channel and its programs. See Using 
Channel Descriptions from a CSV File. 

• None — Your EPG will use a brief, generic statement to describe this channel and its programs. See Using Generic 
Channel Descriptions. 

Note EPG data is not required for Enterprise TV to work. You can use options at Enterprise TV > Skins Customization to 
enable or disable the EPG for Cisco DMS. You are not required to subscribe to any EPG data service. 

CSV File (Browse) The method to find and select a CSV file that you have stored locally and will upload to your DMM appliance. 

Download the CSV Template A downloadable template file in Microsoft Excel format that you can use to define the EPG attributes for programs on one 
channel. This link is visible only when you have chosen Upload CSV from the EPG Provider list. See Using Channel Descriptions 
from a CSV File. 

Call Letters for Channel A list of call letters for TV channels that your EPG subscription includes. The list is variable according to your location in the 
United States, the package of channels that you receive from your cable or satellite TV provider, the nature of your contract with 
TMS, and possibly other factors. Your list might include some or all of these call letters, possibly among others: 

• ABC — American Broadcasting Company 
• AZA — Azteca América 
• CBC — Canadian Broadcasting Corporation 
• CBS — CBS Broadcasting 
• CW — The CW Television Network 
• FOX — Fox Broadcasting Company 
• MNT — MyNetworkTV 
• NBC — National Broadcasting Company 
• PAX — ION Television 
• PBS — Public Broadcasting Service 
• SRC — SRC 
• TEL — Telemundo 
• TLF — TeleFutura 
• TQS — Télévision Quatre Saisons 
• TVA — Tele Vida Abundante 
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• UNI — Univision 
This list is visible only after you choose Tribune Media Services from the EPG Provider list. 

 
Related Topics 

• Adding or Editing Subscriptions to Data from an EPG Provider 

• Configuring Subscription Settings for EPG Providers 

• Using `Skins' to Customize the Enterprise TV Menu System 

Editing Channels 
Procedure 

Step 1 Click the TV Channels tab. 

Step 2 In the Channel Number column, identify the channel to be edited; then, click the arrow ( ) in the Actions column for that row. 

The Actions menu expands so that you can see and choose among its options. 

Step 3 Click Edit Channel Setting. 

The Edit an Existing Channel dialog box opens. 

Step 4 Choose the options or enter the values that meet your requirements, as described in Table 3-12. 

Step 5 Do one of the following: 

• To save your entries, click Update Channel. 

• To discard your entries, click Cancel. 

Related Topics 
• UI Reference: Elements to Manage TV Channels 

Reassigning Channel Numbers 
Procedure 

Step 1 Click the TV Channels tab. 

Step 2 In the Channel Number column, identify the channel to be edited. 

Step 3 Click the up ( ) or down ( ) arrow to reassign this channel to the nearest unused number. 

Alternatively, to specify a number for a channel, do the following: 

a. In the Channel Number column, identify the channel to be edited; then, click the arrow ( ) in the Actions column for that row. 

The Actions menu expands so that you can see and choose among its options. 
b. Click Reassign to Any Unused Channel. 

c. From the list in the Actions column, choose the channel number to assign to this channel. 

Related Topics 
• UI Reference: Elements to Manage TV Channels 

• "Reassign to Nearest Unused Channel" (in Table 3-11) 

Deleting Channels 
Procedure 

Step 1 Click the TV Channels tab. 

Step 2 In the Channel Number column, identify the channel to be deleted; then, click the arrow ( ) in the Actions column for that row. 
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The Actions menu expands so that you can see and choose among its options. 

Step 3 Click Delete This Channel. 

The Delete Confirmation dialog box opens. 

Step 4 Do one of the following: 

• To delete the channel, click Yes. 

• To retain the channel, click No. 

Related Topics 
• UI Reference: Elements to Manage TV Channels 

Listing Only the Defined (Active) or Undefined (Inactive) TV Channels 
You can filter the TV Channels table so that it describes defined channels only or undefined channels only. By default, the table describes all channels. 
Procedure 

Step 1 Click the TV Channels tab. 

Step 2 From the Channel View list above the column headings, choose one of the following options: 

• All Channels (default)  — Shows the combination of all defined and undefined channels. 

• Active Channels — Shows only the defined channels. 

• Inactive Channels — Shows only the channels that are not yet defined. 

Related Topics 
• UI Reference: Elements to Manage TV Channels 

Understanding Data Formats for EPG Provider Subscriptions 

Note When you negotiate the contract to receive EPG data in any format, tell your subscription provider that you will use its EPG data with Cisco Enterprise TV. Knowing this, your provider can ensure that your license grants 
you sufficient permissions so that you are not in violation of its terms. 

We support the XMLTV and TMS data formats for subscriptions to electronic program guide (EPG) data. 
XMLTV 

• XMLTV is an emerging, open-source format for EPG data, based in part on RFC 2838, and maintained by the XMLTV Project. An EPG data file that complies with this format contains structured records that describe 
the attributes of episodes and channels individually. 

Cisco DMS supports EPG data subscriptions that retrieve a single gzip-compressed XMLTV file from an ftp server. Many subscription providers compile and deliver EPG data in this way, including these providers based in the 
United States: 

• FYI Television, Inc. (http://www.fyitelevision.com/)  
1901 N State Hwy 360 3rd Floor 
Grand Prairie, TX 75050 
• Schedules Direct (http://www.schedulesdirect.org/) 
8613 42nd Ave S 
Seattle, WA 98118 

Tribune Media Services 
Tribune Media Services (TMS; http://tms.tribune.com/products/k-epgs.html) sells subscriptions to EPG data in several proprietary data formats that it controls. Cisco DMS supports only one of these data formats. Specifically: 

• The name of the supported product is TV Schedules, United States. 
• The scope of the supported product is Fourteen (14) rolling days. 
• Subscriptions that use this format are available only within the United States. 

Other EPG subscription products from TMS use data formats that we do not support. If you are already a TMS customer, check whether your preexisting subscription contract already authorizes you to obtain and use EPG data 
in the supported format. 
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Note • To learn more about the supported TMS data format or to negotiate the commercial contract for a subscription, contact Amy Mann, the director of new media sales at Tribune Media Services. Her toll-free 
telephone number is 800 833-9581, ext. 2333, and her email address is aamann@tribune.com. To ensure that your contract includes sufficient permissions, be sure to say that you intend to use TMS data for Cisco 
Enterprise TV. 
• It might be necessary to adjust security settings in your network so that you can receive EPG data from TMS. The ftp server on your DMM appliance must be able to reach the TMS ftp server. 
• Data from TMS is proprietary, copyrighted, and licensed. Although TMS compiles this licensed data in good faith, neither Cisco nor TMS makes any express or implied warranties regarding the data or its merchantability 
or fitness for any particular purpose. 

Configuring Subscription Settings for EPG Providers 
Electronic program guide (EPG) data is not required for Enterprise TV to work. You can enable or disable the EPG for Cisco DMS. You are not required to subscribe to any EPG data service. 

Tip To have and use an EPG without entering into a subscription contract with TMS, you can create and upload a CSV file that contains program descriptions that you have entered. 

• Adding New Channels 

• Using Channel Descriptions from a CSV File 

• Adding or Editing Subscriptions to Data from an EPG Provider 

• Deleting the Settings That Define an EPG Data Subscription 

• Synchronizing TV Channel Schedules and Program Descriptions for the EPG 

Adding or Editing Subscriptions to Data from an EPG Provider 
You use elements on the EPG Providers page to define the settings for your EPG data subscriptions, view a summary of all subscriptions that you have defined and, optionally, choose whether to edit, delete, or synchronize a 
subscription. 
For information about associating a subscription with a channel, see Adding New Channels. 

Procedure 

Step 1 Click the EPG Providers tab. 

Step 2 Do one of the following: 

• To define the settings for a new subscription, click Add an EPG Provider. 

• To edit a subscription that you defined previously: 

a. In the EPG Provider Name column, identify the subscription to be edited; then, click the corresponding arrow ( ) in the Actions column. 
The Actions menu expands so that you can see and choose among its options. 

b. Click Edit. 
A dialog box opens, in which you can define or edit the attributes for this subscription. 

Step 3 Choose the options or enter the values that meet your requirements, as described in Table 3-13. 

Step 4 Do one of the following: 

• To save your entries, do one of the following: 

– If you are defining a new subscription, click Add Provider. 
– If you are editing a subscription that you defined previously, click Update Provider. 

• To discard your entries, click Cancel. 

UI Reference: EPG Provider Settings 

Table 3-13 Elements for Defining EPG Subscription Settings  

Element Description 

Provider Name The name that you use to distinguish this provider from all other providers. 
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Data Format The file format for your subscription data, after you download and decompress it. One of these: 
• Tribune Media Services - TV Schedules 
• XMLTV 

Host or IP 
Address 

The routable IP address or DMS-resolvable hostname of the ftp server where you obtain EPG data from your subscription provider. 

Username Your username to log in to the specified ftp server. 

Password The password to authenticate your username to the specified ftp server. 

Remote Path The ftp server subdirectory path where EPG data files are stored for your subscription. 
Enter the full pathname, including the actual filename for the .gz (gzipped) archive, if the data format is XMLTV. For example, you might enter pub/xmltv.xml.
gz. 

 
Proxy Settings (Optional) 

Proxy Hostname The routable IP address or DMS-resolvable hostname and port number of the proxy server that your DMM appliance should use if it does not have direct 
Internet access. 

Note Do not enter a colon before the port number. 
Note Do not configure proxy settings for DMM appliances that have direct access to the Internet. 

Proxy Port 

 
Automatic Synchronization Time 

Hour The exact time of day when your DMM appliance should synchronize its program guides for Enterprise TV with the latest available EPG data from your 
service provider. 

Minute 

 
Deleting the Settings That Define an EPG Data Subscription 
Procedure 

Step 1 Click the EPG Providers tab. 

Step 2 In the EPG Provider Name column, identify the subscription to be deleted; then, click the corresponding arrow ( ) in the Actions column. 

The Actions menu expands so that you can see and choose among its options. 

Step 3 Click Delete. 

Step 4 Click Yes to delete the subscription, when prompted to confirm your choices. 
Alternatively, click No to retain the subscription. 

Synchronizing TV Channel Schedules and Program Descriptions for the EPG 
Procedure 

Step 1 Click the EPG Providers tab. 

Step 2 In the EPG Provider Name column, identify the subscription whose TV channel schedules and program descriptions should be synchronized to your EPG; then, click the corresponding arrow ( ) in the 
Actions column. 

The Actions menu expands so that you can see and choose among its options. 

Step 3 Click Synchronize. 

The Performing EPG Synchronization dialog box opens. It shows a progress indicator ( ) that spins until synchronization has finished. The dialog box then closes itself automatically. 

Step 4 (Optional) To dismiss the dialog box and perform synchronization in the background so that you can continue your work, click Run in Background. 

Configuring Enterprise TV Settings for Video on Demand 
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Activation Video-on-demand (VoD) features for Enterprise TV depend upon the media library features for digital signage. Therefore, even though the DMM-ETV and DMM-DSM software modules are 
licensed separately and can operate independently of one another in most ways, you cannot use VoD features for Enterprise TV unless you have installed the 
licenses for both DMM-ETV and DMM-DSM. 

• Working With VoD Categories 

• Mapping a Video to a VoD Category 

• Organizing Videos in VoD Categories 

• Removing a Video from a Category 

Working With VoD Categories 
Categories help you to manage how VoDs are organized for the interactive menu system at sites where you deploy Enterprise TV. 

• Adding a New VoD Category 

• Adding a New VoD Subcategory 

• Editing a VoD Category 

• Deleting a VoD Category 

• Mapping a Video to a VoD Category 

• UI Reference: VoD Categories 

Adding a New VoD Category 
Procedure 

Step 1 Choose Video on Demand > Categories. 

The Categories area is on the left, and after you click a category, a table on the right describes the videos that are mapped to that category. 

Step 2 Click Actions > Create a Category. 

Step 3 Enter a descriptive name for the category. 

Step 4 Click Save. 
Alternatively, click Cancel to discard your work. 

Related Topics 
• Working With VoD Categories 

• UI Reference: VoD Categories 

Adding a New VoD Subcategory 
Procedure 

Step 1 Choose Video on Demand > Categories. 

The Categories area is on the left, and after you click a category, a table on the right describes the videos that are mapped to that category. 

Step 2 Click the category that should contain the subcategory. 

Step 3 Choose Actions > Create a Category. 

Step 4 Enter a descriptive name for the subcategory. 

Step 5 Click Save. 
Alternatively, click Cancel to discard your work. 

Related Topics 
• Working With VoD Categories 

• UI Reference: VoD Categories 

Editing a VoD Category 
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Procedure 

Step 1 Choose Video on Demand > Categories. 

The Categories area is on the left, and after you click a category, a table on the right describes the videos that are mapped to that category. 

Step 2 Click the name of the category to be edited. 

Step 3 Choose Actions > Modify Category. 

Step 4 Edit the values. 

Step 5 Click Save. 
Alternatively, click Cancel to discard your work. 

Related Topics 
• Working With VoD Categories 

• UI Reference: VoD Categories 

Deleting a VoD Category 
Procedure 

Step 1 Choose Video on Demand > Categories. 

The Categories area is on the left, and after you click a category, a table on the right describes the videos that are mapped to that category. 

Step 2 Click the name of the category that you want to delete. 

Step 3 Click Actions > Delete Category. 

The Delete Confirmation dialog box opens. 

Step 4 Click Yes to delete the category. 
Alternatively, click No to retain it. 

Related Topics 
• Working With VoD Categories 

• UI Reference: VoD Categories 

UI Reference: VoD Categories 
Navigation Path 
Enterprise TV > Video on Demand > Categories 

Table 3-14 Elements for Managing VoD Categories  

Element Description 

Categories selector A hierarchical tree (an object selector) of VoD categories. Highlight the name of a category to designate it as the one that should contain a VoD that you 
will map to it. 

Actions Options that you can choose, whose effect is relative to the category that you chose. 
• Create a Category 
• Modify Category 
• Delete Category 

untitled table Each row describes one VoD asset that is mapped to a category for Enterprise TV. Asset attributes that these columns describe are derived from 
records in your media library: 

• Title 
• Description 
• Duration 
• Source 
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Map Videos to 
Category 

Opens a dialog box in which you can choose the videos to be mapped. 

 
Mapping a Video to a VoD Category 
Each video that you map to a category will be listed as a VoD in the interactive menu system at sites where you deploy Enterprise TV. 
Before You Begin 

• Add the video to your shared Media Library for digital signage and Enterprise TV. 
• Create the category. See Working With VoD Categories. 

Procedure 

Step 1 Click the Video on Demand tab. 

Step 2 In the Categories area, click the name of the category to which you will add a video. 

Step 3 In the area that lists videos, click Map Videos to Category. 

The VoD Mapping dialog box opens. A tree on the left shows the hierarchy of categories for assets in your shared Media Library and, after you click a category, an untitled table on the right describes each asset in that category. 

Step 4 Click the Media Library category that contains the video that you want to use as a VoD. 

The videos in this category are described in the untitled table on the right. 

Step 5 Click the name of the video, and then drag and drop it to the area below. 

Tip To choose more than one video, press the Shift key while clicking the names of videos. 

Step 6 Do one of the following: 

• To add the video, click Submit Mapping. The category that you chose is now part of the categories tree on the Video on Demand page. When you choose that category in the tree, the untitled table on the left 
side of the page describes each video that you added as a VoD. 

• To discard your entries, click Cancel. 

Organizing Videos in VoD Categories 
When you organize the videos in a VoD category, you set the order in which Enterprise TV shows the videos at your deployment sites. 
Procedure 

Step 1 Click the Video on Demand tab. 

Step 2 In the Categories area, click the name of the category that includes the videos to be organized. 

The videos in this category are described in the untitled table on the right. 

Step 3 Click the name of the video; then, drag and drop it to its new location in the list. Videos that are higher in the list will be shown before videos that are lower in the list. 

Removing a Video from a Category 
When you remove a video from a category on the Video on Demand page, you remove it also from the interactive menu system at sites where you deploy Enterprise TV. 
Procedure 

Step 1 Click the Video on Demand tab. 

Step 2 In the area that lists videos, click Map Videos to Category. 

The VoD Mapping dialog box opens. 

Step 3 Click the Remove link that corresponds to a video that should be removed. 
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Using `Skins' to Customize the Enterprise TV Menu System 
You can customize the interactive menu system that is presented to viewers at your deployment sites and choose which features this menu should include. 

• Choosing the Color Scheme for Your Menu System 

• Specifying Which Features Your Menu System Should Include 

• Showing a Custom Logo in Your Menu System 

• Showing the Cisco Logo in Your Menu System 

• Choosing the Date and Time Formats for Your Menu System 

• Deploying Menu System Customizations to Your DMPs 

Choosing the Color Scheme for Your Menu System 
Procedure 

Step 1 Click the Skin Customization tab. 

Step 2 In the Choose a Skin area, click the radio button for the color scheme that you want. 

Step 3 Click Save to save your work. 
Alternatively, click Cancel to discard it 

Tip Menu customizations do not take effect until you deploy them to DMPs. 

Related Topics 
• Deploying Menu System Customizations to Your DMPs 

Specifying Which Features Your Menu System Should Include 
Procedure 

Step 1 Click the Skin Customization tab. 

Step 2 In the Features to Include in the Enterprise TV Main Menu area, check the check box for each feature that the menu system should include: 

• Electronic Programming Guide 

• Video on Demand 

• Live TV Channels 

Step 3 Click Save to save your work. 
Alternatively, click Cancel to discard it 

Tip Menu customizations do not take effect until you deploy them to DMPs. 

Related Topics 
• Deploying Menu System Customizations to Your DMPs 

Showing a Custom Logo in Your Menu System 
Procedure 

Step 1 Click the Skin Customization tab. 

Step 2 In the Upload a Custom Logo area, click Browse. 

Step 3 Choose the file to be uploaded, and then click Open. 
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Step 4 Click Preview to view the logo file. 

Step 5 Check the Display Custom Logo check box. 

The logo appears in the upper right of the menu system. 

Step 6 Click Save to save your work. 
Alternatively, click Cancel to discard it 

Tip Menu customizations do not take effect until you deploy them to DMPs. 

Related Topics 
• Deploying Menu System Customizations to Your DMPs 

Showing the Cisco Logo in Your Menu System 
Procedure 

Step 1 Click the Skin Customization tab. 

Step 2 Check the Display Cisco Logo check box. 

The logo appears in the lower left of the menu system. 

Step 3 Click Save to save your work. 
Alternatively, click Cancel to discard it 

Tip Menu customizations do not take effect until you deploy them to DMPs. 

Related Topics 
• Deploying Menu System Customizations to Your DMPs 

Choosing the Date and Time Formats for Your Menu System 
Procedure 

Step 1 Click the Skin Customization tab. 

Step 2 Choose either mm/dd/yyyy or yyyy/mm/dd from the Date Format list, where: 

• mm is the month 

• dd is the date in the month 

• yyyy is the year 

Step 3 Check the Use Military Time check box if your menu system should use a 24-hour clock that counts from 00:00 to 23:59 the hours that pass from one midnight to the next.  
Alternatively, uncheck this check box if your menu system should use a 12-hour clock that counts from 12:00 to 11:59 the hours that pass from midnight to noon (designated as a.m.), and again from noon to midnight 
(designated as p.m.). 

Step 4 Click Save to save your work. 
Alternatively, click Cancel to discard it 

Tip Menu customizations do not take effect until you deploy them to DMPs. 

Related Topics 
• Deploying Menu System Customizations to Your DMPs 
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Deploying Menu System Customizations to Your DMPs 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Choose the DMP or DMP group that should use this menu skin. 

Step 3 Choose ETV-PG from the Actions list, and then click Go. 

Related Topics 
• Managing and Grouping Your DMPs 

Using DMP Local Storage for Enterprise TV VoD Playback 
If your WAN has limited bandwidth that would reduce the playback quality for VoD programs that Enterprise TV receives over your network or if you do not have a dedicated content delivery solution in place, such as WAAS or 
ACNS, you can provision Enterprise TV assets directly to a DMP, for storage on: 

• Its internal SD flash memory card (usb_1). 
• An external USB drive (usb_2), which you have attached to the DMP. 

This technique conserves WAN bandwidth and avoids latency that might detract from the quality of your Enterprise TV VoD programming. 
Procedure

 Workflow Actions 

Step 1  Create the DMP group whose member DMPs 
should all store local copies of your VoD assets. 

See Managing and Grouping Your DMPs. 

Step 2  Define your channel lineup for Enterprise TV. See Adding New Channels. 

Step 3  Customize your Enterprise TV menu system. See Using `Skins' to Customize the Enterprise TV Menu System. 

Step 4  Define VoD categories for Enterprise TV. See Working With VoD Categories. 

Step 5  Add video assets to your shared media library. See: 
• Adding One Asset at a Time to Your Media Library. 

• Adding Multiple Assets Simultaneously to Your Media Library. 

Step 6  Populate your VoD categories with video assets 
from your media library. 

See Mapping a Video to a VoD Category. 

Step 7  Verify that the FTP service is enabled on the 
target DMPs. 

See System Tasks. 

Step 8  Create a deployment package for the 
Enterprise TV program guide. 

a. Choose Digital Media Players > Advanced Tasks. 

b. Choose Deployment Package from the Application Types list. 

c. Click  Add New Application. 

d. Choose Enterprise TV from the Applications list. 

e. Enter Deploy-Local-ETV in the Name field. 

f. Choose an option from the Mount Point list: 

• Choose Flash Storage (default) if "usb_1" — an SD memory card that is 
installed inside your DMP — should be the mount point. 

• Choose USB if "usb_2" — an external hard drive or flash drive that you have attached to 
your DMP — should be the local mount point. 

g. Click the name of your Enterprise TV program guide, and then click Select 
Application. 

h. Click Submit. 
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Step 9  Provision your Enterprise TV program guide to 
DMPs that should serve on-demand video from 
their local storage. 

If the Program Guide Should be Provisioned Now 
a. Choose Schedules > Play Now. 

b. Choose the DMP or the DMP group that should receive this deployment. 

c. Choose Advanced Tasks from the Select an Event Type list, and then click 
Select Advanced Tasks. 

d. In the Select Event dialog box: 

1. Click Deployment Package. 
2. Click Deploy-Local-ETV, or whichever other name you used in -e. 

3. Click OK. 
e. Click Submit, and then go to . 

If the Program Guide Should be Provisioned in the Future 
a. Choose Schedules > Play in Future. 

b. From the calendar, choose the year, month, and day when the deployment should start. 

c. Choose Advanced Tasks from the Add an Event list under the timeline. 

d. In the Schedule Task dialog box (and the dialog boxes that it spawns): 

1. Click Select Group, click the group name, and then click OK. 
2. Click Select Advanced Tasks, click Deployment Package, and 
then click OK. 
3. Edit date and time values and the settings for recurrence. 
4. Verify that the deployment start and stop times occur the logical order, and differ. 
5. Click Save. 

e. Click Save All. 

Note You must click Save All. If you do not click it, the schedule discards your selections 
immediately after you refresh your browser or load any other page. 

f. Click Publish All, and then go to 

Step 10  Transfer your customized menu system, 
channels list, VoD playlist, and video assets to 
DMPs. 

Choose whether to use DMS-CD or the legacy "File Transfer to DMP or Server" feature. 
• If you will use DMS-CD, see Using DMS-CD Deployment Packages to Provision Assets to 
DMPs. 

• If you will use the legacy method, see File Transfer to DMP or Server. 

Note We recommend that you use DMS-CD instead of the legacy method, which is deprecated. 
When you use the "File Transfer to DMP or Server" feature to provision assets to DMP local 
storage, these assets are saved to the flash memory card (usb_1) that is preinstalled inside the 
DMP. You cannot use this feature to transfer assets to any external USB drive (usb_2) that you 
might have attached to the DMP. Furthermore, this feature lacks the differential download 
intelligence that is built into DMS-CD. 

Step 11  Monitor progress and the current status of your 
deployment. 

a. Choose Digital Media Players > Deployment Manager > 
Deployment Status. 

b. (Optional) Use filtering options above the table to limit how many deployment packages 
the table describes. 

Related Topics 
• About the Built-in Mechanism for Content Distribution, DMS-CD 

• Scheduling Time Slots for Media and Events on DMPs 

Emulating the DMP Remote Control for Enterprise TV 
Topics in this section describe a software-based emulator that you can use in place of, or in addition to, the remote control unit for a DMP. 
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Note • Although Cisco sells a physical remote control device for use with DMPs that deliver Enterprise TV programming to their attached displays, the remote control unit is an optional accessory for a DMP. To obtain 
one of these remote control units as a spare part, order Cisco part number 74-5639-01. 
• To learn about the remote control unit, see Remote Control Quick Start Guide for Cisco Digital Media Players and Regulatory Compliance and Safety Information for the Cisco Digital Media Player Remote Control on 
Cisco.com. 
• The emulated remote control supports changing channels for Enterprise TV, navigating in the Enterprise TV menu system, and adjusting audio volume settings for a DMP. 

• Workflow in Cisco Unified Communications Manager to Provision the Emulator for IP Phones 

• Configuring Emulator Settings in DMM-ETV 

• Configuring an IP Phone to Emulate the Remote Control 

• Starting the Emulator on an IP Phone 

• Starting the Emulator on a Mobile Phone 

• Using the Emulator on an IP Phone or a Mobile Phone 

Workflow in Cisco Unified Communications Manager to Provision the Emulator for IP Phones 
You can provision the Enterprise TV remote control emulator for use on Cisco IP phones. 
Before You Begin 
This workflow assumes that you are experienced as an administrator in Cisco Unified Communications Manager and that you use it already to manage a network of IP phones. 

Tip Skip this workflow if you will not use any IP phones to emulate the remote control for Enterprise TV. 

Note This workflow is based on Cisco Unified Communications Manager release 6.1. If you use any other release, the workflow might differ slightly in your network. We recommend that you read on Cisco.com the particular 
revisions of these guides that apply to your network: 

• Cisco Unified Communications Manager Administration Guide 
• Cisco Unified Serviceability Administration Guide 

Procedure

 Workflow Actions 

Step 1  Activate all services. a. Log in to Cisco Unified Communications Manager Administration. 

b. Choose Cisco Unified Serviceability from the Navigation list, and then 
click Go. 

c. Choose Tools > Service Activation. 

d. Click the Server list and choose from among its options the server where the remote control 
emulation service should be activated for Enterprise TV. 

e. Click Go. 

f. Check the Check All Services check box, and then click Save. 

g. Click OK. 

Step 2  Start all services. a. Choose Tools > Control Center - Feature Services. 

b. Click the Server list and choose from among its options the server where the remote control 
emulation service should be started for Enterprise TV. 

c. Click Go. 

d. Repeat as many times as necessary until every service is running: 
Click the radio button for any service that is not yet running, and then click Start. 
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Step 3  Configure enterprise parameters for the phone 
URL. 

a. Choose Cisco Unified CM Administration from the Navigation list, and then 
click Go. 

b. Choose System > Enterprise Parameters., and then scroll to the Phone URL 
Parameters area. 

c. Verify that you have not changed the factory-default values for any of these parameters: 

• URL Authentication 

• URL Directories 

• URL Information 

• URL Services 

d. Click Save. 

Step 4  Enable autoregistration of IP phones. a. Choose System > Cisco Unified CM, and then click Find. 

b. Click the name of the server whose managed IP phones should be autoregistered. 

c. Uncheck the Auto-registration disabled on this Cisco Unified Communications Manager check 
box. 

d. Edit the range of values that starts in the Starting Directory Number field and ends in the 
Ending Directory Number field. 

e. Click Save. 

Step 5  Define attributes of the emulator phone 
service. 

a. Choose Cisco Unified CM Administration from the Navigation list, and then 
click Go. 

b. Choose Device > Device Settings > Phone Services. 

c. Click Add New. 

d. Enter Enterprise TV in both of these fields: 
  ·    Service Name 
  ·    ASCII Service Name 

e. Enter this URL in the Service URL field: 
http://<DMM_hostname>:8080/etv-remotecontrol-webapp/app/getpin 

f. Click Save. 

Step 6  Make the emulator service available to each 
IP phone that should subscribe to it. 

a. Choose Cisco Unified CM Administration from the Navigation list, and then 
click Go. 

b. Choose Device > Phone. 

c. Click Find. 

d. Repeat this sequence of actions for each phone that should subscribe to the emulator: 

1. Click the name, in the Device Name (Line) column, of the managed IP phone that you will 
configure. By default, this name is just SEP prefixed to the MAC address of the phone. 

Your server might be configured to use some other naming format. 
2. When the page refreshes, choose Subscribe/Unsubscribe Services from 
the Related Links list. 

A popup window opens. 
3. Choose Enterprise TV from the Select a Service List, and then click Next. 
4. Choose Enterprise TV from the ASCII Service Name list, and then click 
Subscribe. 
5. Verify that the message in the Status area says, "Add successful," and that the 
Subscribed Services area includes "Enterprise TV." 
6. Close the popup window. 
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7. Click Go. 

Note Emulator-related configuration changes that you make on your Cisco Unified Communications Manager server do not become useful until after you also configure DMM-ETV to serve the emulator, and configure at least 
one IP phone to run the emulator. 

Related Topics 
• Configuring Emulator Settings in DMM-ETV 

• Configuring an IP Phone to Emulate the Remote Control 

• Using the Emulator on an IP Phone or a Mobile Phone 

Configuring Emulator Settings in DMM-ETV 
Procedure 

Step 1 Choose Enterprise TV > Remote Control. 

Tip The first time that you use this feature, you might notice that options are dimmed and not available to you. Click Save to activate all options so that you can choose options. 

Step 2 Choose an option from the Display Security PIN on screen list, to set how many of your DMPs should support the emulator: 

• All DMPs 

• Selected DMPs 

• None 

Tip If you choose None in Step 2, the Display DMP Selections button is dimmed and not available to you. To see and use this button, you must choose either All DMPs or Selected DMPs. 

Step 3 If you chose Selected DMPs in Step 2, click Display DMP Selections to open a dialog box where you can refine your list of which DMPs should support the emulator. In this dialog box: 

a. Use the check boxes to select and deselect DMPs. 

b. Click Save Selection Changes to save your work, and then click Close to dismiss the dialog box.  
Alternatively, click Close to discard your work and close the dialog box. 

Step 4 Choose an option from the Security PIN behavior list. Although Enterprise TV randomly generates all of its emulator PINs, the fixed and dynamic types differ in their persistence: 

• Fixed — These PINs persist until the PIN management type is changed. 

• Dynamic — These PINs expire and then are regenerated after an update interval that you define. 

No two DMPs in your network will use the same PIN at any one time. 

Step 5 If you chose the dynamic PIN type in Step 4, enter at least one digit in the Security PIN update interval (minutes) field. The interval cannot be any less than 2 min. If you do not enter any value, DMM-ETV uses 
its factory-default interval of 5 min. 

Step 6 Enter a shortened URL in the Access URL field for a page that will redirect ultimately to http://<DMM_hostname>:8080/etv-remotecontrol-webapp/app/index.htm. 

Note The shortened URL must not be more than 24 characters long. 

Step 7 Click Save.  
Alternatively, to discard your selections and start over again, click Cancel. 

Step 8 Deploy the new emulator settings to your DMPs: 

a. Choose Digital Media Players > DMP Manager. 
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b. Choose the DMP or DMP group that should use these settings. 

c. Choose ETV-PG from the Actions list, and then click Go. 

Related Topics 
• Workflow in Cisco Unified Communications Manager to Provision the Emulator for IP Phones 

• Configuring an IP Phone to Emulate the Remote Control 

• Starting the Emulator on an IP Phone 

• Starting the Emulator on a Mobile Phone 

• Using the Emulator on an IP Phone or a Mobile Phone 

Configuring an IP Phone to Emulate the Remote Control 
You can configure a Cisco IP Phone from the 7960 series or the 7970 series to emulate the remote control for Enterprise TV, and then use keys drawn on its touchscreen to choose options from the electronic program guide, 
change channels, and adjust audio volume levels. 
Before You Begin 
Complete the workflow in Cisco Unified Communications Manager to provision the emulator to your IP phones. 
Procedure 

Step 1 Press Settings on your Cisco IP phone. 

Step 2 Press * * #. 

A confirmation message at the bottom of the touchscreen says, "Settings Unlocked!" 

Step 3 Go to Network Configuration, and then press Select. 

Step 4 Go to Alternate TFTP, and then press Yes. 

Tip If Alternate TFTP is not an option in the Network Configuration menu, contact the administrator for Cisco Unified Communications Manager. 

Step 5 Click Save. 

The IP phone is restarted automatically, so that its configuration changes can take effect. 

Related Topics 
• Workflow in Cisco Unified Communications Manager to Provision the Emulator for IP Phones 

• Using the Emulator on an IP Phone or a Mobile Phone 

Starting the Emulator on an IP Phone 
Before You Begin 

• Provision the emulator for use on Cisco IP phones. 
• Configure emulator settings in DMM-ETV. 
• Configure your IP phone to emulate the remote control. 
• Make note of the generated PIN code in the top-right corner of a DMP display that is showing Enterprise TV. The emulator cannot control the corresponding DMP without this PIN. 

Procedure 

Step 1 Press Services on your Cisco IP phone. 

Step 2 Highlight the remote control option in the services list, and then press Select. 

Step 3 Tap the PIN field on your touchscreen. 

Step 4 Use the keypad to enter the PIN code. 

Step 5 Tap Submit on the touchscreen. 

The touchscreen is refreshed and the emulator starts. 
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Related Topics 
• Workflow in Cisco Unified Communications Manager to Provision the Emulator for IP Phones 

• Configuring Emulator Settings in DMM-ETV 

• Using the Emulator on an IP Phone or a Mobile Phone 

Starting the Emulator on a Mobile Phone 
Before You Begin 

• Configure emulator settings in DMM-ETV. 
• Make note of the generated PIN code in the top-right corner of a DMP display that is showing Enterprise TV. The emulator cannot control the corresponding DMP without this PIN. 
• This procedure assumes that you are using a supported platform. To learn which mobile phone platforms we support in this release, see Release Notes for Cisco Digital Media System 5.x on Cisco.com. An 
unsupported platform might not be capable of running the emulator. 

Procedure 

Step 1 Start the Internet browser on your mobile phone. 

Step 2 Go to the URL that you see on the DMP display that is showing Enterprise TV. 

You are prompted to enter the PIN. 

Step 3 Enter the PIN, and then click Go. 

The emulator starts. 

Related Topics 
• Configuring Emulator Settings in DMM-ETV 

• Using the Emulator on an IP Phone or a Mobile Phone 

Using the Emulator on an IP Phone or a Mobile Phone 
Before You Begin 

• (If you will use the emulator on an IP phone) Complete the workflow in Cisco Unified Communications Manager to provision the emulator to your IP phones. 
• Configure emulator settings in DMM-ETV. 
• Start the emulator on your phone. 

Procedure 

Step 1 See Remote Control Quick Start Guide for Cisco Digital Media Players on Cisco.com, and pay particular attention to its sections called "Using the Primary Buttons" and "Using the Secondary Buttons." Their 
descriptions of the remote control and its effect in a variety of scenarios apply equally to the physical remote control unit and to its emulator. 

Note The emulator has fewer buttons than the physical remote control has. You cannot invoke behaviors from the emulator which correspond to any buttons that it does not have. 

Related Topics 
• Workflow in Cisco Unified Communications Manager to Provision the Emulator for IP Phones 

• Configuring Emulator Settings in DMM-ETV 

• Starting the Emulator on an IP Phone 

• Starting the Emulator on a Mobile Phone 

Working with Assets and Categories in Your Media Library 
Activation Software feature modules for Cisco DMS are purchased and licensed separately. Features are hidden from all users until you purchase and install the required license to use them, and even 
then remain hidden from users whose privilege levels are low. To understand feature licenses and learn how to install them, see Managing Licenses for Features and Components of Cisco DMS, page 2-
3. To learn how user access to features is restricted by the combination of licenses and user privilege levels, see Understanding User Roles in DMS-Admin, page 2-9. To learn which software feature 
modules are available for you to purchase, see http://www.cisco.com/go/dms. 

To simplify management, you can organize your assets for digital signage and Enterprise TV. We recommend that you create categories for sets of characteristics that your assets have in common — such as their file type, 
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intended audience, or genre. 

Note This release does not support audio in Shockwave Flash media. If your media library contains any Shockwave Flash files that use audio, their playback will be silent on your DMP displays. 

Before You Begin 
To see and use the Media Library, you must be: 

• Using a DMM appliance on which a valid license is installed for DMM-DSM. 
• Logged in as a user with at least read-only permissions for at least one category. 

Procedure 

Step 1 Click the Media Library tab. 

A tree on the left side of the Media Library page names the types of media that are supported and shows the hierarchy of categories that you have created to organize assets without regard for their media type. 

Step 2 Click the name of a media type or of a category. 

An untitled table on the right side of the page is updated automatically to describe assets of the relevant type that your library contains. 

Step 3 (Optional) Use filtering controls above the table, so that it describes only a narrow subset of your assets, based on criteria such as the title, file type, or duration. 

Step 4 Enter the values and choose the options that meet your requirements. 

Related Topics 
• UI Reference: Elements to Manage Assets and Categories 

• Understanding Restrictions for Enterprise TV 

UI Reference: Elements to Manage Assets and Categories 
Navigation Path 
Digital Signage > Media Library 

Table 3-15 Elements for Managing a Media Library  

Element Icon and Description 

Media Types A complete list of the types of assets that are supported. The supported assets are: 

• DMP Firmware ( )  

• HTML ( )  

• Images ( )  

• Shockwave Flash ( )  

• UDP ( )  

• Video ( )  
When you click the name of a media type, an untitled table on the right side of the page is updated automatically to describe assets of the relevant type that 
your library contains. 
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Categories A hierarchical list (an object selector) of all categories in your media library. A category can contain assets or it might be empty. You can create new 
categories, edit existing categories, delete categories, or click a category whose assets the untitled table should describe. You can add almost any number 
of nested categories to your media library. 

Options — A menu from which you can choose among these options: 
• Create Category — Opens the Add Category dialog box. 
• Rename Category — Opens the Edit Category dialog box. 
• Delete Category — Deletes the category that you highlighted. 

Create Category — Opens the Add Category dialog box. 

 
Filter by 

Methods by which you can cause the untitled table to describe only the assets from your media library that match parameters you have specified. Choose the filtering method, 
specify the parameters, and then click Go. You can use only one filter per query. You cannot apply a second filter to results that are already filtered. 

Title Enter at least one word that the title contains. 

Filename Enter a string of characters that the filename contains. 

Description Enter at least one word that the description contains. 

File Type Enter the file type to be matched. 

Estimated Duration Enter in hours, minutes, and seconds, the duration to be matched. 

Date Modified 

Click the first calendar icon ( ) to choose the start date for the range of modification dates to be matched, and then click the second calendar 
icon to choose the end date for the range. 

Owner Enter the DMM username for the asset owner to be matched. 

Source Choose whether the asset is stored locally (File) or remotely (URL). 

Path Enter a string of characters that the path contains. 

 
untitled table 

Describes all assets contained in the category, or of the media type, that you clicked in the object selector. The table sorts information into columns. 

Asset Title A unique and human-readable title that you entered. 

Filename The filename for this asset. 

File Type Identifies the format of the asset that the corresponding row describes. 

Size The file size in bytes. 

Estimated Duration The duration value that you entered when you added this asset to your media library, or when you edited attributes of this asset. 

Date Last Modified Time stamp (in the format DD-MM-YYYY hh:mm:ss) that says when the file was last modified. 

 
pagination controls 

Buttons and fields clustered under a table, by which you: 
• Set how many rows a table should show per page before it starts to span multiple pages. 
• Move from one page to another in a table that spans multiple pages. 
• Cause the table to show refreshed data. 

 
Options 
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Choose the option, if any, that meets your requirements 

Add Media Asset Opens the Add Asset dialog box. 

View Media Asset Opens the View Asset dialog box. 

Edit Media Asset Opens the Edit Asset dialog box. 

Remove Media 
Asset 

Deletes the asset that you highlighted. 

Add Media Asset Opens the Add Asset dialog box. 

Create Playlist Opens the New Playlist dialog box in a popup window. 

 
Related Topics 

• UI Reference: Elements to Add Categories and Rename Them 

• UI Reference: Elements to Add Assets and Edit Their Attributes 

UI Reference: Elements to Add Categories and Rename Them 
The Add Category and Rename Category dialog boxes help you to manage the categories for organizing assets in your media library. 
Navigation Path 

• Digital Signage > Media Library > Create Category 
• Digital Signage > Media Library > Options > Create Category 
• Digital Signage > Media Library > Options > Rename Category 

Table 3-16 Elements for Managing Media Library Categories  

Element Description 

Name A unique and human-readable name for a category. 

Description A brief description of the category and its purpose. 

 
About the Maximum File Size for Assets in Your Media Library 

• Before you add any asset, confirm that its file size is not more than 1.9 GB, which is the maximum stream size for any asset that you include in the layout for a DMD presentation. 
• For purposes of stage-one failover, the combined size of all assets cannot exceed the capacity of the SD card in a DMP. To understand failover, see the "Understanding Content Substitution (Failover)" topic in User 
Guide for Cisco Digital Media Player Device Manager 5.1 on Cisco.com. 

Adding One Asset at a Time to Your Media Library 

Note • After you start to import an asset, do not click any browser button or navigate away from this page until the import is finished. If you do, the import will not finish successfully. 
• We recommend that you do not use your DMM appliance as if it is a storage server. It has limited capacity to store files and DMM might not function as designed if space runs low. 

Procedure 

Step 1 Click the Single tab. 

Step 2 Do one of the following in the Source area to specify the full local pathname or remote HTTP URL of the asset: 

• Click URL, enter the URL, and then check or uncheck the Download URL check box to control whether you download a local copy of the asset or use the version of it that is stored remotely. The URL must be 
encoded properly (using "%20" instead of spaces, for example), according to the principles set forth in RFC 2396. 

• Click Local File, and then click Browse or enter the full local pathname. 

Step 3 Choose the option in the File Type area that best describes the asset. 

Step 4 Enter a title for the asset. 

Step 5 Enter the estimated duration for playback. 

Step 6 Choose at least one category. 
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Step 7 (Optional) Enter a description. 

Step 8 (Optional) Enter an owner for the asset. 

Step 9 Click Save.  
Alternatively, to discard your selections, click Cancel. 

Adding Multiple Assets Simultaneously to Your Media Library 
The amount of time that a batch download operation requires depends on the speed of your connection, the number of directory levels that you search for downloadable files, and the total combined file size of all files that you 
transfer. 

Note • After you start to import an asset, do not click any browser button or navigate away from this page until the import is finished. If you do, the import will not finish successfully. 
• We recommend that you do not use your DMM appliance as if it is a storage server. It has limited capacity to store files and DMM might not function as designed if space runs low. 

Procedure 

Step 1 Click the Batch tab. 

Step 2 Enter, in the Base URL area, the root-level URL for the batch download operation. 

We do not support any use of spaces in URLs. 

Step 3 Enter, in the Pattern area, a filename pattern that identifies which files to download. 

For example, to download every file that uses the three-letter MPG filename extension, the pattern is *.MPG. 

Note Do not enter the filename pattern to use any unsupported file type. 

Step 4 Make choices and enter values to add assets to your library, and then click Save.  
Alternatively, to discard your selections, click Cancel. 

UI Reference: Elements to Add Assets and Edit Their Attributes 
Features of the Add Media Asset and Edit Media Asset dialog boxes help you to populate and manage your media library. Options are sorted under two tabs, Single and Batch, which help you to manage either one asset or 
multiple assets, respectively. 
Navigation Path 

• Digital Signage > Media Library > Add Media Asset 
• Digital Signage > Media Library > Options > Add Media Asset 
• Digital Signage > Media Library > Options > Edit Media Asset 

. 

Table 3-17 Elements for Adding and Editing Assets  

Element Description 

 
Single tab 

Elements to add or edit one asset. 

Source The full local pathname or remote HTTP URL of the asset. We do not support any use of spaces in filenames or URLs. 
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File Type Choose the type that best describes the asset: 
• Video — A video file in MPEG-1, MPEG-2, or MPEG-4 format. Our support for MPEG-4 requires that you use the MPEG-4 Part 2 or Part 10 
(H.264) codec and that you multiplex audio and video in an MPEG-2 Transport Stream. If your DMP is a 4400G, we support MPEG-4 Part 10/H.264 video 
in MPEG-2 TS. (Neither the 4300G nor the 4305G supports MPEG-4 Part 10/H.264.) The filename extension must be MPG or MPEG and you must enter 
the estimated duration. 
• Shockwave Flash — An Adobe Shockwave Flash 6, or 7 file if your DMP is a 4300G or a 4305G. Alternatively, if your DMP is a 4400G, and 
then a file in the format of Shockwave Flash 6, 7, 8, 9, or 10. The filename extension must be SWF and you must enter the estimated duration. This 
release does not support audio in Shockwave Flash media. If your media library contains any Shockwave Flash files that use audio, their playback will be 
silent on your DMP displays. 
• Images — A standard image file, such as a nonprogressive JPEG image. The filename extension must be JPG, JPEG, GIF, or PNG. 
• HTML — A web page. The filename extension must be HTM or HTML. 
• Firmware — A firmware or kernel image for the DMP. The filename extension must be FWIMG or BIN for firmware, or TIVELLA for kernels. 
• UDP — The routable IP address and UDP port for a streaming server. 

Title A unique and human-readable name for the asset. 

Estimated 
Duration 

The estimated duration for playback, counted in hours, minutes, and seconds. 

Category Describes each of the categories that should contain this asset. To add a category to the list, click Select Category. 

Description Optional, brief description of the asset. 

Owner Your name or the name of the person who added the asset. 

 
Batch tab 

Elements to add or edit multiple assets simultaneously. 

Base URL An HTTP URL that points to a directory on a server. The directory that you point to serves as the root-level URL for the batch download operation; every file 
that you download is retrieved from this directory or from one of its children at a lower level. We do not support any use of spaces in URLs. 

Pattern The filename pattern that identifies which files to download. We do not support any use of spaces in filenames. 

File Type Choose the type that best describes these assets: 

• Video1  — A video file in MPEG-1, MPEG-2, or MPEG-4 format. 

• Shockwave Flash2  — Any Adobe Shockwave Flash 6, or 7 file if your DMP is a 4300G or a 4305G. Alternatively, if your DMP is a 4400G, 
any Adobe Shockwave Flash 6, 7, 8, 9, or 10 file. 
• Images — Any standard image file, such as a nonprogressive JPEG image. The filename extension must be JPG, JPEG, GIF, or PNG. 
• HTML — Any web page. The filename extension must be HTM or HTML. 
• Firmware — Any firmware image for the DMP. The filename extension must be FWIMG or BIN for firmware, or TIVELLA for kernels. 
• UDP — The routable IP address and UDP port for a streaming server. 

Levels The number of levels below the specified base URL to search for (and download) files with filenames that match the specified pattern. 

Category Click the name of the one category that should contain these assets. 

1 Our support for MPEG-4 requires that you use the MPEG-4 Part 2 or Part 10 (H.264) codec and that you multiplex audio and video in an MPEG-2 Transport Stream. If your DMP is a 4400G, we support MPEG-4 Part 10/H.264 video in MPEG-2 TS. Neither the 
4300G nor the 4305G supports MPEG-4 Part 10/H.264. The filename extension must be MPG or MPEG and you must enter the estimated duration. 
2 The filename extension must be SWF and you must enter the estimated duration. This release does not support audio in Shockwave Flash media. If your media library contains any Shockwave Flash files that use audio, their playback will be silent on your DMP 
displays. 

 
Related Topics 

• DMP Firmware Upgrade 

UI Reference: Elements that Describe and Preview One Asset 
The View Asset dialog box describes the attributes of one asset in your Media Library and, in some cases, shows a preview. Attribute information is sorted under two tabs, Overview and Usage. Click a tab to see the asset 
attributes that it describes. To close the View Asset dialog box, click Close. 
Navigation Path 
Digital Signage > Media Library > Options > View Media Asset 
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Table 3-18 Elements for Viewing Asset Attributes  

Element Description 
 
Overview tab 

Attributes that are derived from information in your media library include the elements with these field labels: Title, Description, File Type, Estimated Duration, Owner, Category 
Names, and Source. To understand these elements, see UI Reference: Elements to Add Assets and Edit Their Attributes. Other elements on the Overview tab are as follows. 

Preview Either a generic icon that represents the asset type or a thumbnail that you can click to view this 
asset, assuming that its file type is viewable in your browser. 

Path The full HTTP pathname for this asset. 

Size The file size. 

Playlist Count The total count of playlists that contain and are dependent upon this asset. To learn more about 
these playlists, click the Usage tab. 

Presentation Count The total count of presentations that contain and are dependent upon this asset. To learn more 
about these presentations, click the Usage tab. 

Date Modified Time stamp (in the format DD-MM-YYYY hh:mm:ss) that says when the file was last modified. 

 
Usage tab 

Shows either the Playlists for Asset table or the Presentations for Asset table, depending on whether you click Playlist or Presentation, respectively. The table sorts 
information into the following columns. 

Name The name of the presentation or the playlist that is dependent upon this asset. 

Time Referenced The total count of instances when the described presentation or playlist includes this asset. 

Date Modified Time stamp (in the format DD-MM-YYYY hh:mm:ss) that says when the described 
presentation or playlist was last modified. 

 
Understanding the Two Types of Playlists for Digital Signage 
DMM-DSM provides two ways to populate playlists for use in your digital signage network. 
The first type is simply called a playlist. You create this type outside Digital Media Designer (DMD) and you can schedule it to play either as a standalone event or within a presentation that you design in DMD. 
The second type is called a presentation playlist. You create this type inside DMD and include it within a presentation that you design in DMD. You cannot schedule this type to play as a standalone event. 
Related Topics 

• Creating and Organizing Presentation Playlists 

• Creating and Organizing Ordinary Playlists 

Working with Presentations, Templates, and Presentation Playlists for Digital Signage 
Digital Media Designer (DMD) is a powerful, drag-and-drop design tool that helps you to create customized presentations for digital signage. Cisco provides predesigned assets that you can use as a jumping-off point for your 
designs or you can create designs that are entirely your own. DMD supports horizontal and vertical screen orientations. With DMD, you: 

• Subdivide the screen space on a DMP display into rectangular areas called screen zones. 
• Choose the media objects,  called assets, to play back in those screen zones — including media from digital video files, JPEG files, SWF files, RSS feeds, ordinary web pages, and other popular media types. 
• Add assets to, and configure the timeline for, any screen zone that represents a presentation playlist. 

Although you use your browser to start DMD, it runs outside your browser, in Java Web Start. You can open and work with only one template or one presentation at a time. Presentations for digital signage most commonly 
divide screen space into two, three, or four screen zones, but you can create more zones for a presentation in DMD if you need more. 
After you create, edit, and save a presentation, you can deploy it to your DMPs from the scheduler. Each affected DMP then restarts automatically before it starts to show the presentation. To learn how to deploy a presentation 
to your DMPs, see Scheduling Time Slots for Media and Events on DMPs. 

This section contains these topics: 
• Before You Start to Use Digital Media Designer 

• Getting Started with DMD 

• DMD User Interface Reference 

• Creating and Organizing Presentation Playlists 
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• Creating and Organizing Ordinary Playlists 

Before You Start to Use Digital Media Designer 
Use the following checklist to track your compliance with the requirements and recommended best practices for using DMD successfully.

Requirements and Recommendations 

 
Prerequisites 

1. Ensure that Java Runtime Engine (JRE) 1.6.0 or later is installed on your PC. Also confirm that it is configured to use 
English as its language, and that it is working correctly. The JRE 1.6.0 release is part of Java Version 6. 
• To learn exactly which JRE release you are using and to confirm that it is working correctly, go to http://java.com/en/download/help/testvm.xml. 

• To understand the Java release naming conventions, which have changed over time, see http://java.sun.com/javase/namechange.html. 

• To obtain the required JRE, go to http://javasoft.com, click Java SE, and then download the latest JRE version. 

• Apple maintains and distributes its own implementations of Java software for Mac OS users. To learn if Apple has made available any JRE that is based on 
JRE 1.6.0, see http://www.apple.com/java. Alternatively, registered Apple Developer Connection (http://connect.apple.com/) members might find that Apple has 
released a preview version of a compatible JRE. We make no claims about the suitability of such software for any purpose and recommend that you test all 
software thoroughly before you rely on it. 

2. If you use Windows, choose Start > Settings > Control Panel > Internet Options, and then click the Advanced tab. Scroll to the 
Browsing area, uncheck the Enable third party browser extensions (requires restart) check box, and then click OK. 

3. Ensure that your DMPs use the latest firmware and kernel versions. 
To check the firmware version on a DMP, log in to its local instance of DMPDM, and then click About. If you see that you must upgrade the firmware, installable files 
are located on the software CD that you received from Cisco after you: 

• Purchased DMM-DSM 5.1. 

• Paid to upgrade from an earlier release. 

• Used the Product Upgrade Tool (http://www.cisco.com/upgrade) to verify that your valid SAS contract for an earlier Cisco DMS release entitles you to upgrade 
DMM-DSM and your DMPs at no additional cost. 

  

These files are not available for download from Cisco.com. 
• On DMP 4300G endpoints, install: 
  ·    5.1.0_FCS_4300.fwimg  
  ·    DMPkernel_A1_4300.tivella 

• On DMP 4305G endpoints, install: 
  ·    5.1.0_FCS_4305.fwimg  
  ·    DMPkernel_A1_4305.tivella 

• On DMP 4400G endpoints, install 5.1.0_FCS_4300.fwimg 

Although the kernel version does not affect your use of DMD directly, an outdated kernel version can interfere with your ability to use network storage servers and 
content-delivery networks successfully with DMP 4300G and 4305G endpoints. This disruption might cause playback to fail on DMP displays for your digital signage 
presentations. 
To learn how to install firmware on a DMP, see DMP Firmware Upgrade. 

4. You must enable popup windows in your web browser. See the manufacturer documentation for your browser and for any 
installed third-party browser extensions, such as toolbars that provide popup-blocking features. 

5. You must already have created and saved the media files that your presentation will show. See Working with 
Assets and Categories in Your Media Library. 

6. Confirm that none of the individual assets that you will show has a file size any larger than 1.9 GB. If any file 
has a larger file size, the presentation that should show the file shows nothing and your DMP device logs will describe many errors. This size is constrained by the 
limits of streaming. 
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7. Make note of the combined file size for the assets in your presentation. If you will use DMS-CD or the advanced task called "File Transfer to DMP or Server" 
to deploy your presentation to the SD memory card inside a DMP, confirm that the combined file size for all assets that you will show in the presentation is not 
collectively any larger than: 
• For playback on a DMP 4300G — 900 MB. 

• For playback on a DMP 4305G — 1.9 GB. 

• For playback on a DMP 4400G — 3.8 GB. 

This size is constrained by the storage capacity of the SD memory card in a DMP, and might be less than stated here if you also have deployed assets for emergency 
notification. You should consider thoughtfully the storage capacity implications on any DMP where you have deployed assets for ordinary events and emergencies. 
If you deploy a presentation to the SD memory card, the assets from that presentation will serve as the basis for stage-one failover on that DMP. If the combined file size 
for a presentation is too large, only stage-two failover is available. 
To check the free space on the SD memory card in a DMP, log in to its local instance of DMPDM, and then click Internal Storage. See the "Understanding 
Content Substitution (Failover)" topic in User Guide for Cisco Digital Media Player Device Manager 5.1 on Cisco.com. 

 
Recommended Best Practices 

8. Understand the factors that can interfere with smooth playback in streaming media. Playback of media in a 
presentation might be slow or jerky or might fail if: 
• You neglect to carefully consider the network bandwidth requirements and DMP memory and CPU requirements for the sum total of all assets that you will 
play simultaneously in a presentation. 

• Your presentation uses too many processor-intensive assets. Remember that some file types (SWF, for example) are more likely than others to require extra 
processing to play back. 

• Your presentation uses asset formats that we do not support. 

• You used incorrect settings when you encoded video for streaming. 

9. Understand the effects on your presentations of the "safe area" on your DMP displays. If you use analog 
DMP displays that are old or inexpensive, be sure that your presentations for signage do not extend past the dotted line in DMD that designates the safe area all 
around the edge of a screen object. The safe area helps you to compensate for such displays, which use only approximately 90 percent of their screens. 

 
Getting Started with DMD 
You can create the layout for a new presentation or edit a presentation that you created previously. 
Procedure 

Step 1 To start Digital Media Designer so that you can define a set of screen zones, choose Digital Signage > Presentations, and then click Start Digital Media Designer. 

Step 2 When prompted, choose the option to use Java Web Start. 

DMD opens. 

In DMD, choose the options and enter the values that meet your requirements. To understand the options, see DMD User Interface Reference. 

Step 3 To save your work in DMD when you are done, choose File > Save. 

Step 4 To close DMD when you are done, choose File > Exit. 

Step 5 (Optional) Deploy the presentation to a DMP group. See Scheduling Time Slots for Media and Events on DMPs. 

Note • To show a presentation during stage-one failovers on a DMP, you must first do one of the following: 
– Use DMS-CD. See Using DMS-CD Deployment Packages to Provision Assets to DMPs. 

– Create and deploy a "File Transfer to DMP or Server" task that saves copies of the presentation and its assets to the SD memory card inside the DMP. When you do this, DMM-DSM automatically creates a "(Go to) 
URL" task.  
 
The name by default for this generated "(Go to) URL" task is "LOCAL - <name_of_presentation>" unless you checked the Emergency/Alarm check box, in which case the name is "ALARM - <name_of_presentation>."  
 
If a DMP should show its locally stored presentation at any time other than during stage-one failover, you must deploy the corresponding "(Go to) URL" task to the DMP. See Scheduling Time Slots for Media and Events 
on DMPs. 

• After you delete a presentation for which DMM-DSM automatically generated a corresponding (Go to) URL task, you must also delete that task. 
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DMD User Interface Reference 
Figure 3-6 shows the Digital Media Designer user interface as it looks when you first open it in Java Web Start. 

Figure 3-6 Digital Media Designer 

In Digital Media Designer, the workspace is the largest part of the user interface. After you enter values for it so that it has the same height and width in pixels as the screen on your DMP display, the workspace is the canvas 
where you design your presentations and presentation templates for digital signage. 
In addition to its workspace, the user interface in Digital Media Designer consists of four menus, a toolbar, and four dockable panels. 
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• Understanding the Menus and Their Options 

• Understanding the Toolbar and Its Options 

• Understanding the Panels and Their Options 

Understanding the Menus and Their Options 
Table 3-19 describes the menus in Digital Media Designer. 

Table 3-19 Digital Media Designer Menus  

Menu Option Description 
 
File Menu 

New Shows the New Design/Template dialog box, which lists all of the templates that you have saved as well as all of the presentation 
templates that Cisco provides with DMD, minus any presentation templates that you have deleted. Click the template that meets your 
requirements, such as the template that contains only a blank canvas. To start work on your design, click OK. Alternatively, click 
Cancel to discard your selections and return to the canvas. 

• {Landscape | Portrait} — Click a tab so that you can choose or configure preliminary options for a design that will use 
the corresponding orientation. 
• untitled table — Most rows describe one presentation template apiece that you can use as the basis for a new presentation or 
as the basis for a new presentation template. Alternatively, you can choose the blank canvas that one row describes. (The blank 
canvas is described, by default, in the first row.) To re-sort the table by the attributes that the Thumbnail, Screen Resolution, Name, 
or Description columns show, click the corresponding column heading. Click a row to choose the presentation template or the blank 
canvas that the row describes. 
• Filter — Enter any part of a presentation template name to filter out from the table all presentation templates whose 
descriptions do not match your text string. The filtering occurs in real time as you enter text. 
• Resolution — Enter the resolution width and height in pixels that your presentation design will use. This feature is 
available only after you choose to use a blank canvas. To learn the native resolution for a display, see its manufacturer 
documentation. 

Open Shows the Open dialog box, which lists all of the presentations and presentation templates that you have saved, in addition to the 
presentation templates that Cisco provides with DMD, minus any presentations or presentation templates that you have deleted. To 
open a design so that you can review or change it, choose it, and then click OK. Alternatively, to return to the canvas without opening a 
design, click Cancel. 

• {Presentations | Presentation Templates} — Click a tab to restrict the type of designs that the table should 
describe. 
• untitled table — Each row describes one design. To re-sort the table by the attributes that the Thumbnail, Screen Resolution, 
Name, or Description columns show, click the corresponding column heading. Click a row to choose the presentation or the 
presentation template that the row describes. 
• Filter — Enter any part of a design name to filter out from the table all of the saved designs whose descriptions do not match 
your text string. The filtering occurs in real time as you enter text. 

Save One of these: 
• If you are designing a presentation that you have not yet saved and named, opens the Save Presentation dialog box. Choose 
the options and enter or confirm the values that meet your requirements: 

– Name — A unique and human-readable name for the presentation. The name is unique in the sense that you have not 
used it previously as the name for anything that can be scheduled. The name cannot be any more than 50 characters long. 
– Description — A brief description of the presentation and its purpose. 
– Resolution — Shows in pixels the width and height that your design will require as a supported resolution on your 
DMP display. Uses this syntax: NNNNxNNN. For example, 1366x768 would specify a display that can show as many as 1,366 
pixels horizontally and as many as 768 pixels vertically. Confirm that the values you see are not any greater than what your 
DMP display can actually show. 
– Presentation — Identifies the layout as a one-time design. A presentation is a design that uses a freeform layout or 
uses a layout derived from a presentation template. 
– Presentation Template — Identifies the layout as a foundational design. A presentation template is the basis, 
potentially, for multiple presentations that you expect to create in the future, which all will share a common look and feel. 

When you are done, click OK to save your work. 
Alternatively, click Cancel to discard your work. 
• If you are working on a layout that you saved previously, saves your work since then. 
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Save As Opens the "Save As Presentation or Presentation Template" dialog box, so that you can save multiple variants of a presentation or a 
template, or so you can overwrite a saved presentation or saved presentation template that you no longer need. Choose the options and 
enter or confirm the values that meet your requirements: 

• {Presentations | Presentation Templates} tab — Determines whether the table under the tab shows 
information about your saved presentations or about your saved presentation templates. Each row in the table shows a thumbnail 
picture of the corresponding design and describes its attributes. 
• Name — A unique and human-readable name for the design. The name is unique in the sense that you have not used it 
previously as the name for anything that can be scheduled. 
• Description — A brief description of the design and its purpose. 
• {Resolution | Screen Resolution} — Shows in pixels the width and height that your design will require as a 
supported resolution on your DMP display. Uses this syntax: NNNNxNNN. For example, 1366x768 would specify a display that can 
show as many as 1,366 pixels horizontally and as many as 768 pixels vertically. Confirm that the values you see are not any greater 
than what your DMP display can actually show. 
• Presentation — Select this radio button to identify the layout as a one-time design that uses a freeform layout or a layout 
that you will derive from a presentation template. 
• Presentation Template — Select this radio button to identify the layout as a foundational design. A presentation 
template is the basis, potentially, for multiple presentations that you expect to create in the future, which all will share a common look 
and feel. 

When you are done, click Save to save your work. 
Alternatively, click Close to discard your work. 

Delete Presentation/ 
Template 

Shows the Delete Presentation(s) and/or Presentation Template(s) dialog box, which lists all of the presentations and presentation 
templates that you have saved, in addition to the presentation templates that Cisco provides with DMD, minus any presentations or 
presentation templates that you have already deleted. 

• {Presentations | Presentation Templates} — Click a tab to restrict the type of designs that the table should 
describe. 
• untitled table — Each row describes one design. To re-sort the table by the attributes that the Thumbnail, Screen Resolution, 
Name, or Description columns show, click the corresponding column heading. Click a row to choose the presentation or the 
presentation template that the row describes. 
• Filter — Enter any part of a design name to filter out from the table all of the saved designs whose descriptions do not match 
your text string. The filtering occurs in real time as you enter text. 

To delete a design, choose it, and then click Delete Selected Presentation. To return to the canvas whether or not you 
have deleted any designs, click Close. 

Rename Presentation/ 
Template 

Shows the Rename dialog box, which you can use in conformance to this recommended best practice: "Instead of creating a 
presentation that is similar to one that used to be in your schedule, simply modify the old presentation and reschedule it. " 

Exit Closes DMD. 

 
Edit Menu 

Whole Screen Expands the selected object so that its height and width become the same as the total height and width of your presentation. To reduce 
its dimensions again if you prefer to use smaller dimensions, edit the height and width values that the Properties panel shows for the 
selected object. This feature is not available for you to use unless at least one object is selected on the workspace or in the Layouts 
panel. 

Safe Area Expands the selected object so that its height and width become the same as the height and width of the safe area in your presentation. 
To change its dimensions again, edit the height and width values that the Properties panel shows for the selected object. This feature is 
not available for you to use unless at least one object is selected on the workspace or in the Layouts panel. 

Delete Deletes the selected object or action from the workspace. This feature is not available for you to use unless at least one object or action 
is selected on the workspace or in the Layouts panel. 

Up Moves the selected object up by one layer, in the sense that your presentation might position overlapping screen zones as if they are 
stacked or piled on top of each other. When you use this option, you make the selected screen zone more prominent than it was before 
you moved it. This feature is not available for you to use unless at least one object is selected on the workspace or in the Layouts panel. 

Down Moves the selected object down by one layer. When you use this option, you make the selected screen zone less prominent than it was 
before you moved it. This feature is not available for you to use unless at least one object is selected on the workspace or in the Layouts 
panel. 
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Top Moves the selected object to the top layer. When you use this option, the effect is that you make the selected screen zone more 
prominent than every other screen zone. This feature is not available for you to use unless at least one object is selected on the 
workspace or in the Layouts panel. 

Bottom Moves the selected object to the bottom layer. When you use this option, the effect is that you make the selected screen zone least 
prominent of all your screen zones. This feature is not available for you to use unless at least one object is selected on the workspace or 
in the Layouts panel 

 
View Menu 

{Objects/ 
Actions | Layers | Navigator | 
Properties} 

Expands or collapses the respective panel. To understand the panels, see Understanding the Panels and Their Options. 

 
Tools Menu 

Add Action > As described in the "UI Reference: Elements for Objects and Actions" section of Table 3-21: 

• {Static | RSS} Text Ticker 
• Synchronize Playlists 

Add Object > As described in the "UI Reference: Elements for Objects and Actions" section of Table 3-21: 

• Screen 
• Box 
• Video Playlist 
• Nonvideo Playlist 

 
Understanding the Toolbar and Its Options 
The toolbar in DMD contains buttons that you click and controls for the degree of workspace magnification. To understand the toolbar, see Table 3-20. 

Table 3-20 Digital Media Designer Toolbar  

Icon Tool Name Description 

Save Changes Saves your work. 

Delete Selected 
Object 

Deletes from your design the one object or action that is selected on the workspace. 

Zoom In Increases the degree of magnification by 10 percentage points per click. 

Incremental Zoom Increases or decreases the degree of magnification by 1 percentage point per click, depending respectively on whether you click the arrow head 
that points up or the arrow head that points down. Alternatively, you can do either or both of the following: 

• Use the scroll wheel on your mouse to increase or decrease the degree of magnification. 
• Enter any percentage value in the unlabeled field, and then press Enter. 

Zoom Out Decreases the degree of magnification by 10 percentage points per click. 

View Workspace Increases or decreases the degree of magnification by whatever percentage amount is necessary to fit the entire screen object inside the visible 
workspace. 

 
Understanding the Panels and Their Options 
Panels are dockable controls in the Digital Media Designer user interface that you can move, resize, expand, or collapse, which contain features to help you design presentations for digital signage. All panels are opened by 
default. To understand how to use the features of a particular panel, see: 

• UI Reference: Elements for Objects and Actions 
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• Understanding the Layers Panel and Its Options 

• Understanding the Navigator Panel and Its Options 

• Understanding the Properties Panel and Its Options 

Moving Panels To move a panel so that its location is more convenient to you, drag it 
by its title bar to the location that you prefer. The only constraint when 
you move a panel is that one side of it will always be pinned to the 
workspace. DMD rearranges and resizes the other panels 
automatically to create an open space for the panel that you are 
moving. 

Resizing Panels To change the width or height of a panel, click and drag the vertical or 
the horizontal border between it and the workspace. The width or 
height of nearby panels changes automatically in response. 

Collapsing and Expanding 
Panels 

• To collapse a panel, click the square button at the right end of 
its title bar. In its collapsed form, the entirety of a panel is reduced 
to button form, where the button shows nothing except the panel 
name in very small type and is pinned to one edge of the DMD 
window. 
• To reopen a panel temporarily after you collapse it, click where 
you see its name pinned to the edge of the DMD window. After you 
move your mouse away from the panel, it closes again 
automatically. 
• To reopen a panel that you collapsed, click where you see its 
name pinned to the edge of the DMD window, and then click the 
square button at the right end of its title bar. 

 
Using Box Objects 
Procedure 

Step 1 Drag a box object ( ) to the workspace from the Objects/Actions panel to start using it. 
Alternatively, choose Tools > Add Object > Box. 

Step 2 Click the box object on the workspace. 

Step 3 Choose options and enter values in the Properties panel to start populating and configuring your box object. 

Tip When you choose which layer to use for a box object in your presentation, ensure that you choose a layer that is lower than any layer that your playlist objects use in the same presentation. Otherwise, your 
DMP displays will not show the screen zone that the box object represents. 

If you right-click a box object after it is part of your presentation, a shortcut menu appears. To understand its options, see the "Edit Menu" section in Table 3-19. 

Related Topics 
• Understanding the Properties of a Box Object That is Associated with a Ticker Action 

• UI Reference: Elements for Objects and Actions 

• Understanding the Layers Panel and Its Options 

• Understanding the Properties Panel and Its Options. 

Understanding the Properties of a Box Object That is Associated with a Ticker Action 
When you associate a box object with a ticker action, the Properties panel values that you see might be confusing for the box object after you click it on the workspace. Furthermore, these confusing attributes in the Properties 
panel differ according to which type of ticker action you use. 

• When you use a static ticker, there are two possible scenarios: 
– In the first scenario, you enter Properties panel text for the box object but not for the ticker action, so the ticker shows the text that you entered for the box object because it has no alternative. 
– In the second scenario, you enter Properties panel text separately for both the box object and the ticker action, and the ticker ignores the text that you entered for the box object because instead, it shows the text 
that you entered for the ticker action. In that case, even though you can see in the Properties panel that you entered text for your box object, DMD ignores that text. 

• When you use an RSS ticker, there is only one relevant scenario — assuming that the server for your RSS feed is reachable and configured correctly. The RSS ticker always shows what it receives from the RSS 
server, without regard for any text that you might have entered in the Properties panel after you selected your box object on the workspace or in the Layouts panel. Even though you can see in the Properties panel that you 
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entered text for your box object, DMD ignores that text. 

Working with Presentation Playlists 

Tip If you include a bitmapped image as part of a playlist in DMD, be sure that the playlist object uses the same height and width in pixels that the bitmapped file uses. If the playlist object is too small, the bitmapped image 
that it includes will be cropped. The bitmapped will not be resized or scaled automatically. 

• Using Nonvideo Playlist Objects 

• Using Video Playlist Objects 

• Synchronizing the Playback Timing of Two Playlists 

• Understanding the Properties of Two Playlist Objects That Are Synchronized 

Using Nonvideo Playlist Objects 
A presentation can contain any number of nonvideo playlist objects at a time, and you can place this object type on any layer in your presentation. 
Procedure 

Step 1 Drag a nonvideo playlist object ( ) to the workspace from the Objects/Actions panel to start using it. 

Alternatively, choose Tools > Add Object > Nonvideo Playlist. 

Step 2 Click this object on the workspace or in the Layouts panel. 

Step 3 Choose options in the Properties panel to populate and configure this object. 

For example, the Properties panel is where you define the playback sequence for a playlist and define the playback duration for each entry that it contains. 

Tip If you right-click a playlist object on the workspace, a shortcut menu appears, from which you can choose options to edit the playlist. 

Related Topics 
• Creating and Organizing Presentation Playlists 

• Synchronizing the Playback Timing of Two Playlists 

• Edit Menu 

• UI Reference: Elements for Objects and Actions 

• Understanding the Layers Panel and Its Options 

• Understanding the Properties Panel and Its Options 

Using Video Playlist Objects 
You can place a video playlist object on any layer. However, when you use this object type, it becomes the topmost layer automatically. Other object types (nonvideo playlist objects and box objects) are rendered in back of the 
video playlist object, which means that you cannot use them to create an overlay or mask for video. 

Tip To use an overlay of that kind, we recommend that you encode the video file itself so that it includes an overlay before you add it to your media library. Alternatively, you can use JavaScript to create a presentation 
outside of DMD. 

A presentation cannot contain any more than one video playlist object at a time. 
Procedure 

Step 1 Drag a video playlist object ( ) to the workspace from the Objects/Actions panel to start using it. 

Alternatively, choose Tools > Add Object > Video Playlist. 

Step 2 Click the object on the workspace, and then use the Properties panel to populate and configure it. 

For example, the Properties panel is where you define the playback sequence for a playlist and define the playback duration for each entry that it contains. 
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Tip If you right-click a playlist object on the workspace, a shortcut menu appears, from which you can choose options to edit the playlist. 

Related Topics 
• Creating and Organizing Presentation Playlists 

• Edit Menu 

• UI Reference: Elements for Objects and Actions 

• Understanding the Layers Panel and Its Options 

• Understanding the Properties Panel and Its Options 

Synchronizing the Playback Timing of Two Playlists 
You can use a synchronization action to bind two playlist objects together in a presentation, imposing the playback timing from the primary playlist on, and overriding, the playback timing for the secondary playlist. In this way, 
you can synchronize transitions in two playlists, no matter how asynchronous those transitions would be ordinarily. 
Procedure 

Step 1 To add the potential for synchronization to your presentation, drag a Synchronize Playlists action to the workspace from the Objects/Actions panel. 

Alternatively, choose Tools > Add Action > Synchronize Playlists. 

Step 2 In the Properties panel: 

a. Choose the primary playlist object from the Primary Playlist list. 

b. Choose the secondary playlist object from the Secondary Playlist list. 

Related Topics 
• Using Nonvideo Playlist Objects 

• Understanding the Properties of Two Playlist Objects That Are Synchronized 

• UI Reference: Elements for Objects and Actions 

• Understanding the Layers Panel and Its Options 

• Understanding the Properties Panel and Its Options 

Understanding the Properties of Two Playlist Objects That Are Synchronized 

The Properties panel values that you see for a selected playlist object (  or ) might be confusing if you have used a synchronize playlists action ( ) to override the natural timing of transitions between assets in the playlist. 
To avoid this potential for confusion, plan ahead, by keeping in mind the eventual synchronization of two playlists when you populate them and configure the playback duration for each asset. Otherwise, synchronization might 
truncate the playback for one or more assets in the secondary playlist. 
Related Topics 

• Using Nonvideo Playlist Objects 

• Using Video Playlist Objects 

• Synchronizing the Playback Timing of Two Playlists 

• Synchronize Playlists 

• UI Reference: Elements for Objects and Actions 

• Understanding the Properties Panel and Its Options 

Using New Screen Objects to Clear the Workspace and Discard Any Unsaved Work 

Caution Completing this procedure closes the active presentation in DMD and discards all unsaved work in it. 

Procedure 

Step 1 Drag a new screen object ( ) to the workspace from the Objects/Actions panel. 

Alternatively, choose Tools > Add Object > New Screen. 
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Step 2 Confirm, when DMD asks you, that you really do want to proceed. 

The workspace is cleared and all unsaved work is discarded. 

Related Topics 
• UI Reference: Elements for Objects and Actions 

Using RSS Feeds and Causing Text to Fade or Scroll 
• Understanding the DMD Concepts that Apply to Text Actions 

• Using Static Text Actions 

• Using RSS Text Actions 

Understanding the DMD Concepts that Apply to Text Actions

dynamic 
text 

Any message that is obtained from a an RSS feed and which is automatically replaced by a newer message 
after: 

• The author publishes an updated RSS feed. 
• A DMP receives this updated version. 

Furthermore, the message populates a ticker. 

Even though `dynamic text' has had fading or motion effects applied to it, these effects are not what we 
mean when we say dynamic. 

static text Any message that is repeated forever or until you enter a new message manually replace the older 
message. Furthermore, the message populates a ticker. 

For our purposes, the term `static text' does not mean text that is motionless. 

ticker The text of any message that fades in and out or scrolls (vertically or horizontally), depending on the 
capacity of a DMP that loads it for playback. Furthermore, the on-screen region that shows this text was 
defined in DMD as part of the layout for a presentation. 
For our purposes, the word `ticker' is not limited to — and does not promise — horizontal scrolling in the 
style of a ticker tape. 

 
Using Static Text Actions 
You can add the potential for a static text ticker to your presentation, and then associate this action with a box object. You can use only one ticker per box object. 

Procedure 

Step 1 Drag a static text ticker action ( ) to the workspace from the Objects/Actions panel. 

Alternatively, choose its type from the Tools menu. The size and placement of this action on the workspace do not matter because actions do not, by themselves, occupy any space. 

Step 2 Click the action on your workspace. 

Step 3 In the Properties panel: 

a. Enter text for your ticker in the Text field. 

b. From the Assign to Object list, select the box object that should contain the ticker. 

Related Topics 
• Using RSS Text Actions 

• UI Reference: Elements for Objects and Actions 

Using RSS Text Actions 
You can add the potential for an RSS text ticker to your presentation, and then associate this action with a box object. You can use only one ticker per box object. 

Procedure 

Step 1 Drag an RSS text ticker action ( ) to the workspace from the Objects/Actions panel. 

Alternatively, choose its type from the Tools menu. The size and placement of this action on the workspace do not matter because actions do not, by themselves, occupy any space. 
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Step 2 Click the action on your workspace. 

Step 3 In the Properties panel: 

a. Enter the RSS feed source URL for your ticker in the RSS URL field. 

The feed that you specify should be one that does not include any file enclosures. We recommend as a best practice that you use only RSS feeds over which you have direct editorial control. 
b. Choose the box object from the Assign to Object list that should contain this ticker. 

An RSS ticker action will not show data from feed on your DMP displays until you finish configuring the association between the action and the object, save your work, and deploy it to DMPs. Your DMPs will check the RSS feed 
for updated content and refresh the ticker every 15 minutes. 

Related Topics 
• Using Static Text Actions 

• UI Reference: Elements for Objects and Actions 

UI Reference: Elements for Objects and Actions 
An action is a behavior that you can add to an object in your presentation. Each object occupies a layer. 

Table 3-21 Digital Media Designer — The Objects/Actions Panel  

Icon Tool Name Description 

 
Box Creates a new screen zone and a new layer where you can show: 

• One bitmapped image in JPEG, GIF, or PNG format. (Other file types are not supported.) If you place a bitmapped image in a box object, 
be sure that the box object uses the same height and width in pixels that the bitmapped file uses. If the box object is too small, the displayed 
image will be cropped. It will not be resized or scaled automatically. 
• One text string. The string can be completely motionless and presented without any visual effects when you show it on a DMP display or 
you can show it in the form of a ticker.) 
• One background color. 

 
Nonvideo Playlist Creates a new screen zone and a new layer where you can arrange and play back in any combination an ordered sequence of: 

• JPEG, GIF, and PNG files. 
• SWF files. 
• Pages on web servers. 

 
Video Playlist Creates a new screen zone and a new layer where you can arrange and play back in any combination an ordered sequence of: 

• Video files: 
– MPEG-1 and MPEG-2 files for all DMP model types. 
– MPEG-4 part 10 H.264 files on the DMP 4400G model exclusively. 

• Multicast video streams. 
• SWF files. 
• JPEG, GIF, and PNG files. 
• Pages on web servers. 

 
New Screen Restarts your design process by closing the open presentation — discarding any design work in it that you have not saved — and showing to you 

a completely new representation of a blank DMP display as your workspace. Because each presentation and each presentation template can 
contain only one screen, the new workspace does not have any objects, actions, or playlists associated with it — even if the closed presentation 
used them. 

 
Static Text Ticker Places a static ticker action on your workspace. 

A ticker action will not produce a visible ticker on your DMP displays until you finish configuring the association between the action and the object, 
save your work, and deliver your presentation to a DMP as part of a scheduled deployment. 

 
RSS Text Ticker Places an RSS ticker action on your workspace. Its size and placement on the workspace do not matter because actions do not, by themselves, 

occupy any space on a screen. 

 

Synchronize 
Playlists 

Places a synchronization action on your workspace. Its size and placement on the workspace do not matter because actions do not, by 
themselves, occupy any space on a screen. 
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Understanding the Layers Panel and Its Options 
The Layers panel lists all of the objects that you have dragged to your workspace, sorted by their placement on different layers. Each layer holds one object only, and each object represents one screen zone. 

• The object at the bottom of the list is also the screen zone that is behind or under all of your other screen zones in this presentation. 
• The object at the top of the list is also the screen zone that is in front of or on top of all of your other screen zones in this presentation. 
• If you select an object in the list, you can use buttons in the Properties panel to manipulate the selected object. 

Table 3-22 Digital Media Designer — The Layers Panel  

Icon Tool Name Description 

 
Remove Deletes the selected object. 

 
Bring to Front Moves the selected object to the absolute top layer. 

 
Move Up Moves the selected object up by one layer per click. 

 
Move Down Moves the selected object down by one layer per click. 

 
Send to Back Moves the selected object to the absolute bottom layer. 

 
Understanding the Navigator Panel and Its Options 
The Navigator panel shows a wireframe thumbnail view of, and scrolling controller for, your workspace in DMD. The Navigator panel is especially useful when you design presentations for high-definition DMP displays, because 
you might not be able to see the entire design all at one time in the workspace area. 
To scroll the workspace vertically and horizontally, click and move the small gray rectangle from place to place inside the Navigator panel. 

Understanding the Properties Panel and Its Options 
Shows the editable and uneditable properties of the selected object or action. The type of properties that you see depend on the type of object or action that you select on the workspace or in the Layouts panel. 

Table 3-23 Digital Media Designer — The Properties Panel  

Element Icon and Description 

Border  
{Style | Width | Color} 

Choose options to define the border attributes, if your box object should be enclosed in a border. 

Assign to Object Select the box object that represents the screen zone where the selected ticker action should show its ticker. 

Duration Shows the playback duration for each asset in the selected playlist. If you use the Synchronize Playlists 
action to make the selected playlist secondary, the duration values shown here might not have any bearing 
on how long an asset plays back before the playlist transitions to the next asset. There is no factory default 
duration value for nonvideo assets, so you must enter all such duration values manually. 

Type Signifies the type of playlist. This value is not editable. 

Name An editable field or an uneditable column in a table: 
• Enter a unique and meaningful name in the Name field to identify the selected object or action. 
• Click the Name column heading to sort the table by the values in that column. 

Playlist Items To understand the elements in the Playlist Items area, see UI Reference: Elements to Populate Playlists. 

To learn about the workflow to create a playlist, see Creating and Organizing Presentation Playlists. 

Primary Playlist Select the playlist object whose transition timing between assets during playback should override the 
equivalent transition timing of a secondary playlist. 

RSS URL Enter the source URL for the RSS feed. 

Effect Choose whether the ticker should fade or scroll and, for scrolling, choose the direction of motion. For a 
DMP 4300G or 4305G, only the fading effect is supported. For a DMP 4400G, all effects are supported. 
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Secondary Playlist Select the playlist object whose transition timing between assets during playback should be overridden by the 
equivalent transition timing from the primary playlist. 

Text {Size | Color | Horizontal Alignment | Vertical Alignment | 
Text} 

All of the following: 
• Increases or decreases the text size (in pixels), depending respectively on whether you click the 
arrow head that points up or the arrow head that points down. 
• Changes the text size (in pixels) to the numeric value that you enter. 
• Changes the text color to match a color that you select after you click ... or to match a hexidecimal 
color value that you enter.1 

• Changes the horizontal or vertical alignment of text to match the alignment types that you select. 
• Shows exactly the text that you enter in the Text field. 

URL  An uneditable column in a table, where each row shows the URL for one remote playlist asset. 

{Width | Height} Enter in pixels the respective width and height of the selected screen zone object. 

{X | Y} X and Y coordinates that represent the placement of the first pixel (when reading from left to right and top to 
bottom) of the selected object. 

1 The text color that you use should be one that results in clear and legible text against the background color that you specified; if there is not enough difference between the two colors, your audience might not see information clearly when you use this 
presentation to show text on a DMP display. 

 
Creating and Organizing Presentation Playlists 
Presentations that you design in DMD can contain presentation playlists that you populate. A presentation playlist contains assets from one or more media library categories or remote servers and shows these assets in the 
sequence that you specify. The only way to save a presentation playlist and deploy it to your DMPs is inside a presentation. 

Caution Important considerations apply to your presentation playlists when you use ACNS. Before you delete a channel from ACNS, you must first remove from the shared schedule for DMM-DSM and DMM-ETV 
every presentation playlist that calls upon the channel. Then, you must edit all affected presentation playlists so that they do not use the channel. Otherwise, if a presentation playlist is scheduled for deployment but you 
delete an ACNS channel that it uses for content distribution, you will be prevented from deleting the playlist manually even though your DMPs cannot obtain its assets successfully from the deleted channel. 

Before You Begin 
• You must add assets to your media library before you can organize them in a playlist. 
• You must add a DMP to DMM-DSM before you can deploy any presentations to it, and you must organize your DMPs into groups before you can deploy any presentation to a group. The DMP Groups list does not show 
any DMPs until you add at least one. 
• You must add an external deployment server to DMM-DSM before you can deploy any presentations to it. Given this, it is important for you to understand that: 

– The DMP Groups list will never describe external deployment servers. 
– You cannot use the Schedules > Play Now feature with external deployment servers. 
– All deployments to your external deployment servers require that you use the Schedules > Play in Future feature. 

Tip We recommend that you use the advanced task called DMP Startup URL and enter a value for either the Video URL or the Browser URL. If both values are blank, you might find that your DMP sometimes loses its ability 
to play even the Shockwave Flash files that it has played successfully in the past. 

Procedure 

Step 1 In DMD, do any of the following: 

• Drag a playlist object (video or nonvideo) to the workspace from the Objects/Actions panel. 

• Click a playlist object that you already placed on your workspace. 

• Click a playlist object in the Layers panel. 

The Properties panel now contains an area called "Playlist Items," where you can add, remove, or rearrange assets in a presentation playlist. 

Step 2 In the Playlist Items area, enter values and select options that meet your requirements. 
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Step 3 To open the Content Chooser dialog box, where you configure a presentation playlist, click . 

Step 4 To save a presentation playlist after you have populated and organized it and set the playback duration for each of its assets, click Submit in the Content Chooser dialog box. 

Step 5 To save a presentation or a template after you have finished designing it, select File > Save in DMD. 

Step 6 Deploy the presentation to the DMP displays that should show it. 

Related Topics 
• Managing and Grouping Your DMPs 

• UI Reference: Elements to Add Assets and Edit Their Attributes 

• Understanding the Two Types of Playlists for Digital Signage 

• Working with Presentations, Templates, and Presentation Playlists for Digital Signage 

• Table 3-19 

• Table 3-24 

• Table 3-25 

• Using Advanced Tasks 

• Table 3-29 

• Scheduling Time Slots for Media and Events on DMPs 

• Configuring the Settings to Deploy to External Servers 

UI Reference: Elements to Populate Playlists 
The Playlist Items area loads inside the Properties panel when the selected object on your workspace is either a video playlist object or a nonvideo playlist object. 

Table 3-24 Elements for Managing Presentation Playlists  

Element Icon and Description 

unlabeled check box Click to select (or to deselect) one or more assets so that you can change the playback sequence of, or remove assets from, the playlist that you are 
editing. 

asset location Shows a miniature icon to indicate whether you selected the asset from your media library or from a remote server. 

  media library 

  remote server 

IANA Internet 
media type 

Shows a miniature file icon to represent the asset that the corresponding row describes. DMD identifies assets according to their IANA-registered 
Internet media types. To learn about media types and understand the requirements to register them, see http://www.iana.org/assignments/media-
types/. 

  Video asset of any supported type, whether a file or a multicast stream. 

  Shockwave Flash 6 or 7 asset, if your DMP is a 4300G or a 4305G. Alternatively, a Shockwave Flash 6, 7, 8, 
or 9 asset, if your DMP is a 4400G. 

  
JPEG, GIF, or PNG asset. 

  
Web page. 

Name A unique and human-readable name that you entered. 

Duration, sec The playback duration in seconds for the asset that the corresponding row describes. Click a value to see and use its duration control (  ), which is 
hidden until you click the value. To increase the playback duration by 1 second, click the top of a control. Alternatively, to reduce the playback duration 
by 1 second, click the bottom of a control. To increment or decrement the duration value quickly, hold down the mouse button after you click the top or 
the bottom of a control. 
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URL Shows the storage URL for the asset that the corresponding row describes. 

Add 

 

Opens the Content Chooser dialog box, where — to populate a playlist — you choose assets from your media 
library or enter the URLs for remotely stored assets. 

Remove 
 

Removes all of the selected assets from the relevant playlist. Nonetheless, the assets remain in your media 
library or on the remote server from which you selected them. 

Move Up 
 

Reorders the playlist so that the selected asset moves up one row, exchanging places with the asset that was 
above it. 

Move Down 
 

Reorders the playlist so that the selected asset moves down one row, exchanging places with the asset that 
was below it. 

 Type — The file format or JPEG. 

 
Related Topics 

• Table 3-21 

• Understanding the Properties Panel and Its Options 

• Table 3-25 

Understanding the Content Chooser and Its Options 
The Content Chooser dialog box is part of DMD. You use the Content Chooser to populate a presentation playlist. 
Procedure 

Step 1 To save your work and use a presentation playlist that you have populated, click Submit.  
Alternatively, to discard your work, click Cancel. 

Tip We recommend that you use the advanced task called DMP Startup URL and enter a value for either the Video URL or the Browser URL. If both values are blank, you might find that your DMP sometimes loses its ability 
to play even the Shockwave Flash files that it has played successfully in the past. 

Related Topics 
• Using Advanced Tasks 

• Table 3-29 

UI Reference: Elements for Choosing the Assets to Populate a Presentation Playlist 

Table 3-25 Elements to Manage Assets in Playlists  

Element Icon and Description 

Click the Content Manager tab or the URL tab to choose whether the Available Content table should describe assets in your media library or help you to select an asset that is 
stored remotely. 

 
Content Manager tab 

Content Groups An object selector that lists all categories in your media library. Click one category that the Available Content table should describe. 

Available 
Content 

A table, which describes every available asset in the category that you clicked. 

 Add to Playlist — Adds to the Selected Items table whichever assets you have checked in the Available Content table, so that they might be 
included in a playlist. To add more assets to the Selected Items table, repeat this step as many times as necessary. 

— Name — The name that you entered for the asset. 

— Type — Says whether the asset is stored locally or should be retrieved from an HTTP URL. 
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— Path — Shows the HTTP URL for the described asset. 

 
URL tab 

External URL Choose an asset that is stored remotely, so that you can add it to the Selected Items table. 

— Name — Enter a name to describe the asset. 

— URL — Enter the HTTP URL for the remote asset, or enter the UDP URL and port number. 

 Add URL — Add the remote asset to the Selected Items table, so you can might include it in a playlist. 

Selected Items A table, which describes every asset that you have chosen so far for the playlist that you are populating. Sorts assets according to their order of playback. 
Also, includes features to change the playback order, change the duration of playback for each asset, and remove assets from the playlist. 

  Move Down — Changes the order of playback for assets in your playlist. Reorders the list so that the one asset whose name you have highlighted 
moves down by one row, exchanging places with the asset that was below it. 

  Move Up — Changes the order of playback for assets in your playlist. Reorders the list so that the one asset whose name you have highlighted 
moves up by one row, exchanging places with the asset that was above it. 

  Remove Assets from Playlist — Removes any number of assets from the playlist that you are configuring. You must first select one or 
more check boxes, corresponding to the assets that you want to remove. Even though you remove these assets from the playlist, they remain available in 
your media library or on the remote server that you specified. 

— Name — The name that you entered for the asset. 

— Duration, sec — The number of seconds that the asset will be visible when you show it on a DMP display. Click a value to see and use its duration 
control (  ), which is hidden until you click the value. To increase the playback duration by 1 second, click the top of a control. Alternatively, to reduce 
the playback duration by 1 second, click the bottom of a control. To increment or decrement the duration value quickly, hold down the mouse button after 
you click the top or the bottom of a control. 

• If you do not specify a duration for playback of video and SWF assets, the file plays to completion one time. 
• If you do not specify a duration for playback of images or web pages, their duration is continuous. 

— URL — Shows the HTTP URL for the described asset. 

 
Related Topics 

• Working with Assets and Categories in Your Media Library 

Creating and Organizing Ordinary Playlists 

Note • Playlists that you create under the Digital Signage tab are separate from the presentation playlists that you create in DMD but they are not mutually exclusive. You can assign ordinary playlists or presentation 
playlists interchangeably to zones in your presentations. 
• You cannot add an advanced task (or a system task) to a playlist. However, you can schedule advanced tasks to occur between playlists. 

Procedure 

Step 1 Choose Digital Signage > Playlists. 

Step 2 Select the options and enter the values that meet your requirements. 

When you choose options anywhere on the Playlists page, it is updated automatically to show the options and features that are relevant to your selection. 

Related Topics 
• Table 3-26 

UI Reference: Elements to Define an Ordinary Playlist 
Navigation 
Digital Signage > Playlists 

Table 3-26 Elements to Define an Ordinary Playlist  
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Element Description 

Title The title for this playlist. 

Assets A table in which each row describes one asset. Attributes are sorted into these columns: 
• Title — A unique and human-readable name for the asset. 
• File Type — the type that best describes the asset: Video, Shockwave Flash, Images, HTML, or Firmware. 
• {Estimated | Planned} — Respectively: 

– An estimate of the actual running time from start to finish of the described asset, without regard for the amount of time the playlist has reserved to 
show it. 
– The amount of time that is reserved in the playlist to show this asset. 

A planned duration of 0 (zero) seconds in the playlist causes a video to play from beginning to end. To skip a video instead of playing it, you must remove it 
from the playlist. Nonvideo assets must have a duration of 1 second or more for each that you include in a playlist. 
• Size — The file size. 
• Delete —  

To select additional assets from your media library that this playlist should include, click Add Assets. To change the sequence of playback for assets in this 
playlist, select an asset that should move and then click either Move Playlist Item Up or Move Playlist Item Down. 

Randomize Enables or disables a randomized sequence of playback for assets in this playlist. To turn randomization on, check the check box. To turn randomization off, 
uncheck the check box. 

Resolution Choose the resolution of your DMP display from the Select list or enter its width and height, in pixels. 

Description A description of this playlist. The description is optional. 

Playlist 
Owner 

Your name or the name of the person who manages this playlist. 

 
Using a Content Delivery System with DMPs 

• Choosing the Content Delivery System to Use in Your Digital Media Network 

• Understanding DMP Support for the CIFS Protocol 

• Upgrading the Kernel in DMP 4300G and 4305G Endpoints to Support CIFS 

• About the Built-in Mechanism for Content Distribution, DMS-CD 

• Best Practices for Limiting the Risk of Disrupted DMP 4400G Performance 

• Checking Disk Space Capacity for Deployments 

• Configuring DMS-CD Deployment Threshold Preferences 

• Using DMS-CD Deployment Packages to Provision Assets to DMPs 

• Methods to Monitor and Troubleshoot DMS-CD Deployments 

Choosing the Content Delivery System to Use in Your Digital Media Network 
In digital media networking, it is sometimes necessary to distribute large files over networks where bandwidth capacity is moderately or severely constrained. The challenge of doing this successfully is that delivering HD or SD 
video streams and deploying large assets often requires an average data transfer rate of greater than 6 million bits per second (Mbps, or megabits). Digital media networks can compound your need for bandwidth. 
There is a practical maximum limit in any WAN for how much bandwidth each of its remote sites can use, and a content delivery solution can help you to manage multicast file distribution efficiently to the DMPs that operate at 
your remote sites. In this way, content delivery solutions can enhance the scalability of your existing network infrastructure and adapt it for digital media deployments. 

Table 3-27 Comparison of Supported Content-Distribution Methods  

Content Distribution Method Use Cases with Cisco DMS 
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DMS-CD DMS-CD might be the best choice for your digital media network if these statements are true: 
• You use Cisco DMS for digital signage only and do not need any content-distribution support for desktop video. 
• You do not show live video or high-definition video. 
• Each site in your WAN has fewer than three DMPs. 
• Each site in your WAN has bandwidth capacity of less than T1/E1. 
• On average, each site in your organization downloads less than 200 MB daily. 
• It takes longer than 5 hours in your WAN to download 300 MB at 128 Kbps. 

ACNS ACNS might be the right choice for your digital media network if these statements are true: 
• You use Cisco DMS for both digital signage and desktop video. 
• You show high-definition video. 
• Each site in your WAN has at least three DMPs or at least three Video Portal users. 
• Each site in your WAN has bandwidth capacity of less than T2/E2. 
• On average, each site in your organization downloads 200-300 MB of video daily. 
• You need a comprehensive platform for media-delivery. 

WAAS WAAS might be the right choice for your digital media network if these statements are true: 
• You use Cisco DMS for both digital signage and desktop video. 
• You use Windows Media for live desktop video streams. 
• Each site in your WAN has at least three DMPs or at least three Video Portal users. 
• Each site in your WAN has bandwidth capacity of less than T2/E2. 
• On average, each site in your organization downloads more than 300 Mbps of video daily. 
• You want to use the Common Internet File System (CIFS) protocol when provisioning assets to your DMPs. 

 

Note Commonly, the bandwidth capacity required to deliver an HD video stream ranges from 10 Mbps to 15 Mbps, while an average SD video stream uses approximately one-third as much capacity as an HD video stream 
does. However, these parameters are highly configurable and will vary from one WAN to another. 

Related Topics 
• About the Built-in Mechanism for Content Distribution, DMS-CD 

• Understanding DMP Support for the CIFS Protocol 

• Configuring the Settings to Use ACNS or WAAS 

Understanding DMP Support for the CIFS Protocol 
Common Internet File System (CIFS) is a network protocol for sharing files and for obtaining remote access to those files. 
A CIFS share is a mount point on a network attached storage device that supports the CIFS protocol. When you choose WAAS as your content distribution method, DMM-DSM instructs DMPs to use the CIFS protocol and 
mount a network share, such as a Windows shared folder, that uses CIFS. The following restrictions apply to our support for CIFS: 

• There can be only one CIFS mount point, which all DMPs use in common. You cannot set DMPs or DMP groups to mount any CIFS share except this one. 
• Either your DMPs all use CIFS, or none of them do. 
• It might be necessary for you to upgrade the kernel that your DMP 4300G and DMP 4305G endpoints use, so that they can support the CIFS protocol. 

Tip There is no need to upgrade the kernel on a DMP 4400G. Every DMP 4400G supports CIFS already. 

Related Topics 
• Upgrading the Kernel in DMP 4300G and 4305G Endpoints to Support CIFS 

• Configuring the Settings to Use ACNS or WAAS 

Upgrading the Kernel in DMP 4300G and 4305G Endpoints to Support CIFS 
DMP 4300G and DMP 4305G endpoints that use an older kernel version cannot use the CIFS protocol that Cisco DMS 5.1 supports. You must upgrade the kernel on these DMPs before you can use CIFS. It is not necessary to 
upgrade the kernel on a DMP 4400G, because the necessary kernel version already is installed. 
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Installable kernel files are stored on the software CD that you received from Cisco after you: 
• Purchased DMM-DSM 5.1. 
• Paid to upgrade from an earlier release. 
• Contacted Cisco TAC to verify a SAS contract that applies to DMM-DSM. 
• Contacted Cisco TAC to verify a SAS contract that applies to your DMPs. 

Note These files are not available for download from Cisco.com. 

• For DMP 4300G endpoints, the kernel is DMPkernel_A1_4300.tivella 
• For DMP 4305G endpoints, the kernel is DMPkernel_A1_4305.tivella 

Procedure

 Task Steps 

Step 1  Check each DMP to see which kernel 
version is installed. 

a. Load this URL in your browser: 
http://<DMP_IP_address>:7777/get_param?p=sinfo.version 

b. Enter the username and password for the DMP web account. 

c. Read the sinfo.version output that your DMP returns. Its time stamp should be exactly: 
Tue Nov 18 14:48:57 EST 2008 

If the time stamp is any earlier than is shown here, the kernel is outdated and you must install the updated 
kernel on this DMP before it will support the CIFS protocol. 

Step 2  Add the kernel to your media library. a. Locate your upgrade CD for this DMP model type. Its silk-screened label says one of the following: 

• Cisco Digital Media Player Software Upgrade for 4300G Version 5.1 

• Cisco Digital Media Player Software Upgrade for 4305G Version 5.1 

b. Locate the kernel file on the CD. Its filename is one of these: 

• DMPkernel_A1_4300.tivella 

• DMPkernel_A1_4305.tivella 

c. Add the kernel to your media library. 

Step 3  Install the new kernel on each DMP. 

Related Topics 
• Adding One Asset at a Time to Your Media Library 

• DMP Firmware Upgrade 

• Upgrading the Firmware or Kernel on DMPs 

About the Built-in Mechanism for Content Distribution, DMS-CD 
Activation Anyone who has purchased a valid license to use this release of DMM-DSM also has a perpetual license to use its built-in implementation of DMS-CD. No additional software is required and 
there is no recurring cost. 

Note • We recommend that you avoid using any value greater than 100, which is the factory-default value, in the "Number of concurrent deployments" field. Using a value greater than 100 can increase the number of 
concurrent DMS-CD sessions to DMPs and increase the load on your DMM appliance. You might try reducing this value if you notice that the CPU load is high on your DMM appliance during DMS-CD deployments. In our 
tests, we found that DMM appliances operate at expected levels while running 75 concurrent DMS-CD sessions. This metric might differ in your WAN, depending on total bandwidth capacity and the value you use in the 
"Enable maximum transfer rate" field. To understand these fields, see Table 3-28. 

• This DMS-CD release does not support live video. It provisions assets that already exist. 
• This DMS-CD release does not support desktop video. It provisions assets to DMPs. 
• This DMS-CD release does not delete files from any DMP that belongs to multiple DMP groups. For autocleaning to occur on a DMP, it can belong to one DMP group only. Alternatively, you can use Play Now to deploy 
a job to DMPs. 
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• You can attach only one external USB flash drive or external USB hard drive to a DMP. We do not support USB hubs or any other method that you might use to attach multiple drives (or other device types) to a DMP. 

Cisco DMS content distribution (DMS-CD) is a file delivery and management mechanism that conserves network bandwidth and optimizes playback performance by provisioning creative assets directly to your DMPs. With DMS-
CD, you can use FTP or SFTP to transfer multiple playlists and presentations to DMP local memory, storing their assets directly on the flash memory card that is preinstalled inside a DMP and — or alternatively — on an 
external USB hard drive or flash drive that you attach to a DMP. 
DMS-CD is designed for use in WANs with as many as 1,000 sites that each have a maximum of three DMPs delivering digital media to their attached DMP displays. Within these parameters, you can provision up to 300 MB of 
new data to each DMP every day, depending on the bandwidth capacity of your WAN. 
Differential download intelligence in DMS-CD prevents the needless provisioning of any asset more than once to any DMP that uses it and already has downloaded it, even if you have used the asset repeatedly in multiple 
playlists or presentations. Your DMPs retain their valid assets and download only what is new or has changed. 
A systemwide threshold that you define limits in your WAN how much bandwidth is used per session when DMS-CD provisions assets to one of your DMPs. For example, a limit of 1.2 mbits means that file transfer speeds for 
DMS-CD deployments cannot exceed the maximum threshold of 1.2 mbits per DMP. Thus, if your deployment provisions assets to 20 DMPs, the maximum WAN bandwidth that DMS-CD uses is 24 mbits, because 
20 x 1.2 = 24. 
If the deployment package is interrupted while you are provisioning assets (due to a power failure or a network outage, for example), the file transfer process resumes automatically after the interval has elapsed that you 
specified in the "Deployment retry time (in seconds)" field. Similarly, the maximum number of times that DMS-CD tries to provision assets for an interrupted deployment package is constrained by the "Deployment retry count" 
value. You define these values at Deployment Manager > Deployment Preferences. If your deployment is scheduled to recur daily, as we recommend, DMS-CD will resume the transfer each day of any assets which were too 
large to transfer completely during the previous 24-hour period, as would be the case for a file that is 1.6 GB if none of your DMPs can download more than 200 MB in a single day. This feature is useful in cases where you must 
compensate for bandwidth throttling or other constraints, such as a limited number of nighttime hours when deployments are certain not to disrupt the digital signage messages or Enterprise TV programs that your organization 
shows to its targeted audiences. 
Because DMS-CD uses the same scheduling features that are built into DMM-DSM, you can schedule assets to be provisioned late at night or at other convenient, planned times. Furthermore, reporting features in DMM-DSM 
show you which DMS-CD deployments have succeeded or failed and show you which files were deployed to each DMP. 

Best Practices for Limiting the Risk of Disrupted DMP 4400G Performance 
Improper scheduling practices and improper WAN bandwidth parameters in your digital media network can cause DMS-CD to disrupt playback performance temporarily on your DMP 4400G endpoints. The disruption affects 
multicast video streams, HD videos, Shockwave Flash animations, and image assets that these DMPs show on their attached DMP displays while simultaneously downloading newly provisioned, large assets. When 
this disruption happens: 

• Videos might become fragmented (contain artifacts), drop frames, or cut out during playback. 
• Flash animations might play slowly. 
• Images might redraw slowly. 
• DMPs might restart unexpectedly, in rare instances. 

These behaviors affect the DMP 4400G due to a hardware resource limitation. However, you can configure bandwidth restrictions in your WAN that should help to alleviate these symptoms or eliminate them completely, 
depending on the system load of each DMP. We recommend that you apply these best practices in your network: 

• If playback and deployments must occur simultaneously, use the "Enable maximum transfer rate" field (at Digital Media Players > Deployment Manager > Deployment Preferences) to configure an upper threshold for 
bandwidth consumption by DMS-CD during its deployments to each individual DMP in your WAN. The value that you enter should be less than the maximum transfer rate of your network. If necessary, adjust and test values 
until you determine exactly how much bandwidth DMS-CD can use in your WAN without affecting DMP performance. In our tests, we found that using 5 Mbps as the upper threshold provided adequate bandwidth restriction 
in most cases; however, this is not necessarily a value that you should use. Results will vary depending on network capacity and the load placed on a DMP. 
• Whenever possible, schedule DMS-CD deployments to run while there is little or no load on your DMPs, such as during the "off hours" at each store or branch site, when no playback is scheduled. If you schedule 
deployments and playback to run in parallel, your deployments might take longer to finish than you anticipate. This delay is predictable because the load is doubled on DMP system resources. In this case, deployments 
might be slow even when you have not imposed any bandwidth restrictions upon DMS-CD. 
• Schedule your DMS-CD deployments to run during hours that have the least possible impact on your audience. For example, you might run deployments late at night or early in the morning if this is when your audience 
is smallest. 
• We recommend that you create no more than one DMS-CD deployment package for each of your DMP groups whose member DMPs should play assets that are stored locally. You can schedule this deployment to 
recur each day at the least disruptive time and you can add, edit, or delete entries whenever necessary in the playlists, presentations, and commands that are part of the deployment package. DMS-CD will sync DMP 
storage with the current version of this deployment package and apply any changes automatically without additional user intervention, preventing your DMPs from keeping local copies of obsolete assets long after you 
obsolete them. Also, this method increases the likelihood that large deployments will resume and be completed successfully on a slow connection. Furthermore, this method prevents DMS-CD deployments from becoming 
so numerous that they are difficult to manage. 

Related Topics 
• Configuring DMS-CD Deployment Threshold Preferences 

• Best Practices for Managing and Maintaining the Schedule 

Checking Disk Space Capacity for Deployments 
Before You Begin 

• Create DMP groups and populate them with DMPs. 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Click in the DMP Groups object selector the name of the DMP group that contains the target DMP. 

The DMP List table is repopulated with the corresponding group membership list. 
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Step 3 (Optional) Use filtering options above the DMP List table to limit how many DMPs the table describes. 

Step 4 Add together the values that you see in the Internal Storage MB. (Total/Free) column and the Internal Storage MB. (Total/Free) column. The combination of these values is the total free capacity. 

Step 5 Compare the total free capacity to the expected size of your deployment package. 

• If the total free capacity is sufficient, provision the assets in a deployment package, as planned. 

• If the total free capacity is not sufficient, do one of the following: 

– Reduce the size of the deployment package. 
– Delete unused or unimportant assets from the DMP. 
– Attach one external USB drive to the DMP if you have not attached one already. 
– Replace the external USB drive with one that has greater capacity. 

Related Topics 
• Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them 

Configuring DMS-CD Deployment Threshold Preferences 

Note • Given the default Retry Count value of 5, and the default Retry Timeout duration of 300 seconds, you can expect that DMS-CD will take as long as 1,500 seconds (25 minutes) by default to detect content or 
determine that a DMP is unreachable and give up. If this is too long, you might try changing the Retry Timeout value from 300 to 30. 
• Most DMS-CD deployment preference settings that you define take effect during the next scheduled DMS-CD deployment. However, any time that you change the "Number of concurrent deployments" value, you must 
restart your DMM appliance and run a scheduled DMS-CD deployment before the changed setting takes effect on your DMPs. 

Procedure 

Step 1 Choose Digital Media Players > Deployment Manager > Preferences. 

Step 2 Define the DMS-CD thresholds that should be applied by default in the future, when you transfer deployment packages: 

a. Enter or edit the requested values. 

b. Choose the file transfer protocol, FTP or SFTP. 

c. Enable or disable a maximum transfer rate. 

Tip Changes to the maximum transfer rate will have no effect on deployments that are running already. They are applied to deployments that start after you save your changes. 

Step 3 Click Update to save your work and put it into effect. Alternatively, click Cancel to discard your work and restore the previous entries. 

Related Topics 
• UI Reference: Elements to Define Deployment Thresholds 

• Creating a DMS-CD Deployment Package 

• Methods to Monitor and Troubleshoot DMS-CD Deployments 

UI Reference: Elements to Define Deployment Thresholds 
Navigation Path 
Digital Media Players > Deployment Manager > Preferences 

Table 3-28 Elements to Configure DMS-CD Deployment Thresholds  

Element Icon and Description 
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Number of concurrent deployments Note Any time that you change this value, you must restart your DMM appliance before the changed setting takes effect on 
your DMPs. 

The maximum number of FTP or SFTP threads (sessions) that are allowed to run concurrently when DMS-CD provisions assets to a 
DMP. 
The permitted value is any whole number in the range from 1 to 1000. The factory-default value is 100 threads. 

Deployment time limit per file (in 
minutes) 

The count of how many seconds will be allowed to elapse after a DMS-CD deployment package begins to provision any file, before the 
file that reached this threshold is moved to the back of the queue and its transfer is deferred. 
The next file advances to the front of the queue and the deployment continues. DMS-CD applies this threshold to a deployment 
package as many times as necessary until it has cycled through all of its files, and then the transfer is resumed for the deferred file after 
it returns to the front of the queue. This threshold might cause the transfer of any especially large file to be distributed across days. 
Bottlenecks are prevented and as many assets are provisioned as can be provisioned. 
The permitted value is any whole number in the range from 1 to 10080, where 10,080 minutes is the same as 168 hours or 7 days.The 
factory-default value is 1440 minutes. 

Deployment retry count The count of how many times DMS-CD should try again to restart a failed deployment, until DMS-CD stops trying. 
The permitted value is any whole number in the range from 1 to 100. The default value is 5 retries. 

Enable maximum transfer rate The upper threshold allowed for bandwidth consumption by DMS-CD during its deployments to each DMP in your WAN, as measured 
in kilobits per second (Kbps). The value that you enter should be less than the maximum transfer rate of your network. 
The permitted value is any whole number in the range from 28 to 102400, where 102400 Kbps is the same as 100 Mbps. The factory-
default setting is that use of the maximum transfer rate is disabled. 

Deployment Protocol FTP or SFTP. 
If you choose SFTP, connections are encrypted between your DMM server and your DMPs. Otherwise, these sessions use clear text. 
The factory-default setting is FTP. 

Maximum file size (in MB) The maximum number of megabytes — per file — that DMS-CD will transport inside a multifile deployment package to your DMPs, 
before the file that reached this threshold is moved to the back of the queue and its transfer is deferred. 
The next file advances to the front of the queue and the deployment continues. DMS-CD applies this threshold to a deployment 
package as many times as necessary until it has cycled through all of its files, and then the transfer is resumed for the deferred file after 
it returns to the front of the queue. This threshold might cause the transfer of any especially large file to be distributed across days. 
Bottlenecks are prevented and as many assets are provisioned as can be provisioned. 
The permitted value is any whole number in the range from 10 to 1024000, where 1,024,000 MB is the same as 1 TB. The factory-
default maximum size is 600 MB. 

Note Although it is technically feasible to enter a file size as great as 1024000 MB, playback fails for any file that is larger than 
1.9 GB, regardless of the DMP model type. This size is constrained by the limits of streaming. 

Deployment retry time (in seconds) The count of how many seconds must elapse before DMS-CD tries again to transfer a deployment package to a DMP on which the 
transfer failed or was interrupted. DMS-CD will never try to resume an interrupted or failed transfer until at least this many seconds 
have elapsed. 
The permitted value is any whole number in the range from 5 to 10800, where 10800 is equal to 3 hours. The factory-default value is 
300 seconds. 

 
Related Topics 

• Configuring DMS-CD Deployment Threshold Preferences 

Using DMS-CD Deployment Packages to Provision Assets to DMPs 
• Creating a DMS-CD Deployment Package 

• Editing a DMS-CD Deployment Package 

• Deleting a DMS-CD Deployment Package 

• Configuring DMS-CD Deployment Threshold Preferences 

• Methods to Monitor and Troubleshoot DMS-CD Deployments 

Creating a DMS-CD Deployment Package 
Before You Begin 

• Configure download threshold preferences for DMS-CD. 
• Check the free disk space on your DMPs for storing provisioned assets. 

Procedure 
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Step 1 Choose Digital Media Players > Advanced Tasks. 

Step 2 Choose Deployment Package from the Application Types list. 

Step 3 Click  Add New Application. 

Step 4 Enter a name and description for this deployment package. 

Step 5 Choose the mount point for this deployment. You can choose only one: 

• Flash Storage is the flash memory card installed inside a DMP, also known as usb_1. 

• USB is the one external USB hard drive that is attached to a DMP, also known as usb_2. 

Note To learn which external USB drives we support and have tested, see Cisco Digital Media System Compatibility Information on Cisco.com: http://www.cisco.com/en/US/products/ps6681/ 
products_device_support_tables_list.html. 

Step 6 Check the Emergency/Alarm check box if this job consists of assets for an emergency notification. Otherwise, uncheck it. 

Step 7 Populate and save the deployment package. 

a. Click the name of an applications category in the Applications list. 

b. Choose one or more applications from the Available Applications list, and then click Select Applications. 

c. (Optional) Reorder the Selected Applications list. 

d. Click Submit. 

Step 8 Use the Play in Future feature to schedule deployment of this package to your DMPs that should receive it, and then wait for the file transfer to finish. 

Note DMS-CD does not prevent you from using the Actions list or the Play Now feature to start transferring a DMS-CD deployment package immediately. However, using either of these methods defeats many of the 
most important benefits of using DMS-CD. We recommend instead that you use the Play in Future feature to schedule all of your DMS-CD deployment packages. 

Bandwidth capacity in your WAN determines how long you must wait for the deployment to finish. After it is finished, DMM-DSM autogenerates the (Go To) URL action for this deployment package. 

Step 9 Choose Digital Signage > Digital Medial Players > Advanced Task > (Go to) URL. 

Step 10 Check that a (Go to) URL action was autogenerated, which adds the prefix LOCAL to the name that you entered in Step 4. 

Step 11 Deploy this autogenerated (Go to) URL action. 

• Use the Actions list to deploy immediately. 

• Use the Play now feature to deploy immediately. 

• Use the Play in Future feature to schedule a future deployment. 

If you use Play in Future, the scheduled start and stop times are derived from the clock in your DMM appliance. 

Note You cannot use the Deployment Status feature (at Digital Media Players > Deployment Manager > Deployment Status) to check the progress or status of immediate deployments. 

Related Topics 
• Checking Disk Space Capacity for Deployments 

• Configuring DMS-CD Deployment Threshold Preferences 

• Editing a DMS-CD Deployment Package 

• Deleting a DMS-CD Deployment Package 
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Editing a DMS-CD Deployment Package 
Before You Begin 

• Configure download threshold preferences for DMS-CD. 
• Check the free disk space on your DMPs for storing provisioned assets. 
• Create at least one DMS-CD deployment package. 

Procedure 

Step 1 Choose Digital Media Players > Advanced Tasks. 

Step 2 Choose Deployment Package from the Application Types list. 

Step 3 Click the name of the deployment package to be edited. 

Step 4 Click  Edit Application. 

Step 5 (Optional) Edit the name or description for this deployment package. 

Step 6 (Optional) Change the mount point for this deployment. You can choose only one: 

• Flash Storage is the flash memory card installed inside a DMP, also known as usb_1. 

• USB is the one external USB hard drive that is attached to a DMP, also known as usb_2. 

Note To learn which external USB drives we support and have tested, see Cisco Digital Media System Compatibility Information on Cisco.com: http://www.cisco.com/en/US/products/ps6681/ 
products_device_support_tables_list.html. 

Step 7 (Optional) Check the Emergency/Alarm check box if this job consists of assets for an emergency notification. Otherwise, uncheck it. 

Step 8 (Optional) Repopulate and save the deployment package. 

a. Click the name of an applications category in the Applications list. 

b. Choose one or more applications from the Available Applications list, and then click Select Applications. 

c. (Optional) Reorder the Selected Applications list. 

d. Click Submit. 

Step 9 Use the Play in Future feature to schedule deployment of this package to your DMPs that should receive it, and then wait for the file transfer to finish. 

Note DMS-CD does not prevent you from using the Actions list or the Play Now feature to start transferring a DMS-CD deployment package immediately. However, using either of these methods defeats many of the 
most important benefits of using DMS-CD. We recommend instead that you use the Play in Future feature to schedule all of your DMS-CD deployment packages. 

Bandwidth capacity in your WAN determines how long you must wait for the deployment to finish. After it is finished, DMM-DSM autogenerates the (Go To) URL action for this deployment package. 

Step 10 Choose Digital Signage > Digital Medial Players > Advanced Task > (Go to) URL. 

Step 11 Check that a (Go to) URL action was autogenerated, which adds the prefix LOCAL to the name that you entered or edited in Step 5. 

Step 12 Deploy this autogenerated (Go to) URL action. 

• Use the Actions list to deploy immediately. 

• Use the Play now feature to deploy immediately. 

• Use the Play in Future feature to schedule a future deployment. 

If you use Play in Future, the scheduled start and stop times are derived from the clock in your DMM appliance. 
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Note You cannot use the Deployment Status feature (at Digital Media Players > Deployment Manager > Deployment Status) to check the progress or status of immediate deployments. 

Related Topics 
• Checking Disk Space Capacity for Deployments 

• Configuring DMS-CD Deployment Threshold Preferences 

• Creating a DMS-CD Deployment Package 

• Deleting a DMS-CD Deployment Package 

Deleting a DMS-CD Deployment Package 
Before You Begin 

• You must have saved at least one DMS-CD deployment package. 
• Use the Reports feature (at Schedules > Reports) to search your schedule for any instances of the deployment package that you will delete. If you find one or more scheduled instances of it, remove those deployments 
from your schedule. 

Procedure 

Step 1 Choose Digital Media Players > Advanced Tasks. 

Step 2 Choose Deployment Package from the Application Types list. 

Step 3 Click the name of the action to be deleted, click  Delete Application, and then click Submit. 

Step 4 Choose (Go to) URL from the Application Types list. 

Step 5 Click the name of the action to be deleted, click  Delete Application, and then click Submit. 

Related Topics 
• Creating a DMS-CD Deployment Package 

• Editing a DMS-CD Deployment Package 

Methods to Monitor and Troubleshoot DMS-CD Deployments 
• Viewing Status Details for DMS-CD Deployments 

• Checking Appliance System Logs for DMS-CD Deployment Errors 

• Using Snapshot Mode or Live Monitor Mode to Check for DMS-CD Deployment Errors 

Viewing Status Details for DMS-CD Deployments 

Tip Values in the Timestamp column always signify one of these: 
• When you clicked Publish All to provision the described deployment package. 
• When the described deployment succeeded. 
• When the described deployment failed 

Procedure 

Step 1 Choose Digital Signage > Digital Media Players > Deployment Manager > Deployment Status. 
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Step 2 (Optional) Use filtering options above the table to limit how many deployment packages the table describes. 

Step 3 If the Status column shows a value of Failed for the deployment package whose status you are checking, click the corresponding  icon in the far right column. 

Step 4 Scroll through the Deployment Details popup window (see Figure 3-7) until you see an error message that might help you to troubleshoot the failure. For example, an error message might say that DMP login 
credentials were incorrect. 

Figure 3-7 Deployment Details 

Related Topics 
• Methods to Monitor and Troubleshoot DMS-CD Deployments 

Checking Appliance System Logs for DMS-CD Deployment Errors 
Procedure 

Step 1 Log in to AAI on your DMM appliance. 

Step 2 Choose DMM_CONTROL > DMM_LOG_LEVEL > DEBUG, to ensure that the logs are verbose. 

Step 3 Choose APPLIANCE_CONTROL > GET_SYSLOG, and then choose the method to receive the system logfiles. 

Step 4 Search through the IFMS.log and catalina.out logfiles for messages about: 

• DMS-CD deployment events 

• DMP deployment events 

• Application deployment events 
(where "application" is another word for "package") 

• File management events 

• Error events 

• Debug logs 

These are the detected and reported error conditions that DMS-CD logging captures: 
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• DMS-CD cannot retrieve a file. 
• DMS-CD cannot provision a file (DMP out of space or missing USB) 
• DMP is not reachable (is down, or has wrong IP) 
• Deployment was interrupted (network outage, DMM down, etc.) 
• Deployment was not completed during its window 

Related Topics 
• Methods to Monitor and Troubleshoot DMS-CD Deployments 

Using Snapshot Mode or Live Monitor Mode to Check for DMS-CD Deployment Errors 
Procedure 

Step 1 Choose Administration > Alerts > Alert Reports. 

Step 2 Do one of the following: 

• Click Live Monitor Mode and choose an option from the Type list. 

Live monitor mode describes the most recent 100 instances of an event type that you choose, and its data is refreshed automatically every 90 seconds. 
• Click Snapshot Mode, choose the start and stop dates and times, and choose an option from the Type list. 

Snapshot mode describes only the events that match the combination of all parameters that you choose. 
Step 3 Click Apply. 

Note These options from the Type list cause the filtered report to describe only the DMS-CD deployments that failed or succeeded: 
• Deployment Failures 
• Deployment Successes 

These options from the Type list cause the filtered report to describe only the events that DMPs reported, some of which might pertain to disrupted or failed deployments with DMS-CD: 
• DMP Outages 
• DMP Restarts 
• DMP IP Conflicts 

When you choose the All Internal Events option from the Type list, these event types also pertain to deployments: 
• Deployment error 
• Deployment started 
• Deployment ended 

Related Topics 
• Methods to Monitor and Troubleshoot DMS-CD Deployments 

Using Advanced Tasks 
Many advanced tasks and options are available to you in DMM-DSM. Your expectations and goals for your digital signage network determine which tasks and options are relevant to you at any particular time or for any 
particular purpose. 
Procedure 

Step 1 Select Digital Media Players > Advanced Tasks, and then click an application name in the Application Types list, as follows:

Application Type Purpose 

(Go to) URL Load media from a web server into TVzilla, the embedded browser on a DMP. See the "(Go to) URL" section. 

DMP Audio/Video Settings Adjust the audio and video signals that DMPs send to their attached DMP displays. See the "DMP Audio/Video Settings" section. 
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DMP Discovery Autoregister the DMPs in a network range that you specify and add those DMPs to DMM-DSM for centralized management. See the "DMP 
Discovery" section. 

DMP Display Controls Bind together a group of RS232 instructions that you can use to remotely configure display settings on some Cisco, NEC, and DMTech display 
models when displays of these types are attached to your DMPs. See the "DMP Display Controls" section. 

DMP Failover Retry Set the DMP Recovery URL value and the Recovery Timeout value. See the "DMP Failover Retry" section. 

DMP Firmware Upgrade Choose firmware upgrades and patches to send to one or more DMPs. See the "DMP Firmware Upgrade" section. 

DMP Startup URL Configure DMPs to load a particular HTTP URL when you start or restart them. See the "DMP Startup URL" section. 

Deployment Package Configure a DMS-CD deployment to DMP local storage. 

File Transfer to DMP 
or Server 

Tip We recommend that you use DMS-CD instead of this deprecated, legacy feature, which deletes anything that you saved previously to 
the flash memory card inside your DMP, and is unable to transfer assets to any external USB drives that you might have attached to your 
DMPs. 

Use HTTP pulling, use FTP to transfer to your DMPs, or use FTP to transfer to your FTP servers (external deployment servers), the: 
• Assets from presentations that you prepared in Digital Media Designer. 
• Commands and settings from advanced tasks that you selected or configured under the Digital Media Players tab. 

See the "File Transfer to DMP or Server" section. 

System Tasks Select an administrative command to send to one or more DMPs. See the "System Tasks" section. 

 
Step 2 (Optional) If you previously defined or configured options for the relevant application and you saved your selections, click any row in the Applications table to select one of the operations that you defined; the 
row that you click should be one that you want to edit, deploy to DMPs, or delete. 

Step 3 Do one of the following: 

• To define or configure options for a new operation, click  Add New Application. 

• To edit the options that you previously defined or configured for the operation that you selected in Step 2, click  Edit Application. 

• To delete the operation that you selected in Step 2, click  Delete Application. 

Step 4 If you clicked  Add New Application or  Edit Application, the page is refreshed and you can select options or enter values that define or redefine the behavior for this 
operation. 

Step 5 To save your selections, click Submit. Otherwise, click Cancel to discard your selections. 

Step 6 To deploy to your DMPs the commands that you saved in Step 5, see Scheduling Time Slots for Media and Events on DMPs. 

Related Topics 
• UI Reference: Elements to Configure Advanced Tasks 

UI Reference: Elements to Configure Advanced Tasks 
• Deployment Package 

• DMP Audio/Video Settings 
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• DMP Discovery 

• DMP Display Controls 

• DMP Failover Retry 

• DMP Firmware Upgrade 

• DMP Startup URL 

• File Transfer to DMP or Server 

• (Go to) URL 

• System Tasks 

– Default 

– FTP {Off | On} 

– HDMI Autodetection {Off | On} 

– Reboot 

– RS-232: Control DMTech displays 

– RS-232: Control supported, non-DMTech displays 

– Save Settings 

– Save Settings and Reboot 

– Screen Resolution Autodetection {Off | On} 

– Show {Browser | Video} 

– Status 

– Stop All Applications 

– Transparency 50% 

– Upgrade Status 

– Version 

Navigation Path 
Digital Media Players > Advanced Tasks 

Table 3-29 Understanding and Using Advanced Tasks  

Application Name Description, Icons, and Options 
 
(Go to) URL 

Load media from a web server into TVzilla, the embedded DMP browser. 

Name A unique and human-readable name for the website that you will select to show in this task. You must enter a name. The 
name is unique in the sense that you have not used it previously as the name for anything that can be scheduled. 

Description A brief description. The description is optional. 

URL The full and correct HTTP URL that points to a page or file on a webserver. The URL that you enter should point to a 
page that is dynamic and does not require any human interaction (such as clicking or scrolling) to be useful or interesting. 
You must enter a URL. 

 
DMP Audio/Video Settings 

Adjust the audio and video signals that DMPs send to their attached DMP displays. 

Name A unique and human-readable name for the settings that you configure in this task. For example, you might adjust the 
brightness setting to accommodate a locale where the lighting is dim, and then enter a name that identifies that kind of 
locale. You must enter a name. The name is unique in the sense that you have not used it previously as the name for 
anything that can be scheduled. 

Description A brief description. The description is optional. 
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Brightness The setting that compensates for any deficiencies in the on-screen brightness of your DMP displays. Brightness 
compensation values can range from -128 to 127. 

Contrast The setting that compensates for any deficiencies in the on-screen contrast of your DMP displays. Contrast compensation 
values can range from 0 to 255. The default is 128. 

Saturation The setting that compensates for any deficiencies in the on-screen color saturation of your DMP displays. Saturation 
compensation values can range from 0 to 255. The default is 128. 

Left Audio Channel Volume The setting to control how loudly or softly your DMP display speakers play sound in the left audio channel. Volume can 
range from 0 to 100, where 0 is silent. The default is 50. 

Right Audio Channel Volume The setting to control how loudly or softly your DMP display speakers play sound in the left audio channel. Volume can 
range from 0 to 100, where 0 is silent. The default is 50. 

 
DMP Discovery 

Autoregister the DMPs in a network range that you specify and add those DMPs to DMM-DSM for centralized management. For autoregistration and centralized management to 
succeed: 

• Your firewall must allow DMM-DSM and your DMPs to communicate over TCP port 7777 and must also allow ICMP (ping) traffic on this port. 

• In DMPDM, you must enable the Enable Cisco TAC Troubleshooting Access option. Alternatively, see Enabling and Disabling Troubleshooting Access on DMPs. 

To learn about other autoregistration options for the DMPs in your digital signage network, see Adding and Editing DMP Groups, and Autoregistering DMPs to Populate Them. 

Note DMP autoregistration operations occur in sequence and cannot overlap. You should not schedule multiple DMP autoregistration operations that overlap or run 
simultaneously. If you do, only the first such operation will run and DMM-DSM will not show any error message to explain why the other autoregistration operations failed to 
find any DMPs. If you must run autoregistration tasks that search different subnets, schedule a 35-minute interval between the start time for one autoregistration and the 
start time for the next autoregistration. 

Name A unique and human-readable name for this autoregistration IP address range task. You must enter a name. The name is 
unique in the sense that you have not used it previously as the name for anything that can be scheduled. 

Description A brief description. The description is optional. 

Discovery IP Range The NMAP syntax to describe one or multiple ranges of IP addresses. 

 
DMP Display Controls 

Bind together a group of RS-232 instructions that you can use to remotely configure display settings. 
Note Before you can use this feature, you must enable RS-232 support for your displays. Select Digital Media Players > Advanced Tasks > System Tasks; then, 
name, save, and deploy one of these as the correct option for your display type: 
  ·    RS-232: Control DMTech displays. 
  ·    RS-232: Control supported, non-DMTech displays. 

Tip To learn about the RS-232 commands that manage Cisco LCD displays, see Using RS-232 Commands to Manage Cisco LCD Professional Series Displays. 

TV Type Choose the manufacturer and the model type: 
• CISCO_40N 
• CISCO_52S 
• DMTECH 
• NEC_3210 
• NEC_4010 
• NEC_4610 
• NEC_5710 

Contrast Choose or enter a contrast value from 0 to 100. 

Brightness Choose or enter a brightness value from 0 to 100. 

Sharpness Choose or enter a sharpness value from 0 to 100. 

Color Choose or enter a color value from 0 to 100. 

Tint Choose or enter a tint value from 0 to 100. 
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TV Channel Choose or enter the analog television signal frequency for a channel from 0 to 99. 

Audio Volume Choose or enter a volume level from 0 to 100. 

Mute Choose whether to mute the display. 
• on 
• off 

Input Select the input type. Options differ, according to your selection from the TV Type list. 
• TV 
• RGB 
• RGB1 (DVI-D) 
• RGB2 (D-SUB) 
• RGB3 (BNC) 
• DVD/HD 
• Video (Composite) 
• Video 1 
• Video 2 
• Video 3 
• S-Video 
• None (DVD) 
• Component 
• PC 
• HDMI 
• None (DVBT) 

Power Choose whether the television should be turned on. 
• on 
• off 

 
DMP Failover Retry 

Configure the recovery URL to use in case of failover and the interval between attempts to reload that URL if the connection to it is disrupted. 

Name A unique and human-readable name for the DMP failover retry task that you are configuring. You must enter a name. The 
name is unique in the sense that you have not used it previously as the name for anything that can be scheduled. 

Description A brief description. The description is optional. 

Recovery URL The URL to show immediately on a DMP display after its attached DMP restarts for any reason, unless other content is 
scheduled to be shown. If this value is blank, your DMP will reuse the most recent URL that failed to load. 

Recovery Timeout (in seconds) The maximum number of seconds that your DMP will wait for a response from the server that you identify in the Recovery 
URL field before it tries again to reach that server. There is no maximum number of retry attempts. 

 
DMP Firmware Upgrade 

Caution Before you install an upgrade, you must run the "Stop All Applications" system task on all the affected DMPs. To do so, click the Schedules tab, select the 
DMP group that you will upgrade, select Stop All Applications from the Actions list, and then click Go. 

Note Before you upgrade a DMP, you must enable troubleshooting access to it. Later, to restore DMP security after the file transfer is finished, you must disable 
troubleshooting access. See Enabling and Disabling Troubleshooting Access on DMPs 

Send a firmware image or kernel file from your media library to a DMP and command the DMP to install it. 
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Name A unique and human-readable name for the upgrade task that you are configuring. You must enter a name. The name is 
unique in the sense that you have not used it previously as the name for anything that can be scheduled. 

Description A brief description. The description is optional. 

Is Kernel Upgrade? A check box that you use to distinguish firmware upgrades from kernel upgrades. 

Media Categories An object selector that lists all the categories in your media library. From the object selector, click the one category that 
the Available Content table should describe. To learn more about categories, see Working with Assets and Categories in 
Your Media Library. 

•  Opened Media Library — Shows all the categories in your media library until you click to hide 
them. 

•  Closed Media Library — Hides the list of categories until you click to show them. 

•  Content Category — A media library category that you created. 

Available Content Click a row to choose an asset in the category. Its attributes are: 
• Name — A unique and human-readable name that you entered. 
• Source — Says whether the asset is a file (F) or an HTTP URL (U). 
• Data Type — Identifies the type of asset. 
• Size — The file size in bytes. 
• Path — The full pathname that points to the file on the DMP. 
• Description — A brief description. The description is optional. 
• Upload Started — Time stamp (in the format YYYY-MM-DD hh:mm:ss:ms) that says when you 
started to upload the file. 
• Upload Finished — Time stamp (in the format YYYY-MM-DD hh:mm:ss:ms) that says when the 
file was completely uploaded. 

• Status — Says whether a DMP is reachable. A green icon ( ) tells you that the DMP is connected to a 
power source, uses a known IP address, and is reachable. A red icon ( ) tells you that the DMP is unreachable. 

 
DMP Startup URL 

Causes DMPs to load and show media that you specify, immediately after every restart. 
Tip We recommend that you enter a value for either the Video URL or the Browser URL. If both values are blank, you might find that your DMP sometimes loses its ability 
to play even the Shockwave Flash files that it has played successfully in the past. 

Name A unique and human-readable name for the startup URL task that you are configuring. You must enter a name. The name 
is unique in the sense that you have not used it previously as the name for anything that can be scheduled. 

Description A brief description. The description is optional. 

Video URL The HTTP URL (or local path on the DMP) that points to an encoded digital video file  that a DMP should load 
automatically and show immediately after every restart. We do not support any use of spaces in filenames or URLs. The 
supported transport protocols and URL types are: 

• http://<ip_address>/<path_and_filename> 
• udp://<ip_address_of_multicast_server>/<port_number> 

Browser URL The HTTP URL of any document that TVzilla, the embedded browser on a DMP, should load automatically and show 
immediately after each restart. We do not support any use of spaces in URLs. We recommend that you do not point to 
any document or site that requires human interaction to be useful, interesting, or entertaining, because there is no 
keyboard or mouse that you can use to interact with what you show on a DMP display. 

Reboot Necessary? Check the check box if a DMP should restart immediately when it receives this instruction. Uncheck the check box if no 
immediate restart is required. 

 
Deployment Package 

Configure a DMS-CD deployment to DMP local storage. 
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Name A unique and human-readable name for the deployment task that you are configuring for DMS-CD. You must enter a 
name. The name is unique in the sense that you have not used it previously as the name for anything that can be 
scheduled. 

Description A brief description. The description is optional. 

Mount Point Choose whether the assets should be provisioned to the flash memory card inside the DMP (usb_1) or to the one external 
USB drive that you attached to the DMP (usb_2). 

Tip To learn which external USB drives we support and have tested, see Cisco Digital Media System Compatibility 
Information on Cisco.com: http://www.cisco.com/en/US/products/ps6681/products_device_support_tables_list.html. 

Emergency/Alarm Check (tick) this box if the transferred files will be used during emergencies. Otherwise, do not check this box. Assets for 
emergencies are saved to a special partition 

Application Types The list of categories for advanced tasks. Click a category to see its tasks. 

Available Applications Advanced tasks in the category that you clicked. Click anywhere in a row to select the corresponding task. 

•  Select Applications — Moves from the Available Applications table to the Selected Applications 
table the tasks that you selected. 
• Name — The unique and human-readable name that identifies a particular task. 
• Description — A brief description. The description is optional. 

Selected Applications Advanced tasks that you selected from the Available Applications table, so that you could include them in the file transfer 
operation that you are configuring. Click a file transfer task to select its assets for deployment. 

• /   Move Selected Item Up/Down — Reorders the list so that the highlighted item moves up 
(or down) one row, exchanging places with the item that was above it (or below it). 

•  Delete Selected Item — Moves from the Selected Applications table to the 
Available Applications table the applications that you selected. 

• /   Zoom In/Out — Shows only the Selected Applications table, hiding the Available Applications 
table. Alternatively, shows the Selected Applications table and the Available Applications table simultaneously. 

 
File Transfer to DMP or Server 

Caution Before you use a file transfer application to deploy the assets from a new or updated presentation to any of your DMPs, you must first run the "Stop All 
Applications" system task on each affected DMP. To do so, click the Schedules tab, select the DMP group that will use the presentation, select Stop All Applications 
from the Actions list, and then click Go. 

Use HTTP pulling or FTP to transfer to particular DMPs or to external (FTP) deployment servers the assets from presentations that you prepared in DMD, the media and electronic 
program guides for Enterprise TV, or the commands and settings from advanced tasks. (Although it is technically possible, it is not useful to transfer a system task, a (Go to) URL 
task, or a startup URL task.) See Scheduling Time Slots for Media and Events on DMPs. 

Name A unique and human-readable name for the file transfer task that you are configuring. You must enter a name. The name 
is unique in the sense that you have not used it previously as the name for anything that can be scheduled. 

Description A brief description. The description is optional. 

DMP Publishing Protocol 

Caution HTTP pulling is highly scalable but can result in a distributed denial-of-service (DDoS) attack 
against any server, such as your DMM appliance, that is not built and configured to withstand the resulting load. If 
you choose HTTP as the protocol, be sure that your DMPs will pull all files from WAAS, ACNS, or another system 
that can tolerate the load. 

Choose HTTP or FTP as the protocol for the file transfer task. 
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Emergency/Alarm Check (tick) this box if the transferred files will be used during emergencies. Otherwise, do not check this box. Assets for 
emergencies are saved to a special partition 

Application Types The list of categories for advanced tasks. Click a category to see its tasks. 

Available Applications Advanced tasks in the category that you clicked. Click anywhere in a row to select the corresponding task. 

•  Select Applications — Moves from the Available Applications table to the Selected Applications 
table the tasks that you selected. 
• Name — The unique and human-readable name that identifies a particular task. 
• Description — A brief description. The description is optional. 

Selected Applications Advanced tasks that you selected from the Available Applications table, so that you could include them in the file transfer 
operation that you are configuring. Click a file transfer task to select its assets for deployment. 

• /   Move Selected Item Up/Down — Reorders the list so that the highlighted item moves up 
(or down) one row, exchanging places with the item that was above it (or below it). 

•  Delete Selected Item — Moves from the Selected Applications table to the 
Available Applications table the applications that you selected. 

• /   Zoom In/Out — Shows only the Selected Applications table, hiding the Available Applications 
table. Alternatively, shows the Selected Applications table and the Available Applications table simultaneously. 

 
System Tasks 

Predefined commands that you can send to a DMP. When you create or edit a system task, these are the elements: 
• Name — A unique and human-readable name for the system task that you are configuring. You must enter a name. The name is unique in the sense that you have not 
used it previously as the name for anything that can be scheduled. 
• Description — A brief description. The description is optional. 
• Request Type — A list in which the options are Get and Set, in the sense that you can set new values on a DMP or instruct DMM-DSM to get information from a DMP and 
show that information in a popup window. 

• Request — The command string. 

Default 

Caution When you restore factory-default settings on a DMP, you must set it up again. To learn how, see 
the quick start guide on Cisco.com for your DMP model. 

Restore factory default settings. 

FTP {Off | On} Enable or disable the FTP service. 

HDMI Autodetection {Off | On} Enable or disable DMP display type autodetection. 

Reboot 

Caution Restarting a DMP will disrupt whatever it is doing at that time. 

Restart. 

Save Settings Save the active settings. 

Save Settings and Reboot Save the active settings, and then restart. 

Screen Resolution Autodetection {Off | On} Enable or disable autodetection of the resolutions that your DMP displays support. 

Show {Browser | Video} Show one content plane but hide the other. 
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Status See the DMP status message in real time. 

Stop All Applications Stop every application that DMPs are running. 

Transparency 50% Set the browser plane (TVzilla) to be partially transparent and show the video plane through it. 

RS-232: Control DMTech displays Tip Before you pass RS-232 commands through your DMPs and to your DMP displays, first confirm that each 
DMP is connected to its display by a signal cable that supports RS-232 signals; otherwise, your displays will never 
receive the commands that you define for them. 

Cause DMPs to send RS-232 management instructions to an LCD display manufactured by DMTech. 

RS-232: Control supported, non-DMTech displays Tip Before you pass RS-232 commands through your DMPs and to your DMP displays, first confirm that each 
DMP is connected to its display by a signal cable that supports RS-232 signals; otherwise, your displays will never 
receive the commands that you define for them. 

Cause DMPs to send RS-232 management instructions to an LCD display manufactured by Cisco or NEC. 

Upgrade Status See the DMP upgrade status message in real time. 

Version See the installed firmware version number. 

  • Stream Type — Shows the type of stream. The supported stream type is UDP. 
DMM-DSM cannot show MPEG-1 files in a UDP multicast stream. To stream MPEG-1 video from DMM-DSM, 
you must use unicast. 

• IP — The IP address of the multicast server. You must enter an IP address. 
• Port — The logical port number through which the multicast server transmits the stream. You must enter the 
port number. 

 
Stopping All Running Events and Commands on DMPs 
Procedure 

Step 1 Use the Actions list or use the Play Now feature to deliver the Stop All Applications command to the DMP group that should receive this command. 

Related Topics 
• Using Play Now to Deploy Assets or Commands Immediately to DMPs 

• Using the Actions List to Deploy Assets or Instructions Immediately to DMPs 

Enabling and Disabling Troubleshooting Access on DMPs 
• Enabling DMP Troubleshooting Access 

• Disabling DMP Troubleshooting Access 

Enabling DMP Troubleshooting Access 
Procedure 

Step 1 Choose Digital Media Players > Advanced Tasks. 

Step 2 Click System Tasks in the list of defined tasks, and then click  Add New Application. 

Step 3 Enter a name and, optionally, a description. 

Step 4 Choose Set from the Request Type list. 

Step 5 Use this syntax in the Request field:  
init.startService_shell=yes&mib.save=1&mng.exit=1. 

Step 6 Click Submit to save your work. 

Step 7 Deploy this troubleshooting access command to the DMP immediately. 

Related Topics 
• Disabling DMP Troubleshooting Access 
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• Using Play Now to Deploy Assets or Commands Immediately to DMPs 

• Using the Actions List to Deploy Assets or Instructions Immediately to DMPs 

Disabling DMP Troubleshooting Access 
Procedure 

Step 1 Choose Digital Media Players > Advanced Tasks. 

Step 2 Click System Tasks in the list of defined tasks, and then click  Add New Application. 

Step 3 Enter a name and, optionally, a description. 

Step 4 Choose Set from the Request Type list. 

Use this syntax in the Request field:  
init.startService_shell=no&mib.save=1&mng.exit=1. 

Step 5 Click Submit to save your work. 

Step 6 Deploy this troubleshooting access command to the DMP immediately. 

Related Topics 
• Enabling DMP Troubleshooting Access 

• Using Play Now to Deploy Assets or Commands Immediately to DMPs 

• Using the Actions List to Deploy Assets or Instructions Immediately to DMPs 

Upgrading the Firmware or Kernel on DMPs 
You can transfer a DMP kernel file or firmware image from your media library to a DMP and send commands to install it on the flash memory card inside the DMP. 
Before You Begin 

• Add the firmware image or kernel file to your media library. 
• Stop all events and commands that are running on the DMPs to be upgraded. 
• Enable troubleshooting access on the DMPs to be upgraded. 

Procedure 

Step 1 Choose Digital Signage > Digital Media Players > Advanced Tasks. 

Step 2 Click DMP Firmware Upgrade. 

Step 3 Click  Add New Application. 

Step 4 Enter a unique name and, optionally, a description. 

Step 5 Check the Is Kernel Upgrade? check box if the asset is a kernel file.  
Otherwise, if the asset is a firmware image, uncheck this check box. 

Step 6 Click the parent category for this asset in the Media Categories object selector. 

Step 7 Click the row that describes this asset in the Available Content table. 

Step 8 Click Submit to save your work as a deployable action.  
Alternatively, click Cancel to discard your work. 

Step 9 Deploy your work: 

• Use the Actions list to deploy it immediately. 

• Use the Play now feature to deploy it immediately. 

• Use the Play in Future feature to schedule a future deployment. 

Step 10 After the deployment is finished: 

a. Disable troubleshooting access on the DMPs that you upgraded. 
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b. Restart the DMPs that you upgraded. 

Related Topics 
• Adding One Asset at a Time to Your Media Library 

• Stopping All Running Events and Commands on DMPs 

• Enabling and Disabling Troubleshooting Access on DMPs 

• Using Play Now to Deploy Assets or Commands Immediately to DMPs 

• Using the Actions List to Deploy Assets or Instructions Immediately to DMPs 

• Working with Future Deployments 

Planning for and Responding to Emergencies 
When emergencies of any kind affect sites where you deploy digital signage, you can use DMP displays to alert your viewers, warn them about dangers that might affect them, and direct them to safety. Or you can provide other 
kinds of information to them as you see fit. Until you stop playing emergency messages, they override all events that were scheduled to run automatically. 
It is important to remember that emergency message insertions in your schedule will override only the events that are scheduled to run automatically. Furthermore, such insertions will override these events on only the DMPs 
that the emergency message insertion affected. All other DMPs in your network will abide by their schedule, without disruption. 
Emergency conditions might prevent messages from playing on your DMP displays. 

Note Consider very carefully which DMM-DSM users should have permission to work with your schedule and manage your DMP groups. Although all of the "Play in Future" features are suspended (for affected DMPs only) 
while an emergency is in progress, none of the "Play Now" features or "DMP Manager" features are suspended. Therefore, it is possible for a careless user or malicious user with sufficient permissions to start another event 
manually on the DMPs where an emergency message should play. 

If policies in your organization require of you that one or more screen zones must show assets that are editable, you can stage the editable assets remotely on one of your external deployment servers instead of staging them 
locally on your DMPs. Then, the people in your organization who are entrusted to edit these assets can change them — to update the emergency message, for example — in real time. 
After an emergency has stopped and normal scheduling has resumed on a DMP group and its children, any playlist or presentation that was scheduled for playback at that time will start from the beginning. 

• Creating Deployment Packages for Emergencies 

• Provisioning Emergency Assets Immediately to DMP Local Storage 

• Scheduling the Future Staging of Emergency Assets to DMP Local Storage or to External Servers 

• Starting Playback of an Emergency Message 

• Stopping Playback of an Emergency Message 

Creating Deployment Packages for Emergencies 
Before You Begin 

• Populate the playlist or design the presentation whose assets you will transfer to your DMPs. 
Procedure 

Step 1 Define a deployment task for DMS-CD to provisioning emergency assets to DMP local storage. 

Alternatively, do the following to define a file transfer task that you can deploy: 

a. Choose Digital Media Players > Advanced Tasks, and then click File Transfer to DMP or Server. 

b. To create a new file transfer task, click  Add New Application. 

c. After the page is refreshed, do the following to define behaviors for, and save, the file transfer task: 

1. Enter a specific name, such as "Fire" or "Flash Flood," for the type of emergency. You might want to use a less specific name, such as "Emergencies," if this task will transfer the assets for multiple 
presentations or playlists, or if your organization uses one playlist or presentation for emergencies of all kinds. 
2. From the DMP Publishing Protocol list, choose FTP or HTTP, and then check the Emergency/Alarm check box. 
3. If the assets are part of a saved presentation, click Presentations in the Applications list. Alternatively, if the assets are part of a saved playlist, click Playlists. 

4. After the page is refreshed, click in the Available Applications list the name of the presentation or playlist whose assets should be transferred, and then click  Select Applications. 
5. (Optional) To transfer the assets for multiple playlists and presentations, repeat the preceding step. 
6. To save this task, so that it becomes available for deployments, click Submit. 
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Note Even though you created and saved a file transfer task, you have not used it yet. Your DMPs will not have local copies of the emergency assets until after you run this task successfully. 

Step 2 Provision the emergency assets to your DMPs. 

Related Topics 
• Working with Presentations, Templates, and Presentation Playlists for Digital Signage 

• Using DMS-CD Deployment Packages to Provision Assets to DMPs 

• Using the Actions List to Provision Emergency Assets Immediately 

• Using the Play Now Feature to Provision Emergency Assets Immediately 

• Scheduling the Future Staging of Emergency Assets to DMP Local Storage or to External Servers 

Provisioning Emergency Assets Immediately to DMP Local Storage 
• Using the Actions List to Provision Emergency Assets Immediately 

• Using the Play Now Feature to Provision Emergency Assets Immediately 

Using the Actions List to Provision Emergency Assets Immediately 
Before You Begin 

• Create and save deployable messages for playback during emergencies. 
Procedure 

Step 1 Click the DMP Manager tab and then, in the DMP Groups tree, click the name of the group whose member DMPs should have local copies of the emergency assets. 

Step 2 In the Actions list, scroll down to the name of the deployment task or the file transfer task that you created, and then click that name. 

Step 3 Click Go to issue the command immediately that transfers copies of the assets to your DMPs, and to create as many Go-to URL entries (all using the prefix "Alarm") as the number of presentations and 
playlists that you chose. 

Related Topics 
• Using DMS-CD Deployment Packages to Provision Assets to DMPs 

• Provisioning Emergency Assets Immediately to DMP Local Storage 

• Scheduling the Future Staging of Emergency Assets to DMP Local Storage or to External Servers 

• Starting Playback of an Emergency Message 

• Stopping Playback of an Emergency Message 

Using the Play Now Feature to Provision Emergency Assets Immediately 
Before You Begin 

• Create and save deployable messages for playback during emergencies. 
Procedure 

Step 1 Choose Schedules > Play Now. 

Step 2 From the Select an Event Type list, choose System Tasks and then click Select System Tasks. 

Step 3 Do one of the following after the Select Event dialog box opens: 

• If you created a DMS-CD deployment task for this emergency, click Deployment Package in the Type column, and then click the name of the task in the Application Name column. 

• If you created a file transfer task for this emergency, click File Transfer to DMP or Server in the Type column, and then click the name of the task in the Application Name column. 

Step 4 Click OK to confirm your selection and close the Select Event dialog box. 

Step 5 Click the name in the DMP Groups tree of the group whose member DMPs should have local copies of the emergency assets. 

Step 6 Click Submit to issue the command immediately that transfers copies of the assets to your DMPs, and to create as many Go-to URL entries (all using the prefix "Alarm") as the number of presentations and 
playlists that you chose. 
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Related Topics 
• Using DMS-CD Deployment Packages to Provision Assets to DMPs 

• Using the Actions List to Provision Emergency Assets Immediately 

• Scheduling the Future Staging of Emergency Assets to DMP Local Storage or to External Servers 

• Starting Playback of an Emergency Message 

• Stopping Playback of an Emergency Message 

Scheduling the Future Staging of Emergency Assets to DMP Local Storage or to External Servers 
Before You Begin 

• Create and save deployable messages for playback during emergencies. 
Procedure 

Step 1 Choose Schedules > Play in Future. 

Step 2 From the calendar, choose the year, month, and day when the assets should be transferred. The timeline is updated automatically, so that it shows the schedule for that day. 

Step 3 Choose Advanced Tasks from the Add an Event list, which is located under the timeline. 

Step 4 Use features of the Schedule Task dialog box to choose the DMPs or the external servers. 

a. Click Select Group, and then click the name of the group whose members should have local copies of the emergency assets. 

b. Click OK to confirm your selection and close the Select DMP Group dialog box. 

Step 5 Choose the task: 

a. Click Select Advanced Tasks. 

b. Do one of the following after the Select Advanced Tasks dialog box opens: 

• If you created a file transfer task for this emergency, click File Transfer to DMP or Server in the Types list, and then click the name of the task in the Application Name column. 

• If you created a DMS-CD deployment task for this emergency, click Deployment Package in the Types list, and then click the name of the task in the Application Name column. 

Note You cannot use DMS-CD to deploy to an external server. DMS-CD supports deployments to DMPs only. 

c. Click OK to confirm your selection and close the Select Advanced Tasks dialog box. 

You can use the provided controls to adjust the start and stop time for this task. Remember to allow sufficient time for the transfer to complete. The amount of time required can vary according to the cumulative file 
size of the selected assets, the capacity of your network, any congestion in your network, and possibly other factors. Emergency conditions might prevent messages from playing on your DMP displays. 
Do not use any of the provided controls for repeating a task. 

Step 6 Click Save to confirm your selections and close the Schedule Task dialog box. 

Step 7 Click Save All to save your work in the schedule before you try to publish it. 

Step 8 Click Publish All to transmit the deployment according to the schedule that you defined. 

Related Topics 
• Configuring the Settings to Deploy to External Servers 

• Using DMS-CD Deployment Packages to Provision Assets to DMPs 

• Provisioning Emergency Assets Immediately to DMP Local Storage 

• Starting Playback of an Emergency Message 

• Stopping Playback of an Emergency Message 

Starting Playback of an Emergency Message 
Before You Begin 

• Create and save deployable messages for playback during emergencies. 
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• Provision assets for the emergency message to DMP local storage or a network server. 
Procedure 

Step 1 Do one of the following: 

• Choose Digital Media Players > Emergencies. 

• Choose Schedules > Emergencies. 

Step 2 Click Start Emergency. 

Step 3 From the Select Emergency list, choose the playlist or presentation that your DMPs should play during the type of emergency that is now in progress. 

Entries that you see in the Select Emergency list are derived from file transfer tasks that you saved after checking the Emergency/Alarm check box. You cannot add the "ALARM" prefix manually to the name of a (Go to) URL 
task to make the task appear in the Select Emergency list. Nor can you delete the "ALARM" prefix manually from the name of a (Go to) URL task to exclude the task from the Select Emergency list. 

Step 4 Expand the Select DMP Group tree, click the entry for the DMP group whose member DMPs should all announce the emergency, and then click Start. 

If you choose a DMP group that has child groups, the child groups and their member DMPs are also selected automatically. 

While this emergency is in-progress, the event-scheduling features at Schedule > Play in Future will be suspended temporarily for whichever group and children you chose. However, your other DMP groups will not be affected. 
You still can schedule events for those other groups. Later, after you stop this emergency, the event-scheduling features at Schedule > Play in Future will be restored for the group and children that you chose. 

Step 5 To confirm your selections and start playback immediately of your emergency presentation or emergency playlist, click OK. (Emergency conditions might prevent messages from playing on your 
DMP displays.) Alternatively, to discard your selections without playing any assets for any emergency, click Cancel. 

A message tells you whether you submitted the emergency successfully. After you dismiss the message, the page is refreshed. If you submitted the emergency, the DMP group that you chose in Step 4 is colored red in the 
Select DMP Group tree. 

Tip You can submit an emergency to a DMP group while it is showing a playlist or presentation that describes some other emergency. There is no need to explicitly stop playback of the current emergency message before 
you start another one. 

Related Topics 
• Planning for and Responding to Emergencies 

• Scheduling the Future Staging of Emergency Assets to DMP Local Storage or to External Servers 

• Stopping Playback of an Emergency Message 

Stopping Playback of an Emergency Message 
Before You Begin 

• Start playback of an emergency message. 
Procedure 

Step 1 Do one of the following: 

• Choose Digital Media Players > Emergencies. 

• Choose Schedules > Emergencies. 

Step 2 Click Stop Emergency. 

Step 3 Expand the Select DMP Group tree, click the DMP group that is colored red, and then click Stop. 

If you choose a DMP group that has child groups, the child groups and their member DMPs are also selected automatically. 

Step 4 To confirm your selections, which will stop playback of your emergency message and restore normal scheduling for the DMP group (and children) that you chose, click OK. Alternatively, to discard your 
selections without stopping the emergency, click Cancel. 

A message tells you whether you stopped the emergency successfully. After you dismiss the message, the page is refreshed. If you stopped the emergency, the DMP group that you chose in Step 3 is no longer colored red in 
the Select DMP Group tree. 

If you selected a DMP group whose member DMPs were not showing emergency messages, these DMPs will stop and then restart their playback of whatever asset they are scheduled to show. 
If separate emergencies were in effect simultaneously across multiple DMP groups and you stopped the emergency for only one group, remember that the event-scheduling features at Schedule > Play in Future still are 
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suspended for all groups where emergencies remain in effect. 
Related Topics 

• Starting Playback of an Emergency Message 

Scheduling Time Slots for Media and Events on DMPs 

Tip Network congestion or other performance problems at a DMP deployment site might cause the assets that you deploy to pause, stop, or play at unacceptably low speeds. To work around this problem, troubleshoot 
network performance at the deployment site and consider upgrading its network or applying policies to shape and prioritize its traffic. 

In DMM-DSM, you can schedule events to start manually ("Play Now") or run automatically ("Play in Future"). Topics in this section tell you how to deliver to your DMPs and servers the assets and commands that you saved in 
DMM-DSM, as well as the TV channels and VoDs that you saved in DMM-ETV. 

• Using Play Now to Deploy Assets or Commands Immediately to DMPs 

• Working with Future Deployments 

• Preempting a Recurring Event for a One-time Event 

• Using Deployment Reports 

Note To learn how to configure DMM-DSM support for ACNS and WAAS, see Configuring the Settings to Use ACNS or WAAS. 

Using Play Now to Deploy Assets or Commands Immediately to DMPs 
In DMM-DSM and DMM-ETV, you can schedule any command, event, presentation, playlist, TV channel, electronic program guide, VoD, or anything else for deployment to DMPs. You can deploy immediately to one DMP or to 
multiple DMPs that all use the same one DMP group as their parent. 

Note • In this release, we do not support immediate deployments to external (FTP) servers. 
• We recommend that you avoid using immediate deployments with ACNS, due to the amount of time required to distribute assets throughout your network and to its edge. If you do so despite this recommendation, DMM-
DSM always uses the default ACNS channel. You cannot select any other channel. 
• We recommend that you avoid using immediate deployments with WAAS, due to the amount of time required to distribute assets throughout your network and to its edge. 

Before You Begin 
• You must already have created and saved what you will deploy. See Working with Assets and Categories in Your Media Library. See also Using Advanced Tasks. 

• You must already have created the DMP group whose member DMPs should receive the deployment. See Managing and Grouping Your DMPs. 

Procedure 

Step 1 Choose Schedules > Play Now. 

Step 2 From the Event Type list, choose Digital Signage, Enterprise TV, or System Tasks, depending on which of these is the deployment type. 

The option that you choose from the Event Type list causes a button to be shown. Its name is derived from your choice. 

Step 3 To choose specifically what should be deployed to your DMPs, click this button. 

A dialog box opens, from which you can choose specifically what to deploy. The name and elements of this dialog box will vary, depending on which option you chose from the Event Type list. 

Step 4 Click the name of the instruction or asset to be deployed, and then do one of the following: 

• To confirm your selection and close the dialog box, click OK. 

• To discard your selection and close the dialog box, click Cancel. 

Step 5 In the DMP Groups object selector, click the name of a DMP group to see a list of its member DMPs. 

Step 6 In the list of DMPs, Ctrl-click the name of each DMP that should receive the deployment. 

Step 7 Do one of the following: 

• To confirm your selections and deploy the element immediately, click Submit. 
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• To discard your work for this deployment, click Cancel. 

Related Topics 
• Using the Actions List to Deploy Assets or Instructions Immediately to DMPs 

• Working with Future Deployments 

Using the Actions List to Deploy Assets or Instructions Immediately to DMPs 
Procedure 

Step 1 Choose Digital Media Players > DMP Manager. 

Step 2 Do either of the following: 

• Navigate in the DMP Groups object selector, expanding its levels as necessary until you find in its hierarchy the parent group for a DMP that should receive assets or instructions. Then, click the name of this DMP group 
in the object selector. 

• Choose an option from the Filter list to restrict which DMPs the DMP List table describes. 

Step 3 (Optional) If DMP data in the table straddles multiple pages, use pagination controls above the table to move between pages. 

Step 4 Choose which DMPs in the DMP List table should receive the assets or instructions that you will deploy. 

Step 5 Choose an action from the Action list, above the DMP List table. 

Step 6 Click Go. The specified action starts immediately. 

Related Topics 
• Using Play Now to Deploy Assets or Commands Immediately to DMPs 

• UI Reference: Top-Level Settings to Manage DMPs and DMP Groups 

• Scheduling Time Slots for Media and Events on DMPs 

Working with Future Deployments 
You can schedule future time slots for elements that you will deploy once or repeatedly to: 

• One registered DMP, if it belongs to a DMP group which does not contain any other DMPs. 
• Multiple registered DMPs that all use the same one DMP group as their parent. 
• All of your registered external (FTP) deployment servers; the schedule treats all of your registered external servers identically. 

You can schedule a deployment to occur at any time and recur any number of times (within reason), and you can schedule any number of deployments. The schedule can manage multiple deployments simultaneously 
and — assuming that a DMP has a fast network connection and you send deployments to it that are not mutually exclusive — a DMP can receive multiple deployments simultaneously. 

Tip You can view two types of summary for any scheduled deployment. See: 
• Understanding Tooltips in the Schedule Timeline 

• Viewing Status Messages Inline for Deployed Events in the Schedule Timeline 

This section contains these topics: 
• Best Practices for Managing and Maintaining the Schedule 

• Understanding Future Deployments for Presentations 

• Understanding Time Zones in the Schedule 

• Scheduling the Time Slot for a Future Event 

Best Practices for Managing and Maintaining the Schedule 
Avoid placing entries in your schedule that recur often and persist for an unreasonably long time, and also avoid all other practices that might cause your schedule to become too large. Otherwise, DMM might not generate your 
manifest files quickly enough and your ACNS CDM or root CE might time out. We recommend that you apply this rough algorithm: 

• An entry that recurs daily should persist in your schedule for no more than 3 days. 
• An entry that recurs weekly should persist in your schedule for no more than 3 weeks. 
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• Almost never schedule event instances that extend more than 60 days into the future. The exceptions to this rule are: 
– An entry that recurs monthly can persist in your schedule for as long as 3 months. 
– An entry that recurs annually can persist in your schedule for as long as 3 years. 

Furthermore, we recommend these additional best practices: 
• Avoid deploying assets to any given DMP more than once per day. Ideally, all deployments should occur outside your normal business hours. You can schedule a deployment package that contains assets for more 
than one presentation if the target DMP has sufficient local storage to save the entire package. Applied outside normal business hours, this simple method reduces your dependence on daytime deployments, which might 
otherwise disrupt your digital signage temporarily. 
• Avoid having any more than approximately 200 events (of all kinds, combined) saved in your schedule at any one time. 
• Avoid having any more than approximately 100 presentations saved in DMD at any one time. If your presentations database grows too large, you might be prevented from designing, saving, and deleting presentations, 
and the start time might be disrupted for your scheduled events. 
• Instead of creating a presentation that is similar to one that used to be in your schedule, simply modify the old presentation and reschedule it. 
• Avoid extending the playback window for your customer-facing presentations and playlists beyond the actual hours when customers will see them. 
• If you are not sure when or how many times a task or presentation occurs in your schedule, you can use the Schedule Reports feature. 

Understanding Future Deployments for Presentations 
You can deploy only one presentation at a time if the assets that it uses should be stored directly on your DMPs. To check the free space on the SD memory card in a DMP, choose Digital Media Players > DMP 
Manager, and then look in the DMP List table for the amounts of free space in internal and external storage. Alternatively, log in to the local instance of DMPDM, and then click Internal Storage. If you want a 
particular presentation to play during stage-one failover on a DMP, the combined file size of all its assets must not be any more than: 

• 0.9 GB (900 MB) on a DMP 4300G. 
• 1.9 GB on a DMP 4305G. 
• 3.8 GB on a DMP 4400G. 

Caution Do not delete the scheduled deployment job for a presentation to stop it from playing on your DMPs. If you delete the deployment job, your DMPs will continue to use the presentation as if you did nothing. 
This happens because each deployment job includes an instruction to stop, but you delete that instruction when you delete the deployment job that contains it. To stop your DMPs from using a presentation in this case, 
create and deploy an advanced task to stop all applications. See the "System Tasks" row in Table 3-29. 

Note It is important that you understand all of the possible limitations and effects of deploying to an FTP server, as well as the exact circumstances that lead to these effects. Files are sometimes unplayable or deleted 
automatically; subdirectories are sometimes created automatically; and values that you enter in DMM-DSM are sometimes changed automatically. 

• Video files do not play at all if you deploy a presentation to an FTP server when the presentation uses MPEG files that are: 
– Requested through Microsoft Proxy Server. 
– Requested through Microsoft Internet Security and Acceleration Server. 

• When your media library in DMM-DSM is the source for a file that you deploy as part of a presentation, and when you select an FTP server as the target to receive that file, DMM-DSM transfers copies of the relevant file 
to all of the FTP servers that you have registered. After the transfer is completed, DMM-DSM deletes the original file from its media library, and then changes the relevant presentation so that it uses a URL instead of a local 
path. The URL that DMM-DSM enters automatically is specific to whichever FTP server you registered first. 
• When an HTTP URL is the source for a deployed file, and when the pathname on the source server contains subdirectories that do not exist on the target FTP server, DMM-DSM automatically creates the required 
subdirectories on the FTP server. 

Understanding Time Zones in the Schedule 
Future time slots that the schedule describes will always designate hours in boldface numerals according to the UTC time zone offset for the locale where your DMM appliance is installed. If you are working from any other time 
zone when you view the schedule, this offset will differ from the offset for your locale and the difference might be confusing. Furthermore, the offset might be confusing even if you and your DMM appliance are together in one 
time zone but you want to schedule time slots for a DMP that is in some other time zone. 
In either scenario, you can cause the schedule to designate hours from two time zones simultaneously. One of these time zones is always the one for your DMM appliance. To choose the second time zone (whether it is for your 
locale or the locale of a DMP), select a named UTC offset option, such as "America/Los Angeles," from the untitled list above the schedule. 
The schedule is updated immediately to show designated hours from the second time zone that you selected, in addition to the designated hours that it always shows for your DMM appliance: 

• Small, plain numerals designate hours for the UTC-offset locale that you selected. 
• Large, boldface numerals designate hours for the locale where your DMM appliance is installed. 

Scheduling the Time Slot for a Future Event 

Tip Displayed times for deployments in the schedule are relative to the time zone where you deployed your DMM appliance, not the time zone where you deployed any DMP, and not the time zone for any other locale. You 
set the time zone value for your DMM appliance when you used AAI to configure it and you can use AAI to correct the time zone value if it is wrong. 
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• To learn how to set or reset the time zone, see the "Administering a DMM Appliance" chapter in Appliance Administration Guide for Cisco Digital Media System 5.1.x on Cisco.com. 
• To understand how the schedule represents time zones, see Understanding Time Zones in the Schedule. 

• If the user interface for the schedule does not load correctly in your browser, see Release Notes for Cisco Digital Media System 5.1.x on Cisco.com. 

Before You Begin 
• You must already have created and saved the elements that you will deploy. See Working with Assets and Categories in Your Media Library. 

• You must already have created the DMP group that should receive a deployment. See Managing and Grouping Your DMPs. 

Procedure 

Step 1 Choose Schedules > Play in Future. 

Step 2 From the calendar, choose the year, month, and day when the deployment should start. 

The timeline is updated automatically, so that it shows the schedule for that day. 

Step 3 From the Event Type list, under the timeline, choose the deployment type. 

Step 4 When the Schedule Task dialog box opens, complete these steps: 

a. Click Select Group, click the group name for the DMPs or the external (FTP) deployment servers that should receive this deployment, and then click OK. 

b. Click the Select <event_type> Tasks button, click the name of the specific event to be deployed, and then click OK. 

c. To designate the start and stop times for this event: 

• In the Start Time area — For the deployment date that you chose in Step 2, enter the hour (numeric, in the range from 1 to 12) and minute (numeric, in the range from 00 to 59) when DMPs should start this event, 
and then enter either AM or PM as the period. 

• In the Stop Time area — Use the same method to specify when DMPs should stop this event. 

Step 5 From the Repeat list, choose the recurrence interval for this event. The intervals are: 

• Never 

• Every Day 

• Every Week 

• Every Month 

• Every Year 

Step 6 To save your selections, click Save All. 

Note • If you do not click Save All, the schedule discards your selections immediately after you refresh your browser or load any other page. 
• You must click Save All even if you do not plan to deploy the event right away. Later, when you are ready to deploy the event, click Publish All. 

Step 7 (Optional) To make copies of an event in the schedule, so that it recurs as many times as you want and at any interval that you specify: 

a. Click the event description on the timeline, and then choose Add an Event > Duplicate All. 

b. Click the first Select button to choose the group whose event will be copied, and then click OK. 

c. Click the second Select button to choose the group that should receive the copy, and then click OK. 

d. Click Save. 

Step 8 To transmit the deployment according to the schedule that you defined — and synchronize it if you use ACNS or WAAS — click Publish All. 

Understanding Tooltips in the Schedule Timeline 
Whenever your pointer hovers over a event in the timeline, the schedule shows a tooltip. Information in the tooltip describes the current status of the corresponding event and summarizes its most important attributes. 
Information in the tooltip is organized as follows:
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Table 3-30 Schedule Timeline Tooltips  

Category Description 

Status One of the following: 
• New — You made selections to define a new deployment. However, because you have not yet clicked Save, the schedule will 
discard your selections if you refresh your browser or load any other page in it. 
• Saved — You made selections to define a new deployment and you clicked Save. You created a permanent record for the 
deployment, but have not scheduled it yet to run. 
• Published — You made selections to define a deployment, you saved your selections, and the deployment is scheduled to run at 
the times that you specified. 
• Scheduled — The deployment is occurring now. 
• Finished — The deployment occurred at the scheduled time and is now stopped. 

App The selection that you made from the Applications list. 

Group The selection that you made from the DMP Groups list. 

From The date and time when the deployment is (or was) scheduled to start. 

To The date and time when the deployment is (or was) scheduled to stop. 

Repeat The number of times that the deployment is scheduled to recur. 

Start Cmd Result (Total/OK/
Failed) 

N/N/N, where: 
• The first N is a color-coded (black) numeral that counts the total number of times that DMM-DSM tried to deploy the command to 
start the designated task. 
• The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM succeeded in deploying the 
command to start the designated task. 
• The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed to deploy the command to start the 
designated task. 

Stop Cmd Result (Total/OK/
Failed) 

N/N/N, where: 
• The first N is a color-coded (black) numeral that counts the total number of times that DMM-DSM tried to deploy the command to stop 
the designated task. 
• The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM succeeded in deploying the 
command to stop the designated task. 
• The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed to deploy the command to stop the 
designated task. 

 
Viewing Status Messages Inline for Deployed Events in the Schedule Timeline 
Whenever you let your pointer hover over a scheduled deployment in the timeline, DMM-DSM describes the current status of the corresponding deployment and summarizes its most important attributes. Information in the 
popup is organized as follows:

Table 3-31 Elements to Describe the Current Status of Scheduled Events  

Category Description 

Application Name The selection that you made from the Applications list. 

Application Type Either Digital Media Designer (see Working with Presentations, Templates, and Presentation Playlists for Digital Signage) or one of 
the following (see Using Advanced Tasks): 

• (Go to) URL 
• Deployment Package 
• DMP Audio/Video Settings 
• DMP Discovery (autoregistration) 
• DMP Display Controls 
• DMP Failover Retry 
• DMP Firmware Upgrade 
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• DMP Startup URL 
• File Transfer to DMP or Server 
• System Tasks 

From The date and time when the deployment is (or was) scheduled to start. 

To The date and time when the deployment is (or was) scheduled to stop. 

How Often The number of times that the deployment is scheduled to recur. 

Status One of the following: 
• New — You made selections to define a new deployment. However, because you have not yet clicked Save, DMM-DSM 
will discard your selections if you refresh your browser or load any other page in it. 
• Saved — You made selections to define a new deployment and you clicked Save. DMM-DSM created a permanent 
record for the deployment, but has not scheduled it yet to run. 
• Published — You made selections to define a deployment, you saved your selections, and DMM-DSM has scheduled 
the deployment to run at the times that you specified. 
• Scheduled — The deployment is occurring now. 
• Finished — The deployment occurred at the scheduled time and is now stopped. 

Group The selection that you made from the DMP Groups list. 

Start Command Summary (Total/OK/
Failed) 

N/N/N, where: 
• The first N is a color-coded (white) numeral that counts the total number of times that DMM-DSM tried to deploy the 
command to start the designated task. 
• The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM succeeded in deploying the 
command to start the designated task. 
• The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed to deploy the command to 
start the designated task. 

Stop Command Summary (Total/OK/
Failed) 

N/N/N, where: 
• The first N is a color-coded (white) numeral that counts the total number of times that DMM-DSM tried to deploy the 
command to stop the designated task. 
• The second N is a color-coded (green) numeral that counts the number of times that DMM-DSM succeeded in deploying the 
command to stop the designated task. 
• The third N is a color-coded (red) numeral that counts the number of times that DMM-DSM failed to deploy the command to 
stop the designated task. 

 
In addition, a status bar at the bottom of the popup window counts the number of errors associated with the described deployment. 

Preempting a Recurring Event for a One-time Event 
In some cases, you might want to show a presentation one time, or for a limited time, that overlaps with a recurring deployment. 
For example, you might schedule a presentation to run from 9:00 a.m. to 6:00 p.m. every weekday in the month of March, but want to show a different presentation on the second Tuesday in March. The problem in this scenario 
is that your DMP cannot prioritize contradictory events that are scheduled to start simultaneously. However, there are three possible methods that you might use to schedule a preemption. In this scenario, you can do any of the 
following:

Method 1 1. Schedule and deploy a recurring event for the first uninterrupted span of dates. 
2. Schedule and deploy the one-time event. 
3. Schedule and deploy a copy of the first recurring event for the second uninterrupted span of dates. 
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Method 2 Create two DMP groups. In this scenario, we will call them Group_A and Group_B. 
• For Group_A, schedule an event that recurs throughout the entire span of dates. 
• For Group_B, schedule the one-time event. 

Then complete these steps: 
1. When the one-time event should begin, move your DMPs from Group_A to Group_B. 
2. When the one-time event should end, move your DMPs back to Group_A, and then select Schedules > Play Now. 
3. In the DMP Groups object selector, click the Group_A name to see its member DMPs in the untitled table. 
4. In the untitled table, Ctrl-click each DMP that should start again to show the recurring presentation. 
5. Choose Select an Event Type > Digital Signage and then click Select Digital Signage. 
6. Click the presentation name and then click OK. 

Method 3 1. Schedule the recurring event to run every weekday, as you would expect, from 9:00 a.m. to 6:00 p.m. 
2. Use one-time scheduling to start an advanced task, such as the (Go to) URL task if the event is a live video stream, at 9:05 a.m, so that it interrupts the 
recurring event instead of conflicting with its start time, and then schedule this one-time event to stop at 6:00 p.m. 

In this method, the one-time event cannot be a presentation; it must be an advanced task. The recurring task will begin again, as expected, the next day. 

 
Using Deployment Reports 
You can view, configure, and export "proof-of-play" reports for the presentations and tasks that you have deployed in your digital signage network. 
Procedure 

Step 1 Choose Schedules > Reports. 

Step 2 Check the check boxes for the relevant DMP groups. 

Step 3 Enter date range values in the From field and the To field. 

Step 4 From the Report Type list, select the report type. 

Step 5 Click Go. 

Using Administrative Options 
This section contains these topics: 

• Configuring User Rights and Permissions for Digital Signage and Enterprise TV 

• Limiting User Permissions 

• Configuring DMM-DSM Server Settings 

• Configuring the Settings to Use ACNS or WAAS 

• Configuring the Settings to Deploy to External Servers 

Configuring User Rights and Permissions for Digital Signage and Enterprise TV 
In DMM-DSM, you can manage access rights and permission levels for administrators and members of the Digital Signage user group that is managed at a higher level in DMS-Admin. The rights and permissions that you 
manage in DMM-DSM are ones that pertain to digital signage and Enterprise TV. 

Tip To understand the high-level concepts and workflow for managing user accounts, access rights, and permission levels, see Understanding User Management Concepts and Workflow, page 2-6. 

Before You Begin 
To see and use the Settings tab, you must be logged in an administrator. 
Procedure 

Step 1 Choose Settings > User Accounts, and then choose the options that meet your requirements. 

Step 2 Click Submit. 

Related Topics 
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• Table 3-32 

Table 3-32 Elements for Configuring DMM-DSM User Accounts  

Element Description 
 
Users List 

Choose an account whose digital signage or Enterprise TV access rights and permission levels you will edit. When you click a username, DMM-DSM automatically shows the 
Change User pane for the corresponding user account. 

 
Change User pane 

A worksheet where you edit attributes of the selected user account. 

Name A unique username. The name is unique in the sense that you have not used it as the name for any other user account that you created in DMM-DSM. You 
must enter the username. 

Description Optional, brief description of the user account and its purpose. 

Password | 
Repeat 

The password for the user account. You must enter a password, and then reenter it. 

Administrator The check box to check if this account belongs to an administrator. When a user account belongs to an administrator, the corresponding user is granted full 
permissions to create, read, write, and delete every object type without limitation. 
Otherwise, uncheck this check box. After you uncheck it, you must manually change the permissions for each user role and each object type that pertain to 
this user account. 
Because we recommend that you follow a best practice in which you create only a few users, this check box is checked by default each time that you add a 
user account. 

Role The list of user role types. Each type of role is associated with some of the features in DMM-DSM. Choose a role to see or change the corresponding 
permissions for the user whose account you are adding or editing. 
After you choose a role, you can set the permissions to create, read, write, and delete objects that are relevant to that role. Depending on the role that you 
choose, an object might be a registered DMP, a registered FTP server, a category in your digital media library, an application that you configured, or the 
target device (DMP or FTP server) to receive a scheduled deployment. 

• DMP Manager — A user with permissions to manage every DMP in your digital signage network, only the DMPs within particular DMP groups 
that you specify, or no DMPs whatsoever. 
• Content Manager — A user with permissions to manage every category in your media library, only the particular categories that you specify, 
or none of the categories. 
• Application Manager —  A user with permissions to work with every application type, only the particular application types that you specify, 
or no applications of any kind. 
• Publisher Manager — A user with permissions to schedule media deployments to all of your registered DMPs and external (FTP) 
deployment servers, only the particular DMPs and FTP servers that you specify, or none of the registered DMPs or FTP servers. 

 
untitled table 

Rows in the untitled table describe user account permissions. 

Objects Contains the Create, Read, Write, and Delete buttons. To see or edit any one of these types of permissions as it applies to the specified user, you must first 
click the corresponding button. If you uncheck both the All check box and the Selected check box in the column under a button, DMM-DSM automatically 
shows the words "No permissions" in red, to signify that the user does not have any permissions of that type in relation to the objects that are relevant to the 
role that you selected from the Role list. 

All Contains the check box that you select to assign global permissions to the user, so that he or she can always create, see, edit, and delete objects that pertain 
to whichever user role you selected from the Role list. 
Click the relevant button, and then check the corresponding check box in the All row. 

Selected Contains the check box that you select to assign limited permissions to the user, so that he or she can create, see, edit, and delete only a subset of the 
objects that pertain to the user role that you selected from the Role list. 
Click the relevant button, select the corresponding check box in the Selected row, and then choose the subset where the user permissions should apply. 
Depending on the object type, you might choose the subset by clicking its name in an object selector or clicking its name in a table; DMM-DSM automatically 
shows either an object selector or a table from which to choose the subset. 
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Limiting User Permissions 
You can restrict the permissions that you grant to particular user accounts in DMM-DSM. For example, you might grant a user the permission to use only the advanced tasks that you choose or to deploy presentations to only 
the DMPs that you choose. 
The list of "applications" that this section describes includes two applications (called "Enterprise TV" and "Enterprise TV VoD") in addition to the full list of advanced tasks. Each Enterprise TV user must have at least read-only 
permission to the "Enterprise TV" application, which pertains to the electronic program guide. 

Tip To understand the high-level concepts and workflow for managing user accounts, access rights, and permission levels, see Understanding User Management Concepts and Workflow, page 2-6. 

Before You Begin 
To see and use the Settings tab, you must be logged in an administrator. 
Procedure 

Step 1 Choose Settings > User Accounts. 

Step 2 In the Users list, click a username to highlight it. DMM-DSM automatically shows the Change User pane for the corresponding user account, where you can edit the permissions that apply to the user. 

Step 3 Choose options to limit any or all of the permissions that you will grant to the user. 

If you do not understand your options, see Table 3-32 or consider the examples in these scenarios: 

• Scenario 1: User Who Can Work with Assets for Signage or Enterprise TV but Cannot Schedule Time Slots 

• Scenario 2: User Who Can Administer One DMP Group but Cannot Manage Assets 

• Scenario 3: User Who Can Administer One DMP Group, Manage Assets, and Schedule Time Slots 

• Scenario 4: User Who Can Schedule Time Slots for One DMP Group But Has No Other Rights 

By limiting permissions in specific ways, similar to the ways that these examples demonstrate, you can assign highly specialized combinations of access to any DMM-DSM user. The examples in these scenarios describe some 
of the commonest types of limited permissions that you might want to assign and tell you how to assign them. 

Step 4 After you have selected the options to meet your requirements, click Submit. 

Scenario 1: User Who Can Work with Assets for Signage or Enterprise TV but Cannot Schedule Time Slots 
To restrict user permissions as they should be restricted in this scenario, you would do the following. 

1. From the Role list, select DMP Manager, check the All check box in the Read column, and then uncheck every check box in the Create, Write, and Delete columns. 
2. From the Role list, select Content Manager, and then check the All check box in the Create, Read, Write, and Delete columns. 
3. From the Role list, select Application Manager, and then check the Selected check box in the Create, Read, Write, and Delete columns. Next, do all of the following: 
• Click Create, and then — in the table that associates permissions with applications — check only these check boxes: Digital Media Designer, Enterprise TV, Enterprise TV VoD, and 
(Go to) URL. 

• Click Read, and then — in the table that associates permissions with applications — check only these check boxes: Digital Media Designer, Enterprise TV, Enterprise TV VoD, and 
(Go to) URL. 

• Click Write, and then — in the table that associates permissions with applications — c heck only these check boxes: Digital Media Designer, Enterprise TV, Enterprise TV VoD, and 
(Go to) URL. 

• Click Delete, and then — in the table that associates permissions with applications — check only these check boxes: Digital Media Designer, Enterprise TV, Enterprise TV VoD, and 
(Go to) URL. 

4. From the Role list, select Publisher Manager, check the All check box in the Read column, and then uncheck every check box in the Create, Read, Write, and Delete columns. 
5. Click Submit. 

Scenario 2: User Who Can Administer One DMP Group but Cannot Manage Assets 
To restrict user permissions as they should be restricted in this scenario, you would do the following. 

1. From the Role list, select DMP Manager, and then check the Selected check box in the Create, Read, Write, and Delete columns. Next, do all of the following: 
• Click Create. Then, in the object selector, click a DMP group to highlight it. 

• Click Read. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 
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• Click Write. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

• Click Delete. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

2. From the Role list, select Content Manager, and then uncheck every check box in the Create, Read, Write, and Delete columns. 
3. From the Role list, select Application Manager, and then — in the table that associates permissions with applications — check only these check boxes: DMP Discovery, DMP Video/
Audio Settings, System Tasks, DMP Firmware Upgrade. 
4. From the Role list, select Publisher Manager, and then check the Selected check box in the Create, Read, Write, and Delete columns. Next, do all of the following: 
• Click Create. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

• Click Read. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

• Click Write. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

• Click Delete. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

5. Click Submit. 

Scenario 3: User Who Can Administer One DMP Group, Manage Assets, and Schedule Time Slots 
To restrict user permissions as they should be restricted in this scenario, you would do the following. 

1. From the Role list, select DMP Manager, and then check the Selected check box in the Create, Read, Write, and Delete columns. Next, do all of the following: 
• Click Create. Then, in the object selector, click a DMP group to highlight it. 

• Click Read. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

• Click Write. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

• Click Delete. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

2. From the Role list, select Content Manager, and then select the All check box in the Create, Read, Write, and Delete columns. 
3. From the Role list, select Application Manager, and then — in the table that associates permissions with applications — check every check box. 
4. From the Role list, select Publisher Manager, and then check the Selected check box in the Create, Read, Write, and Delete columns. Next, do all of the following: 
• Click Create. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

• Click Read. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

• Click Write. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

• Click Delete. Then, in the object selector, click and highlight the same DMP group that you highlighted for the DMP Manager role. 

5. Click Submit. 

Scenario 4: User Who Can Schedule Time Slots for One DMP Group But Has No Other Rights 
To restrict user permissions as they should be restricted in this scenario, you would do the following. 

1. From the Role list, select DMP Manager, check the All check box in the Read column, and then uncheck every check box in the Create, Write, and Delete columns. 
2. From the Role list, select Content Manager, and then uncheck every check box in the Create, Read, Write, and Delete columns. 
3. From the Role list, select Application Manager, check the All check box in the Read column, and then uncheck every check box in the Create, Write, and Delete columns. 
4. From the Role list, select Publisher Manager, and then check the Selected check box in the Create, Read, Write, and Delete columns. Next, do all of the following: 
• Click Create. Then, in the object selector, click a DMP group to highlight it. 

• Click Read. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

• Click Write. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

• Click Delete. Then, in the object selector, click and highlight the same DMP group that you highlighted for Create permissions. 

5. Click Submit. 

Configuring DMM-DSM Server Settings 
You must configure DMM-DSM to use the correct Java servlet server and to use one, consistent username and password for administrative access to all of the DMPs that you will manage centrally. 
Before You Begin 
To see and use the Settings tab, you must be logged in an administrator. 
Procedure 
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Step 1 Choose Settings > Server Settings. 

Step 2 In the Servlet Server Address field, enter the routable IP address or resolvable DNS hostname for your DMM appliance. It will not be updated automatically if you use AAI to change the IP address of your 
DMM appliance. 

Step 3 In the DMP User Name field, enter the one administrative username that you have configured all of your DMPs to share. 

Step 4 In the DMP User Password field, enter the one administrative password that you have configured all of your DMPs to share. 

Step 5 Click Save. 

Configuring the Settings to Use ACNS or WAAS 
You can configure DMM-DSM to use the content-distribution features of ACNS or WAAS. 

Caution Never delete an ACNS channel that Cisco DMS uses. If you do, you will not be able to see, select, edit, or delete in your schedule any events that use the deleted channel. Failover (content substitution) 
occurs on your DMPs when scheduled events call upon missing assets. Before you delete any ACNS channel, be sure that you have deleted from your schedule all events that will be disrupted otherwise. 

Before You Begin 
To see and use the Settings tab, you must be logged in an administrator. 
Procedure 

Step 1 Choose Settings > Media Delivery, and then choose the options that meet your requirements. 

Step 2 Click Save. 

Related Topics 
• UI Reference: Elements for Defining ACNS or WAAS Settings 

UI Reference: Elements for Defining ACNS or WAAS Settings 

Table 3-33 Elements for Using ACNS  

Element Description 

Would you like to configure settings for ACNS or WAAS at this 
time? 

Either Yes or No. 
• Yes — You will use either ACNS or WAAS as your content distribution methods. 
• No — You will not use either of these methods. 

 
ACNS 

CDM Address The routable IP address or resolvable DNS hostname of the appliance or services module ("blade") that 
runs ACNS and Content Distribution Manager software. 

Port The TCP port for login access to CDM. The port number by default is 8443. 

User The username for login access to CDM. 

Password The password that corresponds to the CDM username that you entered. 

 
WAAS 

User The username for mounting the CIFS share. 

Password The password for mounting the CIFS share. 

Share The name of the CIFS share. 

Hostname or IP address The hostname or IP address of the CIFS share server. 

 
Related Topics 
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• Configuring the Settings to Use ACNS or WAAS 

Configuring the Settings to Deploy to External Servers 
You can configure DMM-DSM to deploy to external servers, but only within these operating parameters: 

• The only supported server type is FTP in this release. 
• You cannot use the Schedules > Play Now feature with external deployment servers. 
• All deployments to your external deployment servers require that you use the Schedules > Play in Future feature. 

Before You Begin 
To see and use the Settings tab, you must be logged in an administrator. 
Procedure 

Step 1 Choose Settings > External Deployment Locations, and then choose options to meet your requirements. 

Step 2 Click Save. 

UI Reference: Elements for Configuring External Deployments 

Table 3-34 Elements to Configure Deployments to External Servers  

Element Icon and Description 
 
External Publishing Server List 

Add, select, edit, or delete external deployment (FTP) servers. Click a server to highlight it, so that you can edit or delete it. DMM-DSM automatically shows the Change External 
Publishing Server pane for the corresponding server, where you can edit its settings. 

Add New External Publishing Server 
 

Shows the Add New External Publishing Server pane, where you can 
define the settings to use a new server. 

Delete External Publishing Server 

 

Deletes the server that you highlighted. 

 
{Add New | Change} External Publishing Server 

Add or edit attributes of the external servers that you use for deployments. Each of your external publishing servers most run the necessary services to function both as an http 
server and as an ftp server. In addition, the root-level directory for ftp must be equal to or under the root-level directory for http. For example, you might use /wwwroot for http and /
wwwroot/ftproot for ftp. 

Host The routable IP address or resolvable DNS hostname of the external deployment (FTP) server. 
You must enter this value. 

Port The port number to use. You can use any port number, but the default is 21. 

Server Type FTP. 

Remote Directory Corresponding to the same server directory structure that you reference when you enter an 
HTTP Mapping value (see the row below this one), enter the root-level deployment directory to 
use on your external publishing server when your communications protocol is ftp. For example, 
you might enter only a forward slash (/). 

HTTP Mapping Corresponding to the same server directory structure that you reference when you enter a 
Remote Directory value (see the row above this one), enter the root-level deployment directory 
to use on your external publishing server when your communications protocol is http. For 
example, you might enter /ftproot. 

HTTP Port Enter the port number to use on the external deployment server. You can use any port number. 
If you do not enter a port number, the default is to use port 80. 
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User Name Enter the FTP username. It is acceptable to use the name anonymous. 

Password | Confirm Password You must enter the FTP password, and then reenter it. 

 
Common Scenarios for Using DMM-DSM 
This section describes common scenarios for using DMM-DSM. 

• Uploading Files to a DMP for Local Storage and Immediate Deployment 

Uploading Files to a DMP for Local Storage and Immediate Deployment 
You can create a presentation that shows video files from a playlist, and then transfer the presentation and its assets to the local Secure Digital (SD) flash memory card in a DMP for playback on its attached DMP display. 

Note • The total amount of available file space for local storage is: 
– 0.9 GB (900 MB) on a DMP 4300G. 
– 1.9 GB on a DMP 4305G. 
– 3.8 GB on a DMP 4400G. 

Consider these SD memory card capacities carefully when you make designs for use during stage-one failover. The combined file size for all assets in such designs cannot exceed the storage capacity of the SD card. To 
check the free space on the SD memory card in a DMP, log in to its local instance of DMPDM, and then click Internal Storage. To understand failover, see the "Understanding Content Substitution (Failover)" topic in 
User Guide for Cisco Digital Media Player Device Manager 5.1.x on Cisco.com. 
• A presentation cannot play any file with a file size greater than 1.9 GB on a DMP, regardless of its model type. This size is constrained by the limits of streaming. 

Before You Begin 
To learn how to create a playlist in Digital Media Designer, so that you can show the playlist as part of a presentation, see Creating and Organizing Presentation Playlists. 

Procedure 

Step 1 To create an advanced task that will transfer the assets for your playlist anywhere in your digital signage network, choose Digital Media Players > Advanced Tasks > File Transfer 
to DMP or Server, and then do the following: 

a. Click  Add New Application, and then enter a name for the new file transfer task in the Name field; for example, you might enter the name LocalPublishing. 

You must enter a name. The name is unique in the sense that you have not used it previously as the name for anything that can be scheduled. 
b. In the Applications list, click Presentation or Playlist. 

c. In the Available Content table, click a row to highlight the presentation, and then click  Select Applications. Doing this moves the highlighted presentation to the Selected Content table, so that its 
assets become available for deployment. 

d. To save your work, click Submit. 

Step 2 To deploy the file transfer task to a DMP or DMP group, select Schedules > Play Now, and then do the following: 

a. From the DMP Groups object selector, select the DMP or DMP group that should receive the deployment. 

b. From the Actions list, select the name of the advanced task that you configured and saved for this file transfer operation, and then click Go. 

DMM-DSM deploys the assets and commands immediately to the DMPs that you selected, and the targeted DMPs restart automatically. 

Note • After they restart, your DMPs will not show the newly received presentation automatically on their attached DMP displays. The presentation will not play unless stage-one failover occurs or until you deploy 
the (Go to) URL task that DMM-DSM generated automatically when you deployed assets to the SD memory card. 
• After you create and deploy any "File Transfer to DMP or Server" task to save the assets from a DMD presentation to the SD memory card inside a DMP, DMM-DSM automatically creates a (Go to) URL task.  
 
The name by default for the (Go to) URL task is "LOCAL - <name_of_presentation>" unless you checked the Emergency/Alarm check box, in which case it is "ALARM - <name_of_presentation>." 
 
If any of your DMPs should show the presentation at any time other than during stage-one failover, you must deploy the corresponding (Go to) URL task to those DMPs. See Scheduling Time Slots for Media and Events on 
DMPs. 

• After you delete a presentation for which DMM-DSM automatically generated a corresponding (Go to) URL task, you must also delete that (Go to) URL task. 
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Integrating Third-party Applications with DMM-DSM 
Cisco Digital Signage is an open and standards-based platform, and Cisco DMS ecosystem business partners and technology development partners are building new methods to extend what your DMPs can do. Contact a 
Cisco sales representative to learn more about potential new uses for your DMPs, such as: 

• Smart signage: 
– Way-finding signs that use RFID. 
– Audience-measuring signs that use video analytics for gaze recognition. 

• Conference room management. 
• Line queuing. 
• Representing dynamic data in real time, such as international currency rates. 
• Regional call center signs that correlate real-time caller statistics with service level targets globally. 
• Environmentally protected outdoor signage. 
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